[PATCH] gnu: Add r-dropletutils.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 2 years ago
(address . guix-patches@gnu.org)
20230511163016.19814-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-dropletutils): New variable.
---
gnu/packages/bioconductor.scm | 44 +++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index cb441655eb..b54585e97f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4897,6 +4897,50 @@ (define-public r-drimseq
results.")
(license license:gpl3+)))
+(define-public r-dropletutils
+ (package
+ (name "r-dropletutils")
+ (version "1.20.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DropletUtils" version))
+ (sha256
+ (base32 "09xwfb4ihpsp465vb1zbcwm6ww6qi3spn9d8p4i1gczyc0p9pf1y"))))
+ (properties `((upstream-name . "DropletUtils")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-beachmat
+ r-bh
+ r-biocgenerics
+ r-biocparallel
+ r-delayedarray
+ r-delayedmatrixstats
+ r-dqrng
+ r-edger
+ r-genomicranges
+ r-hdf5array
+ r-iranges
+ r-matrix
+ r-r-utils
+ r-rcpp
+ r-rhdf5
+ r-rhdf5lib
+ r-s4vectors
+ r-scuttle
+ r-singlecellexperiment
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/DropletUtils")
+ (synopsis "Utilities for handling single-cell droplet data")
+ (description
+ "This package provides a number of utility functions for handling
+single-cell (RNA-seq) data from droplet technologies such as 10X Genomics.
+This includes data loading from count matrices or molecule information files,
+identification of cells from empty droplets, removal of barcode-swapped pseudo-
+cells, and downsampling of the count matrix.")
+ (license license:gpl3)))
+
(define-public r-dss
(package
(name "r-dss")

base-commit: e2eb43f945fd467e9b55a4b3c91cd186cf32e268
--
2.39.2
Ricardo Wurmus wrote 2 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 63447-done@debbugs.gnu.org)
87o7mqt2zq.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-dropletutils): New variable.

Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63447@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63447
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help