gnu: Add r-ggpattern and r-gridpattern.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
dcac3f190fc84a8783848dd4de7668e8@mdc-berlin.de
* gnu/packages/cran.scm (r-ggpattern): New variable.

* gnu/packages/cran.scm (r-gridpattern): New variable.
Attachment: file
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 1/2] gnu: Add r-gridpattern.
(address . 63446@debbugs.gnu.org)
20230511160412.18081-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-gridpattern): New variable.
---
gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6920dbe13a..d8bf51654c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17853,6 +17853,35 @@ (define-public r-tractor-base
handling.")
(license license:gpl2)))
+(define-public r-gridpattern
+ (package
+ (name "r-gridpattern")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gridpattern" version))
+ (sha256
+ (base32 "13yypjsbpr61yn15y4cyz6s8jvcgg3mmr8rncskinpk8lsa8h2h4"))))
+ (properties `((upstream-name . "gridpattern")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-glue
+ r-memoise
+ r-png
+ r-rlang
+ r-sf))
+ (native-inputs (list r-knitr r-rmarkdown))
+ (home-page "https://trevorldavis.com/R/gridpattern/")
+ (synopsis "Grid pattern grobs")
+ (description
+ "This package provides grid grobs that fill in a user-defined area with
+various patterns. Includes enhanced versions of the geometric and image-based
+patterns originally contained in the ggpattern package as well as original pch,
+polygon_tiling, regular_polygon, rose, text, wave, and weave patterns plus
+support for custom user-defined patterns.")
+ (license license:expat)))
+
(define-public r-gridsvg
(package
(name "r-gridsvg")

base-commit: e2eb43f945fd467e9b55a4b3c91cd186cf32e268
--
2.39.2
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 2/2] gnu: Add r-ggpattern.
(address . 63446@debbugs.gnu.org)
20230511160412.18081-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-ggpattern): New variable.
---
gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d8bf51654c..a5292fec57 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20191,6 +20191,36 @@ (define-public r-ggextra
marginal histograms/boxplots/density plots to ggplot2 scatterplots.")
(license license:expat)))
+(define-public r-ggpattern
+ (package
+ (name "r-ggpattern")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggpattern" version))
+ (sha256
+ (base32 "1b9bfxlg64gr39bz58fp6jmg4nziwk8rk94rzpjsqhfhpwi2lrgr"))))
+ (properties `((upstream-name . "ggpattern")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ggplot2
+ r-glue
+ r-gridpattern
+ r-rlang
+ r-scales))
+ (native-inputs (list r-knitr r-ragg r-rmarkdown))
+ (home-page "https://github.com/coolbutuseless/ggpattern")
+ (synopsis "Ggplot2 pattern geoms")
+ (description
+ "This package provides ggplot2 geoms filled with various patterns. Includes
+a patterned version of every ggplot2 geom that has a region that can be filled
+with a pattern. Provides a suite of ggplot2 aesthetics and scales for
+controlling pattern appearances. Supports over a dozen builtin patterns (every
+pattern implemented by gridpattern) as well as allowing custom user-defined
+patterns.")
+ (license license:expat)))
+
(define-public r-minpack-lm
(package
(name "r-minpack-lm")
--
2.39.2
Ricardo Wurmus wrote 2 years ago
Re: [bug#63446] [PATCH 1/2] gnu: Add r-gridpattern.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 63446-done@debbugs.gnu.org)
87sfc2t3sy.fsf@elephly.net
I applied both with changes to the description.
Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63446@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63446
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help