Some python-pyelftools test failed

  • Open
  • quality assurance status badge
Details
2 participants
  • c4droid
  • Peter Polidoro
Owner
unassigned
Submitted by
c4droid
Severity
normal
C
C
c4droid wrote on 11 May 2023 10:11
(address . bug-guix@gnu.org)
tencent_BCF0C6F50ED2F00A013DA78350D1362BD006@qq.com
Hi, Guix!

I'm packaging some python package depend python-pyelftools, I noticed python-pyelftools some test
failed, detail for build log:

```
...
starting phase `check'
...........................................................................................
----------------------------------------------------------------------
Ran 91 tests in 3.508s

OK
Example './examples/dwarf_decode_address.py'
Example './examples/dwarf_die_tree.py'
Example './examples/dwarf_lineprogram_filenames.py'
Example './examples/dwarf_location_info.py'
Example './examples/dwarf_pubnames_types.py'
Example './examples/dwarf_range_lists.py'
Example './examples/elf_low_high_api.py'
Example './examples/elf_notes.py'
Example './examples/elf_relocations.py'
Example './examples/elf_show_debug_sections.py'
Example './examples/elfclass_address_size.py'
Example './examples/examine_dwarf_info.py'

Conclusion: SUCCESS
Test file 'test/testfiles_for_readelf/aarch64-relocs-le.o.elf'
Test file 'test/testfiles_for_readelf/angr-eh_frame.elf'
Test file 'test/testfiles_for_readelf/core_simple64.elf'
Test file 'test/testfiles_for_readelf/dt_flags.elf'
Test file 'test/testfiles_for_readelf/dwarf_gnuops4.so.elf'
.......................FAIL
....for option "--debug-dump=decodedline"
....Output #1 is readelf, Output #2 is pyelftools
@@ Mismatch on line #1:
Toggle quote (2 lines)
>>pascal.cpp:<<
>>cu: e:\seva\projects\anyarxi_3.43.5\libyarxi\src\main\jni/pascal.cpp:<<
([('insert', 0, 0, 0, 58), ('equal', 0, 11, 58, 69)])
@@ Output #1 dumped to file: /tmp/guix-build-python-pyelftools-0.28.drv-0/out1_gu9j_ocd.stdout
@@ Output #2 dumped to file: /tmp/guix-build-python-pyelftools-0.28.drv-0/out2_xeuf7h64.stdout

Conclusion: FAIL
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("test/run_readelf_tests.py") exit-status: 1 term-signal: #f stop-signal: #f>
phase `check' failed after 31.4 seconds
command "python" "test/run_readelf_tests.py" failed with status 1
...
```
P
P
Peter Polidoro wrote on 25 May 2023 15:42
(address . 63440@debbugs.gnu.org)
87pm6oh6eo.fsf@polidoro.io
I am also running into the same issue. I am trying to package
python-platformio, but python-pyelftools fails its check phase so
it cannot be used as a dependency.
?