[PATCH] gnu: python-pytest-httpx: Update to 0.22.0, fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Vinicius Monego
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
64e11d462a73b70f58cfeeaf4436249ca192d032.1683758992.git.sharlatanus@gmail.com
* gnu/packages/python-check.scm (python-pytest-httpx): Update to 0.22.0,
fix build.
[build-system]: Use pyproject-build-system.
[arguments]: Remove as no longer required.
---
gnu/packages/python-check.scm | 14 +++-----------
1 file changed, 3 insertions(+), 11 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f272a252fc..6c5f45d4b5 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2530,7 +2530,7 @@ (define-public python-pytest-parawtf
(define-public python-pytest-httpx
(package
(name "python-pytest-httpx")
- (version "0.21.0")
+ (version "0.22.0")
(source
(origin
;; pypi package doesn't include the tests
@@ -2540,16 +2540,8 @@ (define-public python-pytest-httpx
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "12mcy1f5d5cq3rqrqgi2ar0qvzw62ibys17hw6dsdfd0j2syck4r"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (setenv "PYTHONPATH" (getcwd))
- (invoke "pytest" "-vv")))))))
+ (base32 "1ncpd74hmsz4sadvjg99fnfscxpgh3mc2siini0dhxzwgwdkk5i7"))))
+ (build-system pyproject-build-system)
(propagated-inputs (list python-httpx))
(native-inputs (list python-pytest python-pytest-asyncio))
(home-page "https://colin-b.github.io/pytest_httpx/")

base-commit: b4e5844700b2304bfde451322feb5797bf0c6179
--
2.39.2
Sharlatan Hellseher wrote 2 years ago
efraim@flashner.co.il
(address . 63431@debbugs.gnu.org)
CAO+9K5r_9vznGe6e4OTczgv7eN_3kAmapOCefKCVQt_6zRtSuw@mail.gmail.com
Hi,
A gentle ping, as it may solve build issues with 4 packages one of
them python-synpy, which I'd like to update to the latest version.
Thanks,
Oleg
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Vinicius Monego wrote 2 years ago
[PATCH] gnu: python-pytest-httpx: Update to 0.22.0, fix build.
(address . 63431-done@debbugs.gnu.org)
b53a3fab-94c7-29e3-2818-9cc8f934fc1a@posteo.net
Hi,

Toggle quote (3 lines)
> * gnu/packages/python-check.scm (python-pytest-httpx): Update to 0.22.0,
> fix build.

I tweaked the commit message a little and pushed the patch. Thanks.

Vinicius
Attachment: file
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63431@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63431
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help