[PATCH 0/4]: gnu: python-can: Update to 4.2.0, fix build.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Maxim Cournoyer
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 11 May 2023 00:11
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
cover.1683756318.git.sharlatanus@gmail.com
Hi Guix!

This patch set updates python-can to the latest version and includes some other
optional patches such as simplification of the package style and sorting of
use-module section alphabetically.

As current build is failing it's blocking to add python-gallia - Extendable
Pentesting Framework.

Sharlatan Hellseher (4):
gnu: python-can: Update to 4.2.0, fix build.
gnu: python-can: Simplify package style.
gnu: Delete duplicated use-module from (gnu package python-xyz).
gnu: Sort use-module alphabetically in (gnu packages python-xyz).

gnu/packages/python-xyz.scm | 85 +++++++++++++++----------------------
1 file changed, 34 insertions(+), 51 deletions(-)


base-commit: e118b92cfe7a598b71dbbda2622b7551f4a72104
--
2.39.2
S
S
Sharlatan Hellseher wrote on 11 May 2023 00:12
[PATCH 1/4] gnu: python-can: Update to 4.2.0, fix build.
(address . 63429@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
8d407dc301a02d568fdfaf9d0d16f59e1ad32429.1683756318.git.sharlatanus@gmail.com
* gnu/packages/python-xyz.scm (python-can): Update to 4.2.0, fix build.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1417031788..c67dae29a1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2548,14 +2548,14 @@ (define-public python-aenum
(define-public python-can
(package
(name "python-can")
- (version "4.0.0")
+ (version "4.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-can" version))
(sha256
(base32
- "0pcbdgdw94lc2sxd56w6wdsshrs9dd5d3wp0x4sfd0drzx32inar"))))
+ "1w5sdzxivpd3pw4pypwnjlksvfimdb93qnlddbrh5f13flhsgg8g"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
--
2.39.2
S
S
Sharlatan Hellseher wrote on 11 May 2023 00:12
[PATCH 3/4] gnu: Delete duplicated use-module from (gnu package python-xyz).
(address . 63429@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
b7214f038aca1a1cf33e10b96e18370622649ff6.1683756318.git.sharlatanus@gmail.com
* gnu/packages/python-xyz.scm: Delete duplicated (gnu packages serialization).
---
gnu/packages/python-xyz.scm | 1 -
1 file changed, 1 deletion(-)

Toggle diff (14 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c22a1aad77..394aeb8d7f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -259,7 +259,6 @@ (define-module (gnu packages python-xyz)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages tcl)
#:use-module (gnu packages bdw-gc)
- #:use-module (gnu packages serialization)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
--
2.39.2
S
S
Sharlatan Hellseher wrote on 11 May 2023 00:12
[PATCH 2/4] gnu: python-can: Simplify package style.
(address . 63429@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
1df36bb06bf3fa14062dc3da5fd2d3942b837f6b.1683756318.git.sharlatanus@gmail.com
* gnu/package/python-xyz.scm (python-can): Simplify package style.
[build-system]: Use pyproject-build-system.
[argument]: Use Gexp. Remove redundant modify-phases procedure. Add
{test-flags}.
---
gnu/packages/python-xyz.scm | 44 ++++++++++++-------------------------
1 file changed, 14 insertions(+), 30 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c67dae29a1..c22a1aad77 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2556,40 +2556,24 @@ (define-public python-can
(sha256
(base32
"1w5sdzxivpd3pw4pypwnjlksvfimdb93qnlddbrh5f13flhsgg8g"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'relax-version-requirements
- (lambda _
- (substitute* "setup.py"
- (("mock~=2\\.0") "mock")
- (("coverage<5") "coverage")
- (("pytest~=4\\.6") "pytest")
- (("pytest-timeout~=1\\.3") "pytest-timeout")
- (("pytest-cov.*") "pytest-cov\n")
- (("hypothesis~=4\\.56") "hypothesis"))))
- (add-after 'unpack 'fix-broken-tests
- ;; The tests try to run two scripts it expects should be
- ;; in PATH, but they aren't at this time (see:
- ;; https://github.com/hardbyte/python-can/issues/805).
- (lambda _
- (substitute* "test/test_scripts.py"
- (("\"can_logger\\.py --help\"") "")
- (("\"can_player\\.py --help\"") ""))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "test"
- ;; Disable tests which require specific CAN
- ;; drivers we have no package for in Guix.
- "--ignore" "test/test_interface_canalystii.py"
- ;; These tests fail with "OSError: [Errno 19]
- ;; No such device".
- "-k" "not BasicTestUdpMulticastBusIPv")))))))
+ (list
+ #:test-flags
+ #~(list
+ ;; TODO: Check if it could be packed:
+ ;; https://github.com/projectgus/python-canalystii
+ ;;
+ ;; Disable tests which require specific CAN drivers we have no
+ ;; package for in Guix.
+ "--ignore" "test/test_interface_canalystii.py"
+ ;; These tests fail with "OSError: [Errno 19] No such device".
+ "-k" (string-append "not BasicTestUdpMulticastBusIPv"))))
(propagated-inputs
(list python-msgpack python-typing-extensions python-wrapt))
(native-inputs
- (list python-codecov
+ (list ;; python-canalystii ; Not packed yet
+ python-codecov
python-coverage
python-future
python-hypothesis
--
2.39.2
S
S
Sharlatan Hellseher wrote on 11 May 2023 00:12
[PATCH 4/4] gnu: Sort use-module alphabetically in (gnu packages python-xyz).
(address . 63429@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
26e2dcd16e28f90b8474f205282287e154ee8243.1683756318.git.sharlatanus@gmail.com
* gnu/packages/python-xyz.scm: Sort use-module alphabetically to ease
maintenance.
---
gnu/packages/python-xyz.scm | 36 ++++++++++++++++++------------------
1 file changed, 18 insertions(+), 18 deletions(-)

Toggle diff (115 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 394aeb8d7f..df5a6e35cc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -156,12 +156,14 @@
(define-module (gnu packages python-xyz)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
- #:use-module (gnu packages algebra)
#:use-module (gnu packages adns)
#:use-module (gnu packages aidc)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages attr)
#:use-module (gnu packages backup)
+ #:use-module (gnu packages base)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages bdw-gc)
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
@@ -176,28 +178,28 @@ (define-module (gnu packages python-xyz)
#:use-module (gnu packages documentation)
#:use-module (gnu packages enchant)
#:use-module (gnu packages file)
- #:use-module (gnu packages fontutils)
#:use-module (gnu packages fonts)
+ #:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
- #:use-module (gnu packages gdb)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages gdb)
#:use-module (gnu packages geo)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
- #:use-module (gnu packages graphviz)
#:use-module (gnu packages graphics)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages gsasl)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages icu4c)
- #:use-module (gnu packages inkscape)
#:use-module (gnu packages image)
#:use-module (gnu packages image-processing)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages inkscape)
#:use-module (gnu packages java)
#:use-module (gnu packages jupyter)
#:use-module (gnu packages kerberos)
@@ -213,10 +215,10 @@ (define-module (gnu packages python-xyz)
#:use-module (gnu packages maths)
#:use-module (gnu packages monitoring)
#:use-module (gnu packages multiprecision)
- #:use-module (gnu packages networking)
#:use-module (gnu packages ncurses)
- #:use-module (gnu packages node)
+ #:use-module (gnu packages networking)
#:use-module (gnu packages ninja)
+ #:use-module (gnu packages node)
#:use-module (gnu packages openstack)
#:use-module (gnu packages pcre)
#:use-module (gnu packages pdf)
@@ -235,14 +237,15 @@ (define-module (gnu packages python-xyz)
#:use-module (gnu packages rdf)
#:use-module (gnu packages readline)
#:use-module (gnu packages regex)
- #:use-module (gnu packages sdl)
#:use-module (gnu packages scanner)
+ #:use-module (gnu packages sdl)
#:use-module (gnu packages search)
#:use-module (gnu packages serialization)
#:use-module (gnu packages shells)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages ssh)
#:use-module (gnu packages swig)
+ #:use-module (gnu packages tcl)
#:use-module (gnu packages terminals)
#:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
@@ -253,22 +256,19 @@ (define-module (gnu packages python-xyz)
#:use-module (gnu packages video)
#:use-module (gnu packages web)
#:use-module (gnu packages wxwidgets)
- #:use-module (gnu packages base)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
- #:use-module (gnu packages xdisorg)
- #:use-module (gnu packages tcl)
- #:use-module (gnu packages bdw-gc)
- #:use-module (guix packages)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system pyproject)
+ #:use-module (guix build-system python)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix hg-download)
- #:use-module (guix gexp)
+ #:use-module (guix packages)
#:use-module (guix utils)
- #:use-module (guix build-system gnu)
- #:use-module (guix build-system cmake)
- #:use-module (guix build-system pyproject)
- #:use-module (guix build-system python)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
--
2.39.2
S
S
Sharlatan Hellseher wrote on 6 Jun 2023 21:50
(address . 63429@debbugs.gnu.org)
CAO+9K5pAp5Rfom3G1YytFfX0Y=9gqiNUvUvDdUnNZYNfthbUTg@mail.gmail.com
Hi Guix,

A gentle ping on this patch set,
Let me know if I need to modify it.

Solving build issue, allowing to pack Gallia (

Thanks,
Oleg
Attachment: file
E
E
Efraim Flashner wrote on 7 Jun 2023 08:54
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
ZIApnS6KAKPSvXo6@3900XT
Patches applied. I couldn't bring myself to split-up the download
imports with (guix gexp) so it's slightly out of order.

On Tue, Jun 06, 2023 at 09:50:49PM +0200, Sharlatan Hellseher wrote:
Toggle quote (11 lines)
> Hi Guix,
>
> A gentle ping on this patch set,
> Let me know if I need to modify it.
>
> Solving build issue, allowing to pack Gallia (
> https://pypi.org/project/gallia/)
>
> Thanks,
> Oleg

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmSAKZ0ACgkQQarn3Mo9
g1GDOg/+LL9XzLcAidFWcRP/yqPCtppaNgqqYL9WMZNu45nEbaJgJ2/T48ghzKDx
zku+cQRcr1loxE8/VedTDmggo/RyXSTbN/MDjn0OW1yWJYzCLGhatsVIscA/VXby
KjMBAQ3IMqXr56ESEiDPvHQd+8t/AHDJtQ0Yw+KLxCSgDvk0ekrSgR7r1IpPRGwn
+fruKI5vMZBVYWiel9esCd5Vud1ZpT4GHwSMCNcrrqnsQOiHJyZ8IYA63yX93Bg+
JQYKlt/Ybg+LL3wo+0TlcSXUMYy18tRBcmtcklZnT7ijXrtBIXCRAacn4QCLmN4+
/ENyyX2g+XU3YjXrh2A8KrDEEnVSs4Hlz7ct03vAB/hkQ2nMMMfLzDSB6i2wYTG2
lRprntpffV+izCksXK2IuzoRFO+oPW9tuVHhvn2A6xkss97wYgwCrV40DoMt3ovJ
UpCfqa1VTagg/6l2/3KMs0BEvaK9H+9/OtxM4K68gV0QErQkbRlyAZswJLojMPn6
4dJebcLfKF5qirdGc4vWyE+HtpjTg51W5SgYfn+pLjwzxgLYRPg8YdXrWVbmA+Et
kBezWu7SLUWQK4yGauojyB4MO+taa7p/+R9CjrcDfYT8CXU5L/pepA0t2ghrWsS/
3+jUxKWyzeJYZWxe+NHj7GeOxojvmvmljpVefFTWG48HQyB2JOc=
=w1XG
-----END PGP SIGNATURE-----


Closed
M
M
Maxim Cournoyer wrote on 7 Jun 2023 21:44
(name . Efraim Flashner)(address . efraim@flashner.co.il)
871qincb1j.fsf@gmail.com
Hello,

Efraim Flashner <efraim@flashner.co.il> writes:

Toggle quote (3 lines)
> Patches applied. I couldn't bring myself to split-up the download
> imports with (guix gexp) so it's slightly out of order.

Thank you!

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63429@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63429
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch