(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
Without that fix we have:
Configuring tasty-1.4.3...
Setup.hs: Encountered missing or private dependencies:
unbounded-delays >=0.1
* gnu/packages/haskell-check.scm(ghc-tasty)[inputs]: Add ghc-unbounded-delays
Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
gnu/packages/haskell-check.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Toggle diff (18 lines)
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 23727fc0b8..95c9521796 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -148,7 +148,8 @@ (define-public ghc-tasty
"006bf4gyc30i2gvb17hj1mzrh1kwnwf7l050x3f72wi6c2axl87l"))))
(build-system haskell-build-system)
(properties '((upstream-name . "tasty")))
- (inputs (list ghc-tagged ghc-optparse-applicative ghc-ansi-terminal))
+ (inputs (list ghc-unbounded-delays ghc-tagged ghc-optparse-applicative
+ ghc-ansi-terminal))
(home-page "https://github.com/UnkindPartition/tasty")
(synopsis "Modern and extensible testing framework")
(description
base-commit: e0c35d1578c10a8fe27c8372f3a8bb5dd88b01b8
--
2.39.2