[PATCH v1] gnu: ghc-tasty: Fix build for i686

  • Done
  • quality assurance status badge
Details
2 participants
  • Denis 'GNUtoo' Carikli
  • Lars-Dominik Braun
Owner
unassigned
Submitted by
Denis 'GNUtoo' Carikli
Severity
normal
D
D
Denis 'GNUtoo' Carikli wrote on 10 May 2023 19:18
(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
20230510171829.6497-1-GNUtoo@cyberdimension.org
Without that fix we have:
Configuring tasty-1.4.3...
Setup.hs: Encountered missing or private dependencies:
unbounded-delays >=0.1

* gnu/packages/haskell-check.scm(ghc-tasty)[inputs]: Add ghc-unbounded-delays

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
gnu/packages/haskell-check.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 23727fc0b8..95c9521796 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -148,7 +148,8 @@ (define-public ghc-tasty
"006bf4gyc30i2gvb17hj1mzrh1kwnwf7l050x3f72wi6c2axl87l"))))
(build-system haskell-build-system)
(properties '((upstream-name . "tasty")))
- (inputs (list ghc-tagged ghc-optparse-applicative ghc-ansi-terminal))
+ (inputs (list ghc-unbounded-delays ghc-tagged ghc-optparse-applicative
+ ghc-ansi-terminal))
(home-page "https://github.com/UnkindPartition/tasty")
(synopsis "Modern and extensible testing framework")
(description

base-commit: e0c35d1578c10a8fe27c8372f3a8bb5dd88b01b8
--
2.39.2
L
L
Lars-Dominik Braun wrote on 13 May 2023 10:23
(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)(address . 63421-done@debbugs.gnu.org)
ZF9JChi3WOfWXTr4@noor.fritz.box
Hi,

Toggle quote (4 lines)
> - (inputs (list ghc-tagged ghc-optparse-applicative ghc-ansi-terminal))
> + (inputs (list ghc-unbounded-delays ghc-tagged ghc-optparse-applicative
> + ghc-ansi-terminal))

that’s a pretty big rebuild (~1500 packages). I’ve added this
conditionally in commit cf89a215cec346bc4d6622cbe353c058452b29b2.

Cheers,
Lars
Closed
D
D
Denis 'GNUtoo' Carikli wrote on 15 May 2023 15:57
(name . Lars-Dominik Braun)(address . lars@6xq.net)(address . 63421-done@debbugs.gnu.org)
20230515155754.7c35f542@primary_laptop
On Sat, 13 May 2023 10:23:38 +0200
Lars-Dominik Braun <lars@6xq.net> wrote:

Toggle quote (1 lines)
> Hi,
Hi,

Toggle quote (8 lines)
> > - (inputs (list ghc-tagged ghc-optparse-applicative
> > ghc-ansi-terminal))
> > + (inputs (list ghc-unbounded-delays ghc-tagged
> > ghc-optparse-applicative
> > + ghc-ansi-terminal))
>
> that’s a pretty big rebuild (~1500 packages). I’ve added this
> conditionally in commit cf89a215cec346bc4d6622cbe353c058452b29b2.
Thanks a lot and sorry for forgetting to check about the number of
rebuilds.

Denis.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAmRiOmIACgkQX138wUF3
4mOknhAAkJLv8M4daLOu2Lm83iWoCk/wCV06/Cik2rkiAa5NaGjs6zgJYYx3EMPo
Rd4qbR5rrnXfpVtTn4Inwl0ELEYEc7luoI9HARWL/+Ogc4s/RlL3OqCz3eaxjrPh
OKTdJrpYpeZKP0jWhLr9HTx4wU1aMplODSVc9B5F29OIBUUWRl+Li+ajmrGiTJK+
yiUUAYJdxb5fd7Ju9sdYM6ro6w6l5SvEw8slrx+sdy2GbX1WioRlof1hO333sQ6m
D7QhO9hq09gfAZ+El7EALB57Pip2J5J7v/zwzT9mHVJrri0/+9YXeidiA65gZRgd
VnGlzOyo2DdIPVkSCL9LiVTs05bR8qpx91CYxv4FskwC8gzDcmTsKL8WDEQjdHUD
76M/r103lDtPgD8VDQNzYe5FBS8TJvtlu4jONOIlMX7Ev2o2IMYNlFokKWsJWZTG
tLbJgPY9mUM8nv7AUMvVZkHFv8jth09GrRkgiIDEiUVLY7aRbPC57NYptd2ffIgX
X08j5aSpI0NeWWOQ9Mkxy6K3+tlZKJ8KbyhD7E1+NyP2AzaD39HfXWJUnEBkQcH3
OmLKpBhrcO+3Ok27+sw8tL2RwKV5Y2ks32xM644htCVfvVYlS4uXLJs6xjM9QJI7
OdZpv7REI0sCQfZsn5d/r8nMiRGlpxK/Fz01LzBb1Xc9QjCUiV8=
=S18w
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63421@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63421
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch