(address . guix-patches@gnu.org)
This seems to work around the crashes/restarts that have recently been
affecting the coordinator (see #63368).
* gnu/services/guix.scm (guix-build-coordinator-shepherd-services): Set
GC_RETRY_SIGNALS=0.
---
gnu/services/guix.scm | 5 +++++
1 file changed, 5 insertions(+)
Toggle diff (21 lines)
diff --git a/gnu/services/guix.scm b/gnu/services/guix.scm
index 90310ab9d9..f8fee38b7a 100644
--- a/gnu/services/guix.scm
+++ b/gnu/services/guix.scm
@@ -372,6 +372,11 @@ (define (guix-build-coordinator-shepherd-services config)
"GUIX_LOCPATH=" #$glibc-utf8-locales "/lib/locale")
"LC_ALL=en_US.utf8"
"PATH=/run/current-system/profile/bin" ; for hooks
+ ;; TODO: This seems to help with avoid
+ ;; crashes/restarts, but ideally the Guix service
+ ;; wouldn't be setting environment variables to fiddle
+ ;; with the behaviour of Guile's GC.
+ "GC_RETRY_SIGNALS=0"
#$@extra-environment-variables)
#:log-file "/var/log/guix-build-coordinator/coordinator.log")
args))))
base-commit: 98c393164167e9a5a205f7dffa966992a71925ae
prerequisite-patch-id: 1a081b728996250cec703888ab2b5aad184e616d
--
2.39.1