[PATCH] services: guix-build-coordinator: Set GC_RETRY_SIGNALS=0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 10 May 2023 14:45
(address . guix-patches@gnu.org)
77bc127265325bc2c593abee09d08b79dc578566.1683722725.git.mail@cbaines.net
This seems to work around the crashes/restarts that have recently been
affecting the coordinator (see #63368).

* gnu/services/guix.scm (guix-build-coordinator-shepherd-services): Set
GC_RETRY_SIGNALS=0.
---
gnu/services/guix.scm | 5 +++++
1 file changed, 5 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/services/guix.scm b/gnu/services/guix.scm
index 90310ab9d9..f8fee38b7a 100644
--- a/gnu/services/guix.scm
+++ b/gnu/services/guix.scm
@@ -372,6 +372,11 @@ (define (guix-build-coordinator-shepherd-services config)
"GUIX_LOCPATH=" #$glibc-utf8-locales "/lib/locale")
"LC_ALL=en_US.utf8"
"PATH=/run/current-system/profile/bin" ; for hooks
+ ;; TODO: This seems to help with avoid
+ ;; crashes/restarts, but ideally the Guix service
+ ;; wouldn't be setting environment variables to fiddle
+ ;; with the behaviour of Guile's GC.
+ "GC_RETRY_SIGNALS=0"
#$@extra-environment-variables)
#:log-file "/var/log/guix-build-coordinator/coordinator.log")
args))))

base-commit: 98c393164167e9a5a205f7dffa966992a71925ae
prerequisite-patch-id: 1a081b728996250cec703888ab2b5aad184e616d
--
2.39.1
M
M
Maxim Cournoyer wrote on 1 Sep 2023 16:21
(name . Christopher Baines)(address . mail@cbaines.net)(address . 63417@debbugs.gnu.org)
87r0ni2cu3.fsf@gmail.com
Hi Christopher,

Christopher Baines <mail@cbaines.net> writes:

Toggle quote (26 lines)
> This seems to work around the crashes/restarts that have recently been
> affecting the coordinator (see #63368).
>
> * gnu/services/guix.scm (guix-build-coordinator-shepherd-services): Set
> GC_RETRY_SIGNALS=0.
> ---
> gnu/services/guix.scm | 5 +++++
> 1 file changed, 5 insertions(+)
>
> diff --git a/gnu/services/guix.scm b/gnu/services/guix.scm
> index 90310ab9d9..f8fee38b7a 100644
> --- a/gnu/services/guix.scm
> +++ b/gnu/services/guix.scm
> @@ -372,6 +372,11 @@ (define (guix-build-coordinator-shepherd-services config)
> "GUIX_LOCPATH=" #$glibc-utf8-locales "/lib/locale")
> "LC_ALL=en_US.utf8"
> "PATH=/run/current-system/profile/bin" ; for hooks
> + ;; TODO: This seems to help with avoid
> + ;; crashes/restarts, but ideally the Guix service
> + ;; wouldn't be setting environment variables to fiddle
> + ;; with the behaviour of Guile's GC.
> + "GC_RETRY_SIGNALS=0"
> #$@extra-environment-variables)
> #:log-file "/var/log/guix-build-coordinator/coordinator.log")
> args))))

Have you tried presenting the problem to more core Guile folks?
(guile-devel). Perhaps someone could tip you in the right direction, or
perhaps it's a bug in Guile?

--
Thanks,
Maxim
C
C
Christopher Baines wrote on 5 Sep 2023 13:20
Re: [bug#63417] [PATCH] services: guix-build-coordinator: Set GC_RETRY_SIGNALS=0.
(address . 63417-close@debbugs.gnu.org)
87r0ncdfxi.fsf@cbaines.net

?