[PATCH] gnu: barrier: Include NULL compatibility.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Simon Tournier
Owner
unassigned
Submitted by
Simon Tournier
Severity
normal

Debbugs page

Simon Tournier wrote 2 years ago
(address . guix-patches@gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
4c0fb1d9136b79f73098fa3df7b32c517b867d4d.1683642570.git.zimon.toutoune@gmail.com
Reported by <john@fremlin.org>

* gnu/packages/barrier.scm (barrier)[arguments]: Use G-exp, add phases
including NULL macro.
---
gnu/packages/barrier.scm | 16 +++++++++++++---
1 file changed, 13 insertions(+), 3 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/barrier.scm b/gnu/packages/barrier.scm
index 5c2ecb0f2f..be0e52349b 100644
--- a/gnu/packages/barrier.scm
+++ b/gnu/packages/barrier.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
+;;; Copyright © 2023 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,6 +20,7 @@
(define-module (gnu packages barrier)
#:use-module (guix build-system cmake)
#:use-module (guix utils)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
@@ -48,9 +50,17 @@ (define-public barrier
(base32 "19bwa9qidq2mxv1fkyxxc1xdmv3jx6bj35bkaaw70jzkblnfmlfs"))))
(build-system cmake-build-system)
(arguments
- '(#:configure-flags
- (list "-DBARRIER_USE_EXTERNAL_GTEST=ON")
- #:tests? #f)) ;tests require a running x server
+ (list
+ #:configure-flags
+ #~(list "-DBARRIER_USE_EXTERNAL_GTEST=ON")
+ #:tests? #f ;; tests require a running x server
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-null
+ (lambda _
+ (substitute* "src/lib/base/Event.h"
+ (("#include \"common/stdmap\\.h\"")
+ "#include \"common/stdmap.h\"\n#include <cstddef>")))))))
(native-inputs
(list googletest pkg-config))
(inputs

base-commit: 76a3deb8675576a6ce64874234c9d3881060db3b
--
2.38.1
Ludovic Courtès wrote 2 years ago
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 63392-done@debbugs.gnu.org)
87zg6b2e8c.fsf@gnu.org
Hi,

Simon Tournier <zimon.toutoune@gmail.com> skribis:

Toggle quote (6 lines)
> Reported by <john@fremlin.org>
>
> * gnu/packages/barrier.scm (barrier)[arguments]: Use G-exp, add phases
> including NULL macro.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63392@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63392
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help