(address . guix-patches@gnu.org)
* gnu/packages/tls.scm (guile-gnutls): Update to 3.7.12.
[source]: Switch to a tarball, to avoid a circular dependency if guile-gnutls
is used in git-download.
[arguments]: Remove phase changes for building from Git.
[native-inputs]: Remove autoconf and automake as they're now unnecessary.
---
gnu/packages/tls.scm | 43 +++++++++++--------------------------------
1 file changed, 11 insertions(+), 32 deletions(-)
Toggle diff (73 lines)
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 6d7cff41b0..095de98d21 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -319,18 +319,18 @@ (define-public guile-gnutls
;; This package supersedes the Guile bindings that came with GnuTLS until
;; version 3.7.8 included.
(name "guile-gnutls")
- (version "3.7.11")
+ (version "3.7.12")
(home-page "https://gitlab.com/gnutls/guile/")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://gitlab.com/gnutls/guile/uploads/"
+ "3fe12c208bdc6155c5116cf5eac7a2ad"
+ "/guile-gnutls-" version ".tar.gz"))
(sha256
(base32
- "06d7v3i0d9ayp7zqk1rsy4z0wfpq69n0r54f1xrppb9gn7q9iva6"))
- (file-name (git-file-name name version))
- (patches (search-patches "gnutls-cross.patch"))))
+ "0dp3zsbnwgb4q4p8n6i5vnlwq52v5hp8f5c44ngyag89fcaz2fjx"))))
(build-system gnu-build-system)
(arguments
(list
@@ -343,34 +343,13 @@ (define-public guile-gnutls
(string-append "--with-guile-site-ccache-dir="
"$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache")
(string-append "--with-guile-extension-dir="
- "$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/extensions"))
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-more-shebangs
- (lambda _
- (substitute* "autogen.sh"
- (("\\$gnulib_tool \\$gnulib_tool_options")
- "sh $gnulib_tool $gnulib_tool_options"))
- (substitute* "configure.ac"
- (("build-aux/git-version-gen")
- "sh build-aux/git-version-gen"))
- (for-each patch-shebang
- '("autopull.sh" "autogen.sh"))))
- (replace 'bootstrap
- (lambda _
- (invoke "bash" "./bootstrap" "--no-git"))))))
+ "$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/extensions"))))
(native-inputs
- (list autoconf
- automake
- libtool
+ (list libtool
pkg-config
texinfo
gnutls
- guile-3.0 ;XXX: 'guile-snarf' invokes the native 'cpp'
- (gnulib-checkout
- #:version "2022-12-06"
- #:commit "440b528b1d81dd31b2a2e4dde20d5c837c147811"
- #:hash (base32 "15mq43abbnkbamchc9lynrvrd5ql8qacgyx2ph4kkngxf1bz3pqy"))))
+ guile-3.0)) ;XXX: 'guile-snarf' invokes the native 'cpp'
(inputs
(list gnutls
guile-3.0))
base-commit: 649ce7b433171a47e8a2819b849bfa88c736d0e9
--
2.39.1