[PATCH] gnu: guile-gnutls: Update to 3.7.12.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 9 May 2023 13:12
(address . guix-patches@gnu.org)
0c21dcb0fb324299bbfafe8c6f67dc1d9db4b84c.1683630749.git.mail@cbaines.net
* gnu/packages/tls.scm (guile-gnutls): Update to 3.7.12.
[source]: Switch to a tarball, to avoid a circular dependency if guile-gnutls
is used in git-download.
[arguments]: Remove phase changes for building from Git.
[native-inputs]: Remove autoconf and automake as they're now unnecessary.
---
gnu/packages/tls.scm | 43 +++++++++++--------------------------------
1 file changed, 11 insertions(+), 32 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 6d7cff41b0..095de98d21 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -319,18 +319,18 @@ (define-public guile-gnutls
;; This package supersedes the Guile bindings that came with GnuTLS until
;; version 3.7.8 included.
(name "guile-gnutls")
- (version "3.7.11")
+ (version "3.7.12")
(home-page "https://gitlab.com/gnutls/guile/")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://gitlab.com/gnutls/guile/uploads/"
+ "3fe12c208bdc6155c5116cf5eac7a2ad"
+ "/guile-gnutls-" version ".tar.gz"))
(sha256
(base32
- "06d7v3i0d9ayp7zqk1rsy4z0wfpq69n0r54f1xrppb9gn7q9iva6"))
- (file-name (git-file-name name version))
- (patches (search-patches "gnutls-cross.patch"))))
+ "0dp3zsbnwgb4q4p8n6i5vnlwq52v5hp8f5c44ngyag89fcaz2fjx"))))
(build-system gnu-build-system)
(arguments
(list
@@ -343,34 +343,13 @@ (define-public guile-gnutls
(string-append "--with-guile-site-ccache-dir="
"$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache")
(string-append "--with-guile-extension-dir="
- "$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/extensions"))
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-more-shebangs
- (lambda _
- (substitute* "autogen.sh"
- (("\\$gnulib_tool \\$gnulib_tool_options")
- "sh $gnulib_tool $gnulib_tool_options"))
- (substitute* "configure.ac"
- (("build-aux/git-version-gen")
- "sh build-aux/git-version-gen"))
- (for-each patch-shebang
- '("autopull.sh" "autogen.sh"))))
- (replace 'bootstrap
- (lambda _
- (invoke "bash" "./bootstrap" "--no-git"))))))
+ "$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/extensions"))))
(native-inputs
- (list autoconf
- automake
- libtool
+ (list libtool
pkg-config
texinfo
gnutls
- guile-3.0 ;XXX: 'guile-snarf' invokes the native 'cpp'
- (gnulib-checkout
- #:version "2022-12-06"
- #:commit "440b528b1d81dd31b2a2e4dde20d5c837c147811"
- #:hash (base32 "15mq43abbnkbamchc9lynrvrd5ql8qacgyx2ph4kkngxf1bz3pqy"))))
+ guile-3.0)) ;XXX: 'guile-snarf' invokes the native 'cpp'
(inputs
(list gnutls
guile-3.0))

base-commit: 649ce7b433171a47e8a2819b849bfa88c736d0e9
--
2.39.1
L
L
Ludovic Courtès wrote on 10 May 2023 00:32
(name . Christopher Baines)(address . mail@cbaines.net)
87h6sldtl8.fsf@gnu.org
Hi Christopher,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (6 lines)
> * gnu/packages/tls.scm (guile-gnutls): Update to 3.7.12.
> [source]: Switch to a tarball, to avoid a circular dependency if guile-gnutls
> is used in git-download.
> [arguments]: Remove phase changes for building from Git.
> [native-inputs]: Remove autoconf and automake as they're now unnecessary.

Excellent! (Thanks, Simon!)

Toggle quote (7 lines)
> (source (origin
> - (method git-fetch)
> - (uri (git-reference
> - (url home-page)
> - (commit (string-append "v" version))))
> + (method url-fetch)

Please add a comment stating why we’re using ‘url-fetch’, with a

Toggle quote (3 lines)
> + (uri
> + (string-append

Rather on the same line maybe? :-)

Thanks for working on it!

Ludo’.
C
C
Christopher Baines wrote on 10 May 2023 12:45
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 63388-done@debbugs.gnu.org)
871qjo31nq.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (22 lines)
> Hi Christopher,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/tls.scm (guile-gnutls): Update to 3.7.12.
>> [source]: Switch to a tarball, to avoid a circular dependency if guile-gnutls
>> is used in git-download.
>> [arguments]: Remove phase changes for building from Git.
>> [native-inputs]: Remove autoconf and automake as they're now unnecessary.
>
> Excellent! (Thanks, Simon!)
>
>> (source (origin
>> - (method git-fetch)
>> - (uri (git-reference
>> - (url home-page)
>> - (commit (string-append "v" version))))
>> + (method url-fetch)
>
> Please add a comment stating why we’re using ‘url-fetch’, with a
> reference to <https://issues.guix.gnu.org/63331>.

Done.

Toggle quote (5 lines)
>> + (uri
>> + (string-append
>
> Rather on the same line maybe? :-)

Sure, I've moved it up.

Toggle quote (2 lines)
> Thanks for working on it!

No problem, I've pushed this to master as
5e1e67442188ccca8db8c1dd092efbc6fc2c33dc.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmRbddlfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeSchAAoBcI3sRhGRJ/T+EgcBdQcFmVQ9HvldJL
Ldmkca7NXYsz4rPG4B1ZW6rGIkxhx2M4hyGn8/EawD/e+Xq5KBnVIEJuJkmj0F6r
yYgud3PTxqi/2HraMR1eKuCCDSW0NZl3Ae/p5UbxTMV7XhCQxYC1r4F4n1tFGJyx
YYHEQf1+DC/Kd7nTrgOODFCjWZHOT2zy4eYJlTnVeBpRfmRqh5Hy+igFyFTLPH8e
ISYyTYSj/tXWEYePdSgOLWimY34Vo+jp5IMFue8odHQVyGLJ5/2/D0NcypGTAYFC
jyTuf6deLU5JVuy7P6qIMD1oV/xW74Irx8jb0Rywv5gczykEToaXLDHXzw5Vsh2w
D3UI/GUPB2iGBovGE7tQ3SynbBS/c2rCQNr0WttWR0+1mSkeOCVHfiJod45JGf+R
poxgMTmxalmIqQcruwkunpxHi6koqcNLKIciMHejZcmuUpR7W/ppedXOmR8nepe+
QMDkY92aNpt7WpfTeDwEvVJOWGzvyN3taLqzc4sIZUE0nlmQtymjLRw3KMgvQfSl
nDdpWg8SNczioczwRf6KUGVuG2Cb9FbHMbzHpLHslmpdmkr23Dlllkb7s94K803+
vHGDyrk+LZgN6gkubvw7/XDPamwzoOg5pOA/szrblcwtvJCbpu9H9ejkWt059XJC
fisGMhTgZbo=
=NL/k
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63388@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63388
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch