[PATCH 0/4] Update pipewire and xdg-desktop-portal

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Benjamin
Owner
unassigned
Submitted by
Benjamin
Severity
normal
B
B
Benjamin wrote on 8 May 2023 23:50
(address . guix-patches@gnu.org)(name . Benjamin)(address . benjamin@uvy.fr)
cover.1683581164.git.benjamin@uvy.fr
Hello Guixers,

These patches are updating components to be able to screencast from
ungoogle-chromium. On my setup : wayland with sway, it was previously
failing.

To be able, for screencast to work, pipewire, wireplumber
xdg-desktop-portal and xdg-desktop-portal-wlr need to be running as
explained in #52492.

While updating pipewire, the upstream repo has been installing an rlimits
file to /etc/security/limits.d/25-pw-rlimits.conf and this was failing
during the installation phase.

Such configuration file would be working with pam_limits service.

I think it is possible to instead copy this file to the store (in
/gnu/store/...pipewire.../etc/security/limits.d/ I guess).
Though, while grepping I did not see such thing beeing done in another
package.
I am pretty new to guix so I do not exactly know what should be done. But
for now, I disabled the installation of this file using meson flag
-Drlimits-install=false

Best

Benjamin


Benjamin (4):
gnu: pipewire: Update to 0.3.70.
gnu: wireplumber: Update to 0.4.14.
gnu: xdg-desktop-portal: Update to 1.16.0.
gnu: xdg-desktop-portal-wlr: Update to 0.7.0.

gnu/packages/freedesktop.scm | 9 +++++----
gnu/packages/linux.scm | 16 +++++++++-------
2 files changed, 14 insertions(+), 11 deletions(-)


base-commit: 28c2c570f80cc0b4e7302ad11cccc8ad600b3274
--
2.39.2
B
B
Benjamin wrote on 8 May 2023 23:55
[PATCH 1/4] gnu: pipewire: Update to 0.3.70.
(name . Benjamin)(address . benjamin@uvy.fr)
b39c42889a15c960b7b8eeb8e3ac3b915437b1e3.1683581164.git.benjamin@uvy.fr
* gnu/packages/linux.scm (pipewire): Update to 0.3.70.
[inputs]: Add glib.
[arguments]: Do not install rlimits.
---
gnu/packages/linux.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ea64e9d241..eac9a241cd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9156,7 +9156,7 @@ (define-public inputattach
(define-public pipewire
(package
(name "pipewire")
- (version "0.3.63")
+ (version "0.3.70")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -9165,18 +9165,20 @@ (define-public pipewire
(file-name (git-file-name name version))
(sha256
(base32
- "1pkngynvhxc6iyv75gsyqjy18ky4si9dhvpavb9xwq5xj71nj0hr"))))
+ "1n74rrbwymm89ri4daa4v092f4b81wrak4vg685xfz2wl89p64n6"))))
(build-system meson-build-system)
(arguments
(list
#:configure-flags
#~(list (string-append "-Dudevrulesdir=" #$output "/lib/udev/rules.d")
- "-Dsystemd=disabled"
+ "-Dman=enabled"
+ "-Drlimits-install=false"
"-Dsession-managers=[]"
"-Dsysconfdir=/etc"
- "-Dman=enabled")))
+ "-Dsystemd=disabled")))
(native-inputs
- (list pkg-config
+ (list `(,glib "bin")
+ pkg-config
python-docutils))
(inputs (list alsa-lib
avahi
--
2.39.2
B
B
Benjamin wrote on 8 May 2023 23:55
[PATCH 2/4] gnu: wireplumber: Update to 0.4.14.
(name . Benjamin)(address . benjamin@uvy.fr)
f78f48fa930b5a5c8b66952d9bc924aff4d3e72d.1683581164.git.benjamin@uvy.fr
* gnu/packages/linux.scm (wireplumber): Update to 0.4.14.
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index eac9a241cd..faca5d808a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9218,7 +9218,7 @@ (define-public pipewire
(define-public wireplumber
(package
(name "wireplumber")
- (version "0.4.13")
+ (version "0.4.14")
(source
(origin
(method git-fetch)
@@ -9228,7 +9228,7 @@ (define-public wireplumber
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "07psjb7rxsigwnwnzmw2y767vhyyha7cn8i8dgq80rzhwgl0sgv7"))))
+ (base32 "0jmnd6000j4wx68lxgz5b4g4hxkf243ivi9swaaf8rnx99cbx91w"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dsystemd=disabled"
--
2.39.2
B
B
Benjamin wrote on 8 May 2023 23:55
[PATCH 3/4] gnu: xdg-desktop-portal: Update to 1.16.0.
(name . Benjamin)(address . benjamin@uvy.fr)
8215545d66a87d357a15631744a9f437fd31618f.1683581164.git.benjamin@uvy.fr
* gnu/packages/freedesktop.scm (xdg-desktop-portal): Update to 1.16.0.
---
gnu/packages/freedesktop.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 78b459443a..09637cccbd 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2755,7 +2755,7 @@ (define-public libportal
(define-public xdg-desktop-portal
(package
(name "xdg-desktop-portal")
- (version "1.14.6")
+ (version "1.16.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2763,7 +2763,7 @@ (define-public xdg-desktop-portal
version "/xdg-desktop-portal-" version ".tar.xz"))
(sha256
(base32
- "1q0djpnwlrqm0h0alyh1r6dlkqdrr7mj5hiam4mqzxqa5jbqkrgj"))))
+ "06cczlh39kc41rvav06v37sad827y61rffy3v29i918ibj8sahav"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
--
2.39.2
B
B
Benjamin wrote on 8 May 2023 23:55
[PATCH 4/4] gnu: xdg-desktop-portal-wlr: Update to 0.7.0.
(name . Benjamin)(address . benjamin@uvy.fr)
144ff73738319effd6d220bb267182896b4d70e1.1683581164.git.benjamin@uvy.fr
* gnu/packages/freedesktop.scm (xdg-desktop-portal-wlr): Update to 0.7.0.
[inputs]: Add mesa.
---
gnu/packages/freedesktop.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 09637cccbd..6d166a09e6 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2912,7 +2912,7 @@ (define-public xdg-desktop-portal-kde
(define-public xdg-desktop-portal-wlr
(package
(name "xdg-desktop-portal-wlr")
- (version "0.5.0")
+ (version "0.7.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2921,7 +2921,7 @@ (define-public xdg-desktop-portal-wlr
(file-name (git-file-name name version))
(sha256
(base32
- "1ipg35gv8ja39ijwbyi96qlyq2y1fjdggl40s38rv68bsya8zry1"))
+ "1b3hpp3ybjgnnmnwsyb5bsnvz9q5nr3zz0j1alh02g24f68lf00k"))
(patches (search-patches "xdg-desktop-portal-wlr-harcoded-length.patch"))))
(build-system meson-build-system)
(arguments
@@ -2955,6 +2955,7 @@ (define-public xdg-desktop-portal-wlr
grim
iniparser
libinih
+ mesa
pipewire
slurp
wayland
--
2.39.2
A
A
Andrew Tropin wrote on 14 Jun 2023 11:50
Re: [bug#63380] [PATCH 0/4] Update pipewire and xdg-desktop-portal
(name . Benjamin)(address . benjamin@uvy.fr)
87pm5ys790.fsf@trop.in
On 2023-05-08 23:50, Benjamin wrote:

Toggle quote (6 lines)
> Hello Guixers,
>
> These patches are updating components to be able to screencast from
> ungoogle-chromium. On my setup : wayland with sway, it was previously
> failing.

Hi Benjamin!

This thread was on my backlog, but I forgot about it, when was updating
xdg-desktop-portals, so I did it separately. Screensharing via pipewire
now works again. I applied your pipewire and wireplumber patches, thank
you very much.

Toggle quote (19 lines)
>
> To be able, for screencast to work, pipewire, wireplumber
> xdg-desktop-portal and xdg-desktop-portal-wlr need to be running as
> explained in #52492.
>
> While updating pipewire, the upstream repo has been installing an rlimits
> file to /etc/security/limits.d/25-pw-rlimits.conf and this was failing
> during the installation phase.
>
> Such configuration file would be working with pam_limits service.
>
> I think it is possible to instead copy this file to the store (in
> /gnu/store/...pipewire.../etc/security/limits.d/ I guess).
> Though, while grepping I did not see such thing beeing done in another
> package.
> I am pretty new to guix so I do not exactly know what should be done. But
> for now, I disabled the installation of this file using meson flag
> -Drlimits-install=false

That's right, limits should be configured via pam-limits-service-type.

Toggle quote (19 lines)
>
> Best
>
> Benjamin
>
>
> Benjamin (4):
> gnu: pipewire: Update to 0.3.70.
> gnu: wireplumber: Update to 0.4.14.
> gnu: xdg-desktop-portal: Update to 1.16.0.
> gnu: xdg-desktop-portal-wlr: Update to 0.7.0.
>
> gnu/packages/freedesktop.scm | 9 +++++----
> gnu/packages/linux.scm | 16 +++++++++-------
> 2 files changed, 14 insertions(+), 11 deletions(-)
>
>
> base-commit: 28c2c570f80cc0b4e7302ad11cccc8ad600b3274

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmSJjUsACgkQIgjSCVjB
3rCH7Q//UvoL5kIO7a9Cxv835IT4pRqCEFrlOVvaQ5bfAGGkF5BqJye3gn5VMzCo
53zNz/kzkFBF1KTZYtBUm68b7PHQ103Hq+jOlyjHmfIizgFMMFQrM/ZNTT1yLYqQ
HGJ2z2xPMvRWZywJ0lzsAvmEKlDe1waJSUOd1Ge0vFx1zP89kbEZa2hkBwprt/WD
p+wFOGVmq04t9L4kbeSeQREydP7PRpF/ZmRYDG2fCiEwax38C5mOsQIFNI+hg041
vWauwVhnu2q7dDlwa4TqVMfXz+adJiFueN0pzVp7IgF9kbMmmK2tZf7xKYb6Uohr
TOLEPIXToE5ubQ5K2DmTFblofffupuQZf/qzJbmlyUr1dKy7SnqpRWPfXlmgJHOn
zC+w79rVNK7OLvSZTypGUa0ntowgvgJMYFafzAYmh0oF+eShYG1G8dBWmDvteVKW
eAxEEeQeXQJq3kPpToLk1ZPDWN5gVCjQiM2xQJHr1np2ZaqTdlREvqXa261tpaZF
ExL7SzAloFFjMIcBCUgY/UR/hqmrkQ8GLLNRHxJK4X209IwjzxBAVkPbwLRomyXX
zbxgSsaEuvRENcg4RjKHK58f5ddz5e5wbpfTwSOWrXAhRkQuG1iUvIxo+ahLvSKb
l2qXj8Nm0KLqhqRYhLZwfheXas440C14zRzxl1IX00834xP7qY0=
=WOfJ
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63380@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63380
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch