[PATCH] gnu: ftxui: Update to 4.0.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 2 years ago
(address . guix-patches@gnu.org)
87a5yf47sh.fsf@gmail.com
Hello,

this patch updates FTXUI[1] to 4.0.0 and fixes its build.
From 492897d7e9a266fecafa31da2342e63b604364e6 Mon Sep 17 00:00:00 2001
Message-Id: <492897d7e9a266fecafa31da2342e63b604364e6.1683529548.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Mon, 8 May 2023 10:05:31 +0300
Subject: [PATCH] gnu: ftxui: Update to 4.0.0.

* gnu/packages/cpp.scm (ftxui): Update to 4.0.0.
[native-inputs]: Add benchmark.
[arguments]: Remove phase modifiers.
---
gnu/packages/cpp.scm | 22 +++++-----------------
1 file changed, 5 insertions(+), 17 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 023d1c0337..242ea088bb 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -67,6 +67,7 @@ (define-module (gnu packages cpp)
#:use-module (gnu packages)
#:use-module (gnu packages assembly)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages benchmark)
#:use-module (gnu packages boost)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages c)
@@ -2433,7 +2434,7 @@ (define-public wdl
(define-public ftxui
(package
(name "ftxui")
- (version "3.0.0")
+ (version "4.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2441,27 +2442,14 @@ (define-public ftxui
(commit (string-append "v" version))))
(sha256
(base32
- "10a4yw2h29kixxyhll6cvrwyscsvz9asxry857a9l8nqvbhs946s"))
+ "01h59ln8amsj6ymxmsxhmslld2yp003n82fg3mphgkrh6lf22h6y"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
- (native-inputs (list googletest))
+ (native-inputs (list googletest benchmark))
(arguments
(list #:configure-flags
#~(list "-DFTXUI_BUILD_TESTS:BOOL=ON"
- "-DFTXUI_BUILD_TESTS_FUZZER:BOOL=OFF")
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-cmake-tests
- (lambda _
- (substitute* "cmake/ftxui_test.cmake"
- (("NOT googletest_POPULATED")
- "FALSE"))
- ;; Disable benchmarks for a while as they require bundled Google
- ;; benchmark and when the 'googlebenchmark' is unbundled, there's
- ;; a CMake configuration error.
- (substitute* "cmake/ftxui_benchmark.cmake"
- (("NOT WIN32")
- "FALSE")))) )))
+ "-DFTXUI_BUILD_TESTS_FUZZER:BOOL=OFF")))
(home-page "https://github.com/ArthurSonzogni/FTXUI")
(synopsis "C++ Functional Terminal User Interface")
(description

base-commit: b7e77446261fdc8dab360d7835a5dec919f6a79f
--
2.34.1
- avp

References:

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQFNBAEBCgA3FiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmRYoI4ZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRDpxaLZCJigL9cGB/4rwJxueC3YR/IOiQEzcdeX
ogAC7CO6uHjUyjHqJ5tfQhV4daVasXwPaW/SEi793LtsAjfuMdEQw/YHRgm0TSZU
w+yrzc0BoMBDY6nxVYJWjrzN1j+pmKs7RjC1EQLEG0S/0u51BljlFa52CYcgH6Lu
+xxIQwzzkZl6Q5YAmeJFcB9K6cDCXh9S3FYPy4c9fv7uGblxTWsc50drNr/irBjn
uZifIU8VUchdnLFudsbW0YN1nmxrK7ZaaXTXrBWCMCLFS8FUYjk8Kz6xKl6Ga63q
3yghgR/Z5W5m7B7cxcleG22iDFqOsp75lH9A8eM73uqjVD5ltGvOArCKeZD2br2t
=QnrU
-----END PGP SIGNATURE-----

宋文武 wrote 2 years ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 63356-done@debbugs.gnu.org)
87fs80sgef.fsf@envs.net
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> writes:

Toggle quote (5 lines)
> Hello,
>
> this patch updates FTXUI[1] to 4.0.0 and fixes its build.
>

Hello, it was already updated to 4.0.0 by another patch.
But this patch's add 'benchmark' and remove the #:phases still apply, so
I did that.

Thank you!
Closed
Artyom V. Poptsov wrote 2 years ago
(name . 宋文武)(address . iyzsong@envs.net)(address . 63356-done@debbugs.gnu.org)
87o7mmzn9a.fsf@gmail.com
Hello!

Toggle quote (4 lines)
> Hello, it was already updated to 4.0.0 by another patch.
> But this patch's add 'benchmark' and remove the #:phases still apply, so
> I did that.

Thanks, I'm glad you found my patch useful.

- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQFNBAEBCgA3FiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmRhQIEZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRDpxaLZCJigLz3zB/wOz2l8cAd8/H3Mlf8oSBxY
bJFawt+B0dzBhp9SYXHIqrF8yy0EZ9tTiYMMLTWIk8TkCISRNp8qwqmttuxhvzVS
lsUTMf6Ne6slgWNEktSatBmWq2joexOtseRIAnCZQi/RAuPh0RJrgDblH5+9FU0T
iLY1GMY9Pwg5XiXZBeIIMQckzAgC4etAkkRA12+XPOR40qupJrdMwT7AZ3nX2A4D
ILEBviwGnasndDnn0S7QXs/vUVlehG8pDjIeWCLuljkaB2vMEzitFctsedGh6UyW
1LeCRXP5aHLWrmASONJgUJB98Co9HPfblKDO1nzwfGvUjGTMzgsvu7YF2dNBmXKL
=Yl61
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63356@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63356
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help