[PATCH] gnu: vulkan-loader: Only run tests on x86.

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Christopher Baines
  • Simon South
  • Simon Tournier
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 2 years ago
(address . guix-patches@gnu.org)
e69158062e0eba76d92762bd2439573cbd64b6ae.1683363858.git.mail@cbaines.net
* gnu/packages/vulkan.scm (vulkan-loader)[arguments]: Only run tests on x86.
---
gnu/packages/vulkan.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index b0d968938b..f03c3dbc6f 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -228,8 +228,10 @@ (define-public vulkan-loader
(build-system cmake-build-system)
(arguments
(list
- #:tests? (not (or (%current-target-system)
- (target-riscv64?)))
+ ;; TODO: Some tests seem to assume running on x86,
+ ;; e.g. TryLoadWrongBinaries
+ #:tests? (and (target-x86?)
+ (not (%current-target-system)))
#:configure-flags
#~(list (string-append "-DVULKAN_HEADERS_INSTALL_DIR="
(dirname (dirname

base-commit: 64086a4fa449a9f6d2f835fcdf5498222b309e3a
--
2.39.1
Simon South wrote 2 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 63325@debbugs.gnu.org)
87h6smx49h.fsf@simonsouth.net
Christopher Baines <mail@cbaines.net> writes:
Toggle quote (2 lines)
> * gnu/packages/vulkan.scm (vulkan-loader)[arguments]: Only run tests on x86.

Christopher,

Disabling tests altogether seems extreme considering the only truly
x86-dependent ones appear to be five of the "TryLoadWrongBinaries" tests
(only these fail on AArch64), and this can perhaps be fixed by modifying
tests/framework/data/CMakeLists.txt to recreate the prebuilt binaries
included in the source package.

At any rate, I'd appreciate a day or two to see if I can come up with a
more nuanced patch that preserves the test suite on at least AArch64.

--
Simon South
simon@simonsouth.net
Simon South wrote 2 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 63325@debbugs.gnu.org)
87ednpxm4v.fsf@simonsouth.net
Simon South <simon@simonsouth.net> writes:
Toggle quote (4 lines)
> At any rate, I'd appreciate a day or two to see if I can come up with
> a more nuanced patch that preserves the test suite on at least
> AArch64.

To avoid hijacking this issue further I've opened one of my own, #63400,
with a patch that disables only the x86-specific tests on non-x86
platforms.


Christopher, does this fix things for you as well? For which
architecture are you building?

--
Simon South
simon@simonsouth.net
Simon Tournier wrote 2 years ago
(address . 63325@debbugs.gnu.org)
87ilcz3twy.fsf@gmail.com
Hi,

On mar., 09 mai 2023 at 16:53, Simon South <simon@simonsouth.net> wrote:

Toggle quote (2 lines)
I am in favor to close this submission and consider #63400. Chris,
WDYT?

Cheers,
simon
Efraim Flashner wrote 2 years ago
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
ZGKCRWR9FTnkoy8n@3900XT
On Thu, May 11, 2023 at 02:59:57PM +0200, Simon Tournier wrote:
Toggle quote (9 lines)
> Hi,
>
> On mar., 09 mai 2023 at 16:53, Simon South <simon@simonsouth.net> wrote:
>
> > https://issues.guix.gnu.org/63400
>
> I am in favor to close this submission and consider #63400. Chris,
> WDYT?

Having come to basically the same patch (sorry Chris!) and having pushed
it, I'm going to close this patch and we can continue in 63400, which so
far has us skipping enough tests to pass on aarch64 but still fail on
other architectures.

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmRigkUACgkQQarn3Mo9
g1FSbg//UVb6WbAL4pk4YE4RajbvssN1qXZfMqBxc19y1wniDqHJcfPh5xhG9cCK
UZ59DtoGU74ocSoIr62BDQA3XMQLIhXsUtd84a78m+LD5PK25p6ezjOrp4c1aHov
+Jvs956nJJbRKT8pl7DSBL7R1RhLhLsyHqLjTDhBx+1cVjTt6F6N9DTyWfTYMpkq
47crmsG+WuKb18qbJuwUQlUoOewE/Y86XChx8HBPL8WTHXze3rtV191/Yq/DFx6v
0YPWnIOwxeMwIvu/7FtY1NgVaCzJns3D46pGaEHzd3S1vimZRGb2UA1qL12eim53
zHbZcQKIiWUsx+mOuuAv6M6N3wkVnd24B6SCg4hzUF9ydmVH85osKUFfskGMPO4w
8LduIPIuFP/uVbsBlA/uQ16mmzZ/mUtQ+NB+TcUW+ZJs5wKf+9OJWC4QiSUkAEuq
xRTd3xugPfqGbx9slKdGaqNI7ZUwfqwXRd6clOav1nBfo5gsNInrDMkKAGVAi/VV
Z3NiMXVsGWaob3zdu7NAETp4BcCwOzM7GSFjWhMIXAQANraZY2/dGO/iL4nf5PYq
TjNpfSbcJdQLEYTXpFrdW8Lz5ASqL1GND/NCxEI26FKTfskqzojZ1vFBaoW5LWdL
NBZnB3qZj6W+JdeMZWubt+8pwAhGzscjNSECzaGNRcK/+KaHJek=
=WeYk
-----END PGP SIGNATURE-----


Closed
Christopher Baines wrote 2 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 63325-done@debbugs.gnu.org)
87wn19e4dc.fsf@cbaines.net
Efraim Flashner <efraim@flashner.co.il> writes:

Toggle quote (16 lines)
> [[PGP Signed Part:Good signature from 41AAE7DCCA3D8351 Efraim Flashner <efraim@flashner.co.il> (trust undefined) created at 2023-05-15T20:04:37+0100 using RSA]]
> On Thu, May 11, 2023 at 02:59:57PM +0200, Simon Tournier wrote:
>> Hi,
>>
>> On mar., 09 mai 2023 at 16:53, Simon South <simon@simonsouth.net> wrote:
>>
>> > https://issues.guix.gnu.org/63400
>>
>> I am in favor to close this submission and consider #63400. Chris,
>> WDYT?
>
> Having come to basically the same patch (sorry Chris!) and having pushed
> it, I'm going to close this patch and we can continue in 63400, which so
> far has us skipping enough tests to pass on aarch64 but still fail on
> other architectures.

No worries, I wasn't planning to merge this before looking at #63400
anyway.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmRik19fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcjchAAq65GpMc/tghUND9WVa5PWbfGoEmlAk2L
+4kHt89gmJW6qdKYXKR5j5wdIEB97KJUFaBCcET6K2L/2fEQEw52gGq9AtR8LjLV
Ba1IbQxEWvvoQ6rQ4JinvInAEXPVDtY6g4hj3dZj/wOmeKAvH64j0AtNX8VmkUgD
2VJmaxuha/4pEEltccfhPb4vIyzLOPzhXcgEePXCtj8X7C+9LMfjR/xmZt+wOeV9
roUZXXjKlz7u2TnfKYbT6QFaCwgVBXJyKY2rrnbklpknWAf5TRaypsN40UdWAhRk
gJkT1eo+uYRz4yv89pN8Haxm/J4mlfXmoGZCeIe7J6pfPal52eBlmYcUBu59r1wx
eZaw5+CaFmcYA4qj/nKLyCtbEbnoFr+Uv97vM0oDvtL0PII0rJa69dDtCzfBsRFK
KFD/B8cjnTLxVWQFH2gBILUf+lwBx0ycX4Ptz86eK//4UgAGU212jRCmfarjsobP
FvM7oDL7rGe6acGlJ7XpKaaPctvwWddSEF9PPu3NQsgLA1rgy7+JpM335zS47Xdg
nHvx8CtCUJtcWmcGvmEY1i/kzewZYYF5KyYu3RENySO1H7TKeSn0ieofDH72VT/J
WJBdKPKTbG7QccyUrINEwhRn10YZbkTAIXNiEDvd98FjI6e3q+sfnDsVDzIlYThH
IWVQrm3NoxQ=
=uqSj
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63325@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63325
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help