[PATCH] gnu: Add capnproto-0.9

  • Open
  • quality assurance status badge
Details
2 participants
  • Franz Geffke
  • Ludovic Courtès
Owner
unassigned
Submitted by
Franz Geffke
Severity
normal
F
F
Franz Geffke wrote on 5 May 2023 12:31
(address . guix-patches@gnu.org)
4fb8c652-b8dd-4be9-bdf4-7abbc0ed29b0@pantherx.org
Toggle diff (26 lines)
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 39954d6764..d0b44f7709 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -613,6 +613,20 @@ (define-public capnproto
RPC system. Think JSON, except binary. Or think Protocol Buffers, except
faster.")
(license license:expat)))

+(define-public capnproto-0.9
+ (package
+ (inherit capnproto)
+ (name "capnproto")
+ (version "0.9.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://capnproto.org/capnproto-c++-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0hi5lpyhskdg99n9zgn0ffr79gn12m1j7igkp9wikklg2p4yjca0"))))))
+
(define-public python-ruamel.yaml
(package
(name "python-ruamel.yaml")
L
L
Ludovic Courtès wrote on 11 May 2023 15:42
(name . Franz Geffke)(address . franz@pantherx.org)(address . 63296@debbugs.gnu.org)
87ilcz2ddq.fsf@gnu.org
Hi Franz,

Franz Geffke <franz@pantherx.org> skribis:

Toggle quote (11 lines)
> diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
> index 39954d6764..d0b44f7709 100644
> --- a/gnu/packages/serialization.scm
> +++ b/gnu/packages/serialization.scm
> @@ -613,6 +613,20 @@ (define-public capnproto
> RPC system. Think JSON, except binary. Or think Protocol Buffers,
> except faster.")
> (license license:expat)))
>
> +(define-public capnproto-0.9

Are there packages in Guix that are going to depend on it?

If not, could you explain briefly why we should have it?

In general, we keep old versions if there’s a package depending on it or
if there’s a strong use case (for example, developers may often work
with different versions of Python, GCC, or LLVM, so we keep several
versions of them).

Ludo’.
L
L
Ludovic Courtès wrote on 14 Jun 2023 23:18
control message for bug #63296
(address . control@debbugs.gnu.org)
877cs5rbd1.fsf@gnu.org
tags 63296 + moreinfo
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 63296@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63296
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch