[PATCH] gnu: Add cpputilities

  • Open
  • quality assurance status badge
Details
One participant
  • Franz Geffke
Owner
unassigned
Submitted by
Franz Geffke
Severity
normal
F
F
Franz Geffke wrote on 5 May 2023 12:24
(address . guix-patches@gnu.org)
61ee5faa-3346-6ff8-8769-add65ee62dd9@pantherx.org
Toggle diff (28 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 023d1c0337..c9718e16fc 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2478,3 +2478,23 @@ (define-public ftxui
@item No dependencies.
@end itemize")
(license license:expat)))
+
+(define-public cpputilities
+ (package
+ (name "cpputilities")
+ (version "5.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Martchus/cpp-utilities/archive/refs/tags/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "18mbzw8w0a4l5r0w1fr200m4v8ww65r838618z19v1ymz6aahs7a"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/Martchus/cpp-utilities/")
+ (synopsis "Useful C++ classes and routines")
+ (description "Useful C++ classes and routines such as
+argument parser, IO and conversion utilities.")
+ (license license:gpl2+)))
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 63294@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63294
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch