[PATCH] gnu: Add r-multibac.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 2 years ago
(address . guix-patches@gnu.org)
20230504154640.1833-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-multibac): New variable.
---
gnu/packages/bioconductor.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 768b55b25e..299d772bd2 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10101,6 +10101,37 @@ (define-public r-mbkmeans
large datasets, including support for on-disk data representation.")
(license license:expat)))
+(define-public r-multibac
+ (package
+ (name "r-multibac")
+ (version "1.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "MultiBaC" version))
+ (sha256
+ (base32 "1qwf1mvw81hb929xpnx5x910f7qnax9lkylhwzcdw1814s4zj25i"))))
+ (properties `((upstream-name . "MultiBaC")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ggplot2
+ r-matrix
+ r-multiassayexperiment
+ r-pcamethods
+ r-plotrix
+ r-ropls))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/MultiBaC")
+ (synopsis "Multiomic batch effect correction")
+ (description
+ "MultiBaC is a strategy to correct batch effects from multiomic datasets
+distributed across different labs or data acquisition events. This package is
+the first batch effect correction algorithm that dealing with batch effect
+correction in multiomics datasets. MultiBaC is able to remove batch effects
+across different omics generated within separate batches provided that at least
+one common omic data type is included in all the batches considered.")
+ (license license:gpl3)))
+
(define-public r-multtest
(package
(name "r-multtest")

base-commit: 7a0a186a32524d4156bf96786d708fab323cebff
--
2.39.2
Ricardo Wurmus wrote 2 years ago
(address . 63275-done@debbugs.gnu.org)
87zg6fw5dh.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63275@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63275
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help