[PATCH] gnu: Add python-goatools.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
7a9dadbaaecb1eab3d713b921a4d808154ac7f99.1683212209.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-goatools): New variable.
---
gnu/packages/bioinformatics.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7db8a91e80..db76d04594 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12337,6 +12337,37 @@ (define-public python-genomic-regions
using the same syntax.")
(license license:expat)))
+(define-public python-goatools
+ (package
+ (name "python-goatools")
+ (version "1.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "goatools" version))
+ (sha256
+ (base32
+ "1p53h7bnbmi23lcgsajf9vb8vxgjp6lmbz0hl1cx62230jvbfp62"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f))
+ (propagated-inputs (list python-docopt
+ python-numpy
+ python-openpyxl
+ python-pandas
+ python-pydot
+ python-requests
+ python-scipy
+ python-statsmodels
+ python-xlsxwriter))
+ (home-page "https://github.com/tanghaibao/goatools")
+ (synopsis "Python scripts to find enrichment of GO terms")
+ (description "Python scripts to find enrichment of GO terms.
+In addition, this package is used for processing the
+obo-formatted file from Gene Ontology website. The
+data structure is a directed acyclic graph that allows
+easy traversal from leaf to root.")
+ (license license:bsd-3)))
+
(define-public python-loompy
(package
(name "python-loompy")

base-commit: f0a51a2bda26f9cc1e0b54b48712bd7cc54408e9
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 63268-done@debbugs.gnu.org)
87ttwsxb6r.fsf@elephly.net
Applied with a number of changes. Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63268@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63268
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help