[PATCH] gexp: Stop generating unreadable builder scripts.

  • Done
  • quality assurance status badge
Details
4 participants
  • Josselin Poiret
  • Ludovic Courtès
  • Christopher Baines
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 4 May 2023 13:24
(address . guix-patches@gnu.org)
20230504112448.22462-1-mail@cbaines.net
In Guile, it's possible to produce output from write that can't be read, and
this applies to the code staged through g-expressions for derivations. This
commit detects this early when the derivation is being created, rather than
leaving the error to happen when the derivation is built.

This is important as it means that tools like guix lint will indicate that
there's a problem, hopefully reducing the number of broken derivations in
Guix.

* guix/gexp.scm (gexp->derivation): Check that the builder script can be read.
---
guix/gexp.scm | 15 ++++++++++++---
1 file changed, 12 insertions(+), 3 deletions(-)

Toggle diff (28 lines)
diff --git a/guix/gexp.scm b/guix/gexp.scm
index 0fe4f1c98a..7af9302ccf 100644
--- a/guix/gexp.scm
+++ b/guix/gexp.scm
@@ -1215,9 +1215,18 @@ (define (add-modules exp modules)
#:target target)
(return #f)))
(guile -> (lowered-gexp-guile lowered))
- (builder (text-file script-name
- (sexp->string
- (lowered-gexp-sexp lowered)))))
+ (builder (text-file
+ script-name
+ (let ((builder-string
+ (sexp->string
+ (lowered-gexp-sexp lowered))))
+ (catch 'read-error
+ (lambda ()
+ (call-with-input-string builder-string
+ read)
+ builder-string)
+ (lambda (key . args)
+ (error "invalid gexp" name exp args)))))))
(mbegin %store-monad
(set-grafting graft?) ;restore the initial setting
(raw-derivation name
--
2.39.1
L
L
Ludovic Courtès wrote on 4 May 2023 14:47
(name . Christopher Baines)(address . mail@cbaines.net)(address . 63263@debbugs.gnu.org)
87zg6kqn50.fsf@gnu.org
Hi,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (11 lines)
> In Guile, it's possible to produce output from write that can't be read, and
> this applies to the code staged through g-expressions for derivations. This
> commit detects this early when the derivation is being created, rather than
> leaving the error to happen when the derivation is built.
>
> This is important as it means that tools like guix lint will indicate that
> there's a problem, hopefully reducing the number of broken derivations in
> Guix.
>
> * guix/gexp.scm (gexp->derivation): Check that the builder script can be read.

Calling ‘read’ on every generated sexp is definitely not something we
should do, performance-wise.

Commit 24ab804ce11fe12ff49cd144a3d9c4bfcf55b41c addressed that to some
extent. It works in examples like this:

Toggle snippet (6 lines)
scheme@(guile-user)> ,lower (computed-file "foo" #~(list #$(current-module)))
While executing meta-command:
ERROR:
1. &gexp-input-error: #<directory (guile-user) 7f26d5918c80>

… where ‘current-module’ returns a non-serializable object.

I think the problem you’re trying to address that we frequently
encounter is old-style packages that end up splicing gexps inside sexps,
as in:

(package
;; …
(arguments `(#:phases (modify-phases whatever ,#~doh!))))

Is that right?

The problem here is that ‘sexp->gexp’, which was added precisely as an
optimization for build systems¹, does not check the sexp it’s given.
Example:

Toggle snippet (6 lines)
scheme@(guile-user)> ,lower (computed-file "foo" (sexp->gexp `(list a b c ,(current-module))))
$19 = #<derivation /gnu/store/j5rgrmdzk4mic67zkal4759bcm5xbk1c-foo.drv => 7f26baf56be0>
scheme@(guile-user)> (sexp->gexp `(list a b c ,(current-module)))
$20 = #<gexp (list a b c #<directory (guile-user) 7f26d5918c80>) 7f26bbf2f090>

Oops!

It would be tempting to change ‘sexp->gexp’ to traverse the sexp in
search of non-serializable things… but that’d defeat the whole point of
‘sexp->gexp’.

How about a linter instead, with the understanding that use of sexps in
packages is vanishing? Perhaps coupled with a ‘guix style’ automatic
rewriter.

Thanks,
Ludo’.

¹ Packages would get long lists/trees in their ‘arguments’ field.
Traversing them in search of lowerable objects is costly, and
‘sexp->gexp’ was introduced precisely do we don’t have to traverse the
sexp. (Gexps are designed so that no such traversal is necessary at
run time.)
C
C
Christopher Baines wrote on 4 May 2023 14:57
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 63263@debbugs.gnu.org)
875y98nryn.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (39 lines)
> Hi,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> In Guile, it's possible to produce output from write that can't be read, and
>> this applies to the code staged through g-expressions for derivations. This
>> commit detects this early when the derivation is being created, rather than
>> leaving the error to happen when the derivation is built.
>>
>> This is important as it means that tools like guix lint will indicate that
>> there's a problem, hopefully reducing the number of broken derivations in
>> Guix.
>>
>> * guix/gexp.scm (gexp->derivation): Check that the builder script can be read.
>
> Calling ‘read’ on every generated sexp is definitely not something we
> should do, performance-wise.
>
> Commit 24ab804ce11fe12ff49cd144a3d9c4bfcf55b41c addressed that to some
> extent. It works in examples like this:
>
> scheme@(guile-user)> ,lower (computed-file "foo" #~(list #$(current-module)))
> While executing meta-command:
> ERROR:
> 1. &gexp-input-error: #<directory (guile-user) 7f26d5918c80>
>
>
> … where ‘current-module’ returns a non-serializable object.
>
> I think the problem you’re trying to address that we frequently
> encounter is old-style packages that end up splicing gexps inside sexps,
> as in:
>
> (package
> ;; …
> (arguments `(#:phases (modify-phases whatever ,#~doh!))))
>
> Is that right?

I think so, I can't remember if I've seen any other ways that this
happens.

Toggle quote (19 lines)
> The problem here is that ‘sexp->gexp’, which was added precisely as an
> optimization for build systems¹, does not check the sexp it’s given.
> Example:
>
> scheme@(guile-user)> ,lower (computed-file "foo" (sexp->gexp `(list a b c ,(current-module))))
> $19 = #<derivation /gnu/store/j5rgrmdzk4mic67zkal4759bcm5xbk1c-foo.drv => 7f26baf56be0>
> scheme@(guile-user)> (sexp->gexp `(list a b c ,(current-module)))
> $20 = #<gexp (list a b c #<directory (guile-user) 7f26d5918c80>) 7f26bbf2f090>
>
> Oops!
>
> It would be tempting to change ‘sexp->gexp’ to traverse the sexp in
> search of non-serializable things… but that’d defeat the whole point of
> ‘sexp->gexp’.
>
> How about a linter instead, with the understanding that use of sexps in
> packages is vanishing? Perhaps coupled with a ‘guix style’ automatic
> rewriter.

A linter might be helpful, but I'm not sure it'll help that much.

I think it's quite a lofty expectation for the linter to be run on
packages that are edited, let alone on the packages affected by those
changes (which is what's needed to catch this problem), so adding a
linter will mean we get lint warnings, but we'll still be living with
these broken derivations.

The builds for affected derivations fail immediately, and it's pretty
obvious from the log that the builder is unreadable, so it should
already be possible to spot this problem from looking at the effect of
package changes on builds, so I think the main way a linter will help is
that it would provide a way to find out what derivations are broken in
this way, without attempting to build all of them.

I guess my perspective on this is more from the operation of the guix
data service, which is carefully computing and storing all of these
broken derivations (and there's a lot, like 10,000+ per revision at the
moment, since they change every time you compute them). This then
propagates down to the build coordinator as well, since there's builds
being submitted for all these broken derivations. I have considered
trying to detect these breakages in the data service, but I'm not sure
how to do it while removing the possibility of false positives.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmRTs7BfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xeobg/+K8wwXAXEmjgLeHr60iMUPHfH4Nts6zJZ
4lQLG+kMNKtARuc8xQP/KxIwkuUkbb1gCwOcER+HDw6DSwAk4MtFzfEG7Ai7H5w2
XPB79I7FeKxithGaX11qowb3Obu10tMOc5WS8dkusXCLUOlqxVekGXn+DMu/Pfhi
Wxnmm6GoUOuzVACUvowE5Cz9QVCB1P8/PWo7lqLOrNmfMpxFATVyBbA1ijSeNhM3
wLFHTTsLMnmZv7+CkEh/tKzXGWZ0AMOFq1HDmWhSPejgSTKtM5pQyySBCTvx0kd0
bYCRviuEGXuneiBhV2AkauoetM9muT/Q69pxTIpDh9x30/7+bib8azVSnmnwkIiQ
q8sSK4wBOIqiZCGdDQBEqucEr+6po02MBwp7A5OArAETblkVUIg0wqiFkL3bgPgl
C7goR/p3BUfIslEcquHG+7hgFqk0pdZeLHibvzTKS/zBYfuzMt2tUb3PUkzqGZfV
8VMD268voHcLmDEMflCecx5bt90WY869e5xK0kDebWR69Otupq1LweNfJI8h5CcK
VsxlTbhCy0dYWZPwPIL4VfdGkjGdmcggeTVNjCJK4V9LUrJkiOc+nYoM2XtJKP2Z
YKNYDHhyP3uD7/5EAURkC0dq++jRSKhP2yj1q0V0FLzDDZwIOJ253SjlcRzt4oL+
RRb6Mn9eNHA=
=j0e4
-----END PGP SIGNATURE-----

J
J
Josselin Poiret wrote on 4 May 2023 21:14
Re: [bug#63263] [PATCH] gexp: Stop generating unreadable builder scripts.
(address . 63263@debbugs.gnu.org)
87y1m33o5e.fsf@jpoiret.xyz
Hi Chris and Ludo,

Christopher Baines <mail@cbaines.net> writes:

Toggle quote (9 lines)
> I guess my perspective on this is more from the operation of the guix
> data service, which is carefully computing and storing all of these
> broken derivations (and there's a lot, like 10,000+ per revision at the
> moment, since they change every time you compute them). This then
> propagates down to the build coordinator as well, since there's builds
> being submitted for all these broken derivations. I have considered
> trying to detect these breakages in the data service, but I'm not sure
> how to do it while removing the possibility of false positives.

I guess you already read the derivations from the data service to find
out what has changed, right? Would you also be able to try to read the
builder script from there, before trying to build? And if the
derivation is bad, signal it somehow and flag it for some sort of gc?
Although then, all other derivations depending on it would also need to
be gc'd, which might be annoying.

I don't know if the data service's architecture would allow this to be
done before trying to build derivations though, sorry in advance if that
would be too much work.

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCgAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmRUA/0QHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcaiucaC/46cA5Fnamrlu1fZ3ZeknxPuuHsj1+NTlaZ
GNdDkH07RPTDA0gl28CZUEgt/xYRwW8R0HGxK5xVMP3z0n/MOVwPfTZ1Lb3kOUaU
Qjc/qKh3EYrpyTHwed4AshNAE1SepSfYGnCq6KZ5M5XxcSAF42bgyDUmbFaUbRps
CYf5diJMSlIdZPTXrMYyAQbpNDZdX1wmKdLm+EXGli+NI4rXvPXjtm9MSIfM2i98
HVF5TCiXlg7hJeZRorymOPSf+Y9EVv/OqiZzQ1ojbzfoI9xFAn3FnjXHsB/iVCRQ
Z91jtJj9s9j/271lxbFx1yheNIDFLla5ETWuztQ3L1uGch6edvvRa15Jp7RXHfi2
BHO5OEWzV/AI4P2ockAHxYS6fhVeEdrgZVvkElOvxnP1p7WpfDP5sg53fqBEJWJD
nS1BBGAokegdmL8SF4R88GaazYBQIBLg/Y5mX9A8v8UcWqWbsqVDQO5XZDOR574k
4qTLv0UDzozq/DAWYjmJKkRFVf+zdU0=
=9oUI
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 5 May 2023 23:45
Re: bug#63263: [PATCH] gexp: Stop generating unreadable builder scripts.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 63263@debbugs.gnu.org)
87ild6mozb.fsf_-_@gnu.org
Hello!

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> Ludovic Courtès <ludo@gnu.org> writes:

[...]

Toggle quote (6 lines)
>> How about a linter instead, with the understanding that use of sexps in
>> packages is vanishing? Perhaps coupled with a ‘guix style’ automatic
>> rewriter.
>
> A linter might be helpful, but I'm not sure it'll help that much.

Yeah.

Another option is ‘guix style -S arguments’:
https://issues.guix.gnu.org/63320. Not an immediate fix, but a tool
that would let us move away more quickly from a situation that’s prone
to this kind of error.

[...]

Toggle quote (5 lines)
> I guess my perspective on this is more from the operation of the guix
> data service, which is carefully computing and storing all of these
> broken derivations (and there's a lot, like 10,000+ per revision at the
> moment, since they change every time you compute them).

Woow, that’s a lot! Could you send a sample of that list, for one
system type, to get an idea of what’s going on?

Thanks,
Ludo’.
C
C
Christopher Baines wrote on 6 May 2023 09:39
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 63263@debbugs.gnu.org)
87pm7d29cd.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (8 lines)
>> I guess my perspective on this is more from the operation of the guix
>> data service, which is carefully computing and storing all of these
>> broken derivations (and there's a lot, like 10,000+ per revision at the
>> moment, since they change every time you compute them).
>
> Woow, that’s a lot! Could you send a sample of that list, for one
> system type, to get an idea of what’s going on?

I think pretty much all the i586-gnu derivations were broken in this
way, on core-updates but then after the merge to master too. I think
I've "fixed" it now, although I think my change [1] needs some
improvement (I fixed some issues in [2], but I saw an error when cross
building).

-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmRWBTJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcEzg//ZSePJ2s7QWHOs6vF00uO9L+XKj6RhQ2A
Hn9NY00yRYamjqqfEmUXjFy95hohT8q0QbmV2HAT3Fgf4WX5fBOE8Bjp2dIz46rV
JnLZ/OIUv5oNGyZLZY+bVL2V0s2lFgxszoCzX7mDFzMprhSqrRccAYF0VMmHIYNZ
cHjWka0sNKqnmQ2OfCfTeUU0mRHNRLcEzILiAxaS54ABDH2Ln2MvMn5jY5bWMmlc
L1f8uoxIO0/Ql7c1ZRF8az3j8RiI1kgMCQ7MRNVqZAiD1iLPT6xjbfF1Pfp34ApR
LG9LZty/cRi2Sp0OMrjMJqBfQQ/76LfxI6Ly7KDrlCOdX/gbgm0WQW2mNIPrrmq1
HrjSkDhkqgWPqvncSepM0xe5LeOh0q4Bcb5TNyyiuTqAnQzFextdMfjjw93s0N0P
7d345Ksxp6Dmri6QOc80gjM+y26oHXf2vOZU+IyPa0ZcdI5YxO2TkMidBolsFcbP
WRIySwB7WyqB+d86kJFRH7quf7iERBCigdQv//UCqh4cfIKeBWN3mvN5k+f1Fde8
lKabunCGWaA4Q2KVS/DslRPorJ7RP96pUvFg/1MFEb1sBuwawtlXvBTbeuXhYAF4
lx4HDivXn+WiD0UcDksa16au1goVtLlcSQouVjLP5q3P09Doxc3hjR8bWzcis4MU
kNhg/mGqkwo=
=cMX1
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 6 May 2023 10:05
Re: [bug#63263] [PATCH] gexp: Stop generating unreadable builder scripts.
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 63263@debbugs.gnu.org)
87lei12820.fsf@cbaines.net
Josselin Poiret <dev@jpoiret.xyz> writes:

Toggle quote (22 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> I guess my perspective on this is more from the operation of the guix
>> data service, which is carefully computing and storing all of these
>> broken derivations (and there's a lot, like 10,000+ per revision at the
>> moment, since they change every time you compute them). This then
>> propagates down to the build coordinator as well, since there's builds
>> being submitted for all these broken derivations. I have considered
>> trying to detect these breakages in the data service, but I'm not sure
>> how to do it while removing the possibility of false positives.
>
> I guess you already read the derivations from the data service to find
> out what has changed, right? Would you also be able to try to read the
> builder script from there, before trying to build? And if the
> derivation is bad, signal it somehow and flag it for some sort of gc?
> Although then, all other derivations depending on it would also need to
> be gc'd, which might be annoying.
>
> I don't know if the data service's architecture would allow this to be
> done before trying to build derivations though, sorry in advance if that
> would be too much work.

It would do, but I'm not sure this would be as reliable as doing the
check from Guix, especially since the version of Guile used for the
checking might be different.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmRWC7dfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xd8yA/+NZ1HjOVWoUaNckfArWu8OH9OFAKLGKgQ
fOnCw4E6zV+NK9H/70IWYNh5NjlPj/lRLQdZ9WaCbHu7LW5UKgWK5J0j0Si2QNYf
PRxya+WmIwePKEnxbB2eLYXzFeaDVp35tyWsmEaOYP7OyPtw6ZeW9U5bWTt4j/oT
z5Ucj1wYHokVPsDpOlm9W53UYFYS/6VVH9LX6QEipuTwwZD4zqFkEK9DOgquzeWE
XTOwfMXxd4bCfQlGBNjGKqnm8TCE0CYz4SznIrFtII5a5K/WPXXIYtmIFun6J+cz
BrgNKTetIJVpYDETxkVx3NQYywxoO5zAUEnxVoyLCxEmtrpX4cuDihEcYg18Z6q1
QiiSsjhKBrkr5ZF9ZKM6sGzbGbO7SBJEymil4suuq4KTke970JD/Fs3D2pQRt9zx
gn9itM1p/FHZy1r271S4H3WYnWuutIVfWFgyc8JsdkN+oArp9y7Ng3EQWF/bjWc6
H5X+CXejVfoHRqMVTvuZKQuva+tJq6B61qpceYbg5qZsszcgF4AF8faAjVpi+fzn
BS79SmYIAuaSRqldnbk3qF48k80KgmFXkCyAEGXGxZrLGq2esLYOlzLPQhAFQB+l
otm++rzZye384GSgwilZcfTW38aceoIUk6wMqpoQcb/w554WkJFUuoZRmLnhvaC/
YUYWHPFWxuw=
=zZHD
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 10 May 2023 17:22
Re: bug#63263: [PATCH] gexp: Stop generating unreadable builder scripts.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 63263@debbugs.gnu.org)
87a5yc9po9.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (12 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>>> I guess my perspective on this is more from the operation of the guix
>>> data service, which is carefully computing and storing all of these
>>> broken derivations (and there's a lot, like 10,000+ per revision at the
>>> moment, since they change every time you compute them).
>>
>> Woow, that’s a lot! Could you send a sample of that list, for one
>> system type, to get an idea of what’s going on?
>
> I think pretty much all the i586-gnu derivations

Oh, I see. I’m less surprised then. :-)

Toggle quote (5 lines)
> were broken in this way, on core-updates but then after the merge to
> master too. I think I've "fixed" it now, although I think my change
> [1] needs some improvement (I fixed some issues in [2], but I saw an
> error when cross building).

I think we’re good now, right?

Ludo’.
C
C
Christopher Baines wrote on 10 May 2023 18:02
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 63263@debbugs.gnu.org)
87354418dr.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (23 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> Ludovic Courtès <ludo@gnu.org> writes:
>>
>>>> I guess my perspective on this is more from the operation of the guix
>>>> data service, which is carefully computing and storing all of these
>>>> broken derivations (and there's a lot, like 10,000+ per revision at the
>>>> moment, since they change every time you compute them).
>>>
>>> Woow, that’s a lot! Could you send a sample of that list, for one
>>> system type, to get an idea of what’s going on?
>>
>> I think pretty much all the i586-gnu derivations
>
> Oh, I see. I’m less surprised then. :-)
>
>> were broken in this way, on core-updates but then after the merge to
>> master too. I think I've "fixed" it now, although I think my change
>> [1] needs some improvement (I fixed some issues in [2], but I saw an
>> error when cross building).
>
> I think we’re good now, right?

I spotted problems again today. I'm not sure if they're new, or just
things I missed in the last round of fixes.

I'm waiting for the data service to give it's opinion on these changes:

-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmRbwFBfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xfszg//Uh43XEsO9xGBvD+1F7COerFN26dQqB9W
z1rBKbTI28m+AnJmNBlpNiDPk9VTFCL733ys1NYlSNpuskJwAQdAanGUQ5OEC6lc
QtPugR4ULDtYi6KIXY68ewjcHXBU24g/t7ulR3ik2jUjIK4HltfplJYRgN5EKvM+
0sV1l0Nfw4QekDU3F0OfCCA4cxLu/FOIgN/+2Ag6sy0ChIPK2OEY2Rns1dvDWW9Q
cFVjiOX0hunv+R464/sRtsI5MFppJSXAPOry+/1zVuvKswfWC6hEMQZ2eN159VnD
lLaNBd+dCWR1mK6b4O9uWw6gx2wy4D872WmNhqMm5WoSTBcd8gP58upJg8IE9RIu
OHtcg2FM3Qp/tsprGTieoP2I4fvwRx+VUregsOgqy4aDJisrzRuvqpV4jXDpx/9D
D3wtKE11iLLlrjGRfKZ0++3BHCexSWWmYE48L+/ZnIlMDzkxlD4+7fDYxZOqNrpE
sSoYjdRElvmcns85YoZAWvjFlPROyemPzWUG/+NCYBXKFIkrRk1hDD4P0LqREGYo
rocY37LXSn8iOjG/P9yGF3lB+S5lsW2pFw7f3/UuAx17D6MGoFUR8FSUpd4FPgM7
AWJ6PG4Byi112pDUCCq9FwWjKY8M3Z9q2lgyjWwHuzLUbZSLyUqvuwV9KeQw8i5h
bCiFZ0hX68I=
=n6Kq
-----END PGP SIGNATURE-----

M
M
Maxim Cournoyer wrote on 1 Sep 2023 16:16
(name . Christopher Baines)(address . mail@cbaines.net)
87v8cu2d2o.fsf_-_@gmail.com
Hi Christopher,

Christopher Baines <mail@cbaines.net> writes:

[...]

Toggle quote (18 lines)
>>> I think pretty much all the i586-gnu derivations
>>
>> Oh, I see. I’m less surprised then. :-)
>>
>>> were broken in this way, on core-updates but then after the merge to
>>> master too. I think I've "fixed" it now, although I think my change
>>> [1] needs some improvement (I fixed some issues in [2], but I saw an
>>> error when cross building).
>>
>> I think we’re good now, right?
>
> I spotted problems again today. I'm not sure if they're new, or just
> things I missed in the last round of fixes.
>
> I'm waiting for the data service to give it's opinion on these changes:
>
> https://issues.guix.gnu.org/63416

Was the problem resolved? If so, can we close this issue?

--
Thanks,
Maxim
C
C
Christopher Baines wrote on 2 Sep 2023 12:36
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 63263-close@debbugs.gnu.org)
87ledoeu5p.fsf@cbaines.net
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (26 lines)
> Hi Christopher,
>
> Christopher Baines <mail@cbaines.net> writes:
>
> [...]
>
>>>> I think pretty much all the i586-gnu derivations
>>>
>>> Oh, I see. I’m less surprised then. :-)
>>>
>>>> were broken in this way, on core-updates but then after the merge to
>>>> master too. I think I've "fixed" it now, although I think my change
>>>> [1] needs some improvement (I fixed some issues in [2], but I saw an
>>>> error when cross building).
>>>
>>> I think we’re good now, right?
>>
>> I spotted problems again today. I'm not sure if they're new, or just
>> things I missed in the last round of fixes.
>>
>> I'm waiting for the data service to give it's opinion on these changes:
>>
>> https://issues.guix.gnu.org/63416
>
> Was the problem resolved? If so, can we close this issue?

Nope, but the issue covering this is #62051.

We can close this patch issue though, as I think there were objections
to the approach.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmTzENJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xei+A//QgwbKMo3zma2Umt3HTFwlKDdPNIPumgb
yn4bXwkuw+de8hh2rPNtPzoQMeGnb9O0pZ+Wz1SLZefDw5jVIbYc/9D4G2E7mM/k
lGf0UXtEQB/0jTqd+/eIY/86IptGgDyhDvrbW/6XP3GYq4Aa9Ln1wiaDBbcgyty4
lqVXeB1jHPj669hVJYzYyqpwnGpxKf/+JBkBJKJov+0JzRjo0AQ/j3f/jOkCB8mj
VUFQqTj6xgAxTN90Ypr5Fu+U67j2ub7v/+nHPAgv/dS6aEUPRghwbmW0qWodASAF
o+O4cdX49eNSzMKf3viXADfc+79z8Toe1RoPpWLQI5WrZc8RPJ/mwk/y0gSNzrot
3O5GcHgL7U3MLk3uQQBDK2G5DIRm2PVhzvM7+zEpk4X3Z4VPVc2yzgINv9rg8x7W
uyxusqHYYcmvvSV3dGsNC5XsPcagtB5fP51shP09pRB7OffwhFygOK5u1UmEPj9l
PyKLN2Co9Yf4sE9GIbxBfO5iwsLwo/UrblkklB1BkAXvgvUQjNFkHvByLsWndSTG
EXmkPIOvFnl+zJcpMcfKGGXleAV2S2Sjbn6qOYWAm7+l4VXbAbJGCaq9r/0JbohP
PB514w8G4Nzlpx3nX8S3ST4QR4escz3c78TVvWcyLn6iAlSPxfuG/HC7j8fi44pW
1WTlnMjiFLc=
=0VvU
-----END PGP SIGNATURE-----

M
M
Maxim Cournoyer wrote on 3 Sep 2023 16:54
(name . Christopher Baines)(address . mail@cbaines.net)(address . 63263-close@debbugs.gnu.org)
87bkejux2f.fsf@gmail.com
Hi,

[...]

Toggle quote (5 lines)
> Nope, but the issue covering this is #62051.
>
> We can close this patch issue though, as I think there were objections
> to the approach.

Thank you. By the way, I think '-close' has been obsoleted by '-done'
in Debbugs; not sure what it does differently, if anything.

--
Thanks,
Maxim
?