(address . bug-guix@gnu.org)
Hello,
Dante package is not compiled with preloading support but it
could be
To reproduce :
guix shell dante w3m
echo "<hmtl><h1> Hello </h1> <p> World ! </p> </html>" | (
export SOCKS_SERVER="127.0.0.1:1"
exec socksify w3m -T text/html -dump
)
Following error is returned
error: dante client not built with preloading support.
Here is the result without socksify
```
echo "<hmtl><h1> Hello </h1> <p> World ! </p> </html>" | (w3m -T text/html -dump)
```
For additional information, I faced the problem when using the "html"
filter of aerc
cat /gnu/store/...aerc.../share/aerc/filters/html
```
#!/gnu/store/rib9g2ig1xf3kclyl076w28parmncg4k-bash-minimal-5.1.16/bin/sh
# aerc filter which runs w3m using socksify (from the dante package) to prevent
# any phoning home by rendered emails
export SOCKS_SERVER="127.0.0.1:1"
exec socksify w3m \
-I UTF-8 \
-T text/html \
-cols $(tput cols) \
-dump \
-o display_image?lse \
-o display_link_number=true
```
It seems that there was also these problem on the side of nixos :