[PATCH] gnu: bear: Build against 'abseil-cpp-cxxstd11'.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Andrew Whatson
Owner
unassigned
Submitted by
Andrew Whatson
Severity
normal
A
A
Andrew Whatson wrote on 3 May 2023 08:43
(address . guix-patches@gnu.org)(name . Andrew Whatson)(address . whatson@tailcall.au)
85ebc606e3a576dec1497b1a3ff141d3e4ea6193.1683096215.git.whatson@tailcall.au
Fixes a linker error when building bear, caused by incompatibility
between abseil-cpp used by bear and abseil-cpp-cxxstd11 used by grpc.

* gnu/packages/build-tools.scm (bear)[native-inputs]: Use
ABSEIL-CPP-CXXSTD11.
---
gnu/packages/build-tools.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index bcca229466..33d91e6043 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -154,7 +154,7 @@ (define-public bear
("re2" ,re2)
("spdlog" ,spdlog-1.10)))
(native-inputs
- `(("abseil-cpp" ,abseil-cpp)
+ `(("abseil-cpp" ,abseil-cpp-cxxstd11)
("googletest" ,googletest)
("openssl" ,openssl)
("pkg-config" ,pkg-config)

base-commit: 94e2e3553440a2a5ac4a312e80b8ea21ddebafeb
prerequisite-patch-id: 3d7fb3e786cac039448473f020bca5a1ba784ba7
prerequisite-patch-id: 9e65215b0ab7e634442ffb20fa51c062754fef36
prerequisite-patch-id: e6f89e5aa48e27e1a05bb25cdf7306904fb97b87
prerequisite-patch-id: dea0b27507762194e6d3323ee383375ce9bb5b3f
prerequisite-patch-id: 4a151f7ab214688100ad9be43cc517d4e83fae5b
prerequisite-patch-id: aa79730a845863aa68c4413f01e9957159d9b37b
prerequisite-patch-id: c991685207a07ca27bf7add0ac6b931919e35652
--
2.39.2
L
L
Ludovic Courtès wrote on 5 May 2023 23:53
(name . Andrew Whatson)(address . whatson@tailcall.au)(address . 63243-done@debbugs.gnu.org)
87ednumolr.fsf@gnu.org
Hi Andrew,

Andrew Whatson <whatson@tailcall.au> skribis:

Toggle quote (6 lines)
> Fixes a linker error when building bear, caused by incompatibility
> between abseil-cpp used by bear and abseil-cpp-cxxstd11 used by grpc.
>
> * gnu/packages/build-tools.scm (bear)[native-inputs]: Use
> ABSEIL-CPP-CXXSTD11.

Applied, thanks!

Ludo’.
Closed
?