[PATCH 0/2] gnu: neovim: Update to 0.9.0

  • Done
  • quality assurance status badge
Details
3 participants
  • Benjamin
  • Efraim Flashner
  • zimoun
Owner
unassigned
Submitted by
Benjamin
Severity
normal
Merged with

Debbugs page

Benjamin wrote 2 years ago
(address . guix-patches@gnu.org)(name . Benjamin)(address . benjamin@uvy.fr)
cover.1682982767.git.benjamin@uvy.fr
Hello,

This is my first contribution to guix (and first time using git email
flow), so I hope I did everything as expected.

This patches update neovim to 0.9.0.

It was required to bump its dependency tree-sitter to 0.20.8 as
there were some missing symbols with 0.20.7.
I also fixed the script avoiding to include gcc in dependencies
as the makefile as moved.

Benjamin (2):
gnu: tree-sitter: Update to 0.20.8
gnu: neovim update to 0.9.0

gnu/packages/tree-sitter.scm | 4 ++--
gnu/packages/vim.scm | 8 ++++----
2 files changed, 6 insertions(+), 6 deletions(-)


base-commit: f21007ce4aceeacf5bbfc7cd45d526073141f194
--
2.39.2
Benjamin wrote 2 years ago
[PATCH 1/2] gnu: tree-sitter: Update to 0.20.8
(address . 63227@debbugs.gnu.org)(name . Benjamin)(address . benjamin@uvy.fr)
11e7c4aab6fc25833dd7fa2dd7f04350bff54cbd.1682982767.git.benjamin@uvy.fr
---
gnu/packages/tree-sitter.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index b91345bb36..386409914b 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -38,7 +38,7 @@ (define-module (gnu packages tree-sitter)
(define-public tree-sitter
(package
(name "tree-sitter")
- (version "0.20.7")
+ (version "0.20.8")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -47,7 +47,7 @@ (define-public tree-sitter
(file-name (git-file-name name version))
(sha256
(base32
- "1nv2a2hr22w8ix71b6rkkxv9rfvhvwlmyql0g6lva9qzj4vy50p4"))
+ "10w17lfn9asqrk612xivkx26lc620s3nnm30hhlyqd4bj19k7gyv"))
(modules '((guix build utils)))
(snippet #~(begin
;; Remove bundled ICU parts
--
2.39.2
Benjamin wrote 2 years ago
[PATCH 2/2] gnu: neovim update to 0.9.0
(address . 63227@debbugs.gnu.org)(name . Benjamin)(address . benjamin@uvy.fr)
37b1b8c9b26e342015ff1263cc4d173f248d5d3e.1682982767.git.benjamin@uvy.fr
---
gnu/packages/vim.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index d555194d0b..e5e9d67c4b 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -693,7 +693,7 @@ (define-public neovim-syntastic
(define-public neovim
(package
(name "neovim")
- (version "0.8.3")
+ (version "0.9.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -702,7 +702,7 @@ (define-public neovim
(file-name (git-file-name name version))
(sha256
(base32
- "1zff73yxbnxym6sn43xk6r0zc2ncingsib81v9g39ibrcinpwaa9"))))
+ "0xsvhm191cy5ivcw0c8dnpzbpcvvn5hsnkzkipr2aabgrsgqj628"))))
(build-system cmake-build-system)
(arguments
(list #:modules
@@ -751,8 +751,8 @@ (define-public neovim
(lambda _
;; nvim remembers its build options, including the compiler with
;; its complete path. This adds gcc to the closure of nvim, which
- ;; doubles its size. We remove the refirence here.
- (substitute* "cmake/GetCompileFlags.cmake"
+ ;; doubles its size. We remove the reference here.
+ (substitute* "cmake.config/versiondef.h.in"
(("\\$\\{CMAKE_C_COMPILER\\}") "/gnu/store/.../bin/gcc"))
#t)))))
(inputs (list libuv-for-luv
--
2.39.2
zimoun wrote 2 years ago
control message for bug #63227
(address . control@debbugs.gnu.org)
86h6stz65m.fsf@gmail.com
merge 63227 63226
quit
Efraim Flashner wrote 2 years ago
Re: [bug#63227] [PATCH 0/2] gnu: neovim: Update to 0.9.0
(name . Benjamin)(address . benjamin@uvy.fr)(address . 63227-done@debbugs.gnu.org)
ZFdy0BpkJ4DyEByn@3900XT
Thanks for the patch!

On Tue, May 02, 2023 at 01:25:02AM +0200, Benjamin wrote:
Toggle quote (5 lines)
> Hello,
>
> This is my first contribution to guix (and first time using git email
> flow), so I hope I did everything as expected.

There's a file in the guix tree at etc/committer.scm which takes care of
some of the less complex commit messages. I rounded out your commit
messages but otherwise everything looks good.

Toggle quote (20 lines)
> This patches update neovim to 0.9.0.
>
> It was required to bump its dependency tree-sitter to 0.20.8 as
> there were some missing symbols with 0.20.7.
> I also fixed the script avoiding to include gcc in dependencies
> as the makefile as moved.
>
> Benjamin (2):
> gnu: tree-sitter: Update to 0.20.8
> gnu: neovim update to 0.9.0
>
> gnu/packages/tree-sitter.scm | 4 ++--
> gnu/packages/vim.scm | 8 ++++----
> 2 files changed, 6 insertions(+), 6 deletions(-)
>
>
> base-commit: f21007ce4aceeacf5bbfc7cd45d526073141f194
> --
> 2.39.2

Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmRXctAACgkQQarn3Mo9
g1EEiw/+PYafKjZGQXDoxDlE4tgEe+6xfxPjb7AUQD/Wj1qJy2xEYycia2g7UZYy
/faVLH2btWFN1pduXcV2vgw+ltVlCBVKxi43q5QCV+lbhiZx6Moi2sfUSuUW6VKv
TujaSEBrUKIhu5grDuqDNWHko/PrRBqI1RwUPI4zNxMN320WrDGpndA73/cCXrMB
hYhjeahSusnFb8xIQX1b4TwaovS6R/ezRuMnNYE/0QcYhqCu4L2E3Qh42+CRvd4G
VJ07pLk+eqFRmd83lcVJPHVlu+6q20pUtahqdzptQMQwAcnYIPPZiN8zJSAwcsc2
cOg9sN5QKvGNNWoGKdGzJg1CkGhNmOhTFV9nCej9rqgpS7N+c1PQrdHLDgDVK936
HoJxZjhZpPKUxr0QGSGzALv9e78ocPy/KBYYjGMVOJtCMwlsusQlmimfG8EcDIoH
baRR+neJGWzsPHaXrgfongcLr9JdFSQFk5UTz7Vh1hWZmIP6R1dRUZOWjf1i+eM+
1i+Xi5uopnDfwW6NqQgrWZ5cajXBRKefjdEHtyzS3118QTL2jIcqOUxtWSOzUoJe
4H9R4gq9WTmNo5l4JeFHll4A/roj5R0gV4+fEsNpH4jDWESAuBqCDR+d5nC+IM9e
ZQ8iiP8a+r6B9wHUaIlmaQqdotlHm17Hwt62kJn1G8iKXkwhngA=
=92pM
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63227@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63227
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help