[PATCH] gnu: git-crypt: Fix build issues on openssl 3

  • Done
  • quality assurance status badge
Details
3 participants
  • Giovanni Biscuolo
  • Ludovic Courtès
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal

Debbugs page

Sergey Trofimov wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20230501161842.5622-1-sarg@sarg.org.ru
* gnu/packages/version-control.scm (git-crypt):
Add compilation flag to work around openssl 3 compatibility.
---
gnu/packages/version-control.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c2ec490383..ba213bafa6 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -936,6 +936,7 @@ (define-public git-crypt
#t))
(replace 'build
(lambda _
+ (setenv "CXXFLAGS" "-DOPENSSL_API_COMPAT=0x30000000L")
(invoke "make" "ENABLE_MAN=yes")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
--
2.39.2
Giovanni Biscuolo wrote 2 years ago
(address . 63209@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
87354floq5.fsf@xelera.eu
Hello,

thank you for your patch: I applied it and it works.

This is also related to bug#63202

Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (22 lines)
> * gnu/packages/version-control.scm (git-crypt):
> Add compilation flag to work around openssl 3 compatibility.
> See https://github.com/AGWA/git-crypt/issues/232
> ---
> gnu/packages/version-control.scm | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
> index c2ec490383..ba213bafa6 100644
> --- a/gnu/packages/version-control.scm
> +++ b/gnu/packages/version-control.scm
> @@ -936,6 +936,7 @@ (define-public git-crypt
> #t))
> (replace 'build
> (lambda _
> + (setenv "CXXFLAGS" "-DOPENSSL_API_COMPAT=0x30000000L")
> (invoke "make" "ENABLE_MAN=yes")))
> (replace 'install
> (lambda* (#:key outputs #:allow-other-keys)
> --
> 2.39.2

Thanks, Gio'

--
Giovanni Biscuolo

Xelera IT Infrastructures
-----BEGIN PGP SIGNATURE-----

iQJABAEBCgAqFiEERcxjuFJYydVfNLI5030Op87MORIFAmRQMJIMHGdAeGVsZXJh
LmV1AAoJENN9DqfOzDkS6uEQALw1kQzcnY+CWnOJEmmqBSrA6kclUQjH5OntwZTK
VlPIKrDy47U53ub6NmFJMGz7meKeY1Sz0XGNti9bzQXIoTDb0aJuEFZeHCL6c//o
s0PI6eyfmPyS4KvxhMJhMfFyBj6fNtWNMqUcE3Zywo84OdfUHAPi41T5MFNfu2fd
ie+Zxj5pH9Dv2OhhWyco54yCuXvCKOCAfcZB8BUVfgVyJuLD+iMPf5uNY3THacsB
eM798IghxsgszJKB3d/HicEqOoiSeER2YkTXM9aFfaSBieVaI6Po2vgzCBMq7VuA
UBcfbqqoYb1qbB5F0yk6r9Cnyx6vGHcFvQEBwbn5HuLR3l1QRvfwa0vth8a6+ogo
wbW6QfrKHjGv17i193s+NoksH3rmSqxquecPkW4iR8F61ygpVbdUOdI5ob0GeCXY
Kk5dkYslD4Z+P7wVmID87VWCccWZXYSyI7DHRj2OXc/wnrAqBw6VnBminvQncfzI
rfRfFiHDuc7OGtOVXUyu3QSLNRhyWgPtUWlnwIxJLNuK5Ty2R85wd1xvQbqp+pY/
ruoQwz/fZUgzyq6FLqqWImSwkY4J+eO8f4poirahMRWb3nFobq1V7TquC7dSsApX
LBLq60b1XnqbsuzBRHKUlXLdPqY+3WHTTfhHjPXESuNYZqNS2s+SQk0kFWLrP3bk
m1Jo
=r6h4
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 2 years ago
Re: bug#63209: [PATCH] gnu: git-crypt: Fix build issues on openssl 3
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 63209-done@debbugs.gnu.org)
871qjumoac.fsf@gnu.org
Hi,

Sergey Trofimov <sarg@sarg.org.ru> skribis:

Toggle quote (4 lines)
> * gnu/packages/version-control.scm (git-crypt):
> Add compilation flag to work around openssl 3 compatibility.
> See https://github.com/AGWA/git-crypt/issues/232

Applied the patch, with these two lines as a comment in the code.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63209@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63209
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help