[PATCH] gnu: gstreamer: Depend on glib-next

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230501161702.29513-1-atai@atai.org
* gnu/packages/gstreamer.scm: gstreamer: [arguments] (configure-flags): Add "--wrap-mode=nofallback" to ensure no subproject sources in repo are used
[propagated-inputs]: Use glib-next
[inputs]: Use glib-next

* gnu/packages/gstreamer.scm: gst-plugins-base: [propagated-inputs]: Use glib-next
[inputs]: Use glib-next

* gnu/packages/gstreamer.scm: gst-plugins-bad: [propagated-inputs]: Use glib-next. Add dav1d
[inputs]: Use glib-next

* gnu/packages/gstreamer.scm: gst-plugins-ugly: [propagated-inputs]: Use glib-next
[inputs]: Use glib-next

* gnu/packages/gstreamer.scm: gst-editing-services [propagated-inputs]: Use glib-next
[inputs]: Use glib-next
---
gnu/packages/gstreamer.scm | 26 ++++++++++++++------------
1 file changed, 14 insertions(+), 12 deletions(-)

Toggle diff (126 lines)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 8971c11479..ea7b9f1229 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -474,6 +474,7 @@ (define-public gstreamer
(build-system meson-build-system)
(arguments
(list #:disallowed-references (list python)
+ #:configure-flags #~(list "--wrap-mode=nofallback")
#:phases
#~(modify-phases %standard-phases
#$@%common-gstreamer-phases
@@ -506,12 +507,12 @@ (define-public gstreamer
;; Requires: glib-2.0, gobject-2.0
;; Requires.private: gmodule-no-export-2.0 libunwind libdw
(list elfutils ;libdw
- glib libunwind))
+ glib-next libunwind))
(native-inputs
(list bash-completion
bison flex
gettext-minimal
- `(,glib "bin")
+ `(,glib-next "bin")
gobject-introspection
perl
pkg-config
@@ -553,7 +554,7 @@ (define-public gst-plugins-base
"0jcxcx4mgfjvfb3ixibwhx8j330mq3ap469w7hapm6z79q614rgb"))))
(build-system meson-build-system)
(propagated-inputs
- (list glib ;required by gstreamer-sdp-1.0.pc
+ (list glib-next ;required by gstreamer-sdp-1.0.pc
gstreamer ;required by gstreamer-plugins-base-1.0.pc
libgudev ;required by gstreamer-gl-1.0.pc
;; wayland-client.h is referred to in
@@ -582,7 +583,7 @@ (define-public gst-plugins-base
zlib))
(native-inputs
(list pkg-config
- `(,glib "bin")
+ `(,glib-next "bin")
gobject-introspection
python-wrapper
gettext-minimal
@@ -690,7 +691,7 @@ (define libsoup
(setenv "DBUS_FATAL_WARNINGS" "0"))))))
(native-inputs
(list gettext-minimal
- `(,glib "bin")
+ `(,glib-next "bin")
gobject-introspection
gsettings-desktop-schemas
libxml2
@@ -704,7 +705,7 @@ (define libsoup
cairo
flac
(librsvg-for-system)
- glib
+ glib-next
glib-networking
glu
gtk+
@@ -827,7 +828,7 @@ (define-public gst-plugins-bad
(list gstreamer gst-plugins-base))
(native-inputs
(list gettext-minimal
- `(,glib "bin") ; for glib-mkenums, etc.
+ `(,glib-next "bin") ; for glib-mkenums, etc.
gobject-introspection
gsettings-desktop-schemas
gst-plugins-good ;for tests
@@ -845,12 +846,13 @@ (define-public gst-plugins-bad
;; ccextractor
chromaprint
curl
+ dav1d
directfb
;; dssim
faad2
flite
fluidsynth
- glib
+ glib-next
glib-networking
glu
gsm
@@ -971,7 +973,7 @@ (define-public gst-plugins-ugly
(setenv "DBUS_FATAL_WARNINGS" "0"))))))
(native-inputs
(list gettext-minimal
- `(,glib "bin")
+ `(,glib-next "bin")
gobject-introspection
gsettings-desktop-schemas
perl
@@ -979,7 +981,7 @@ (define-public gst-plugins-ugly
python-wrapper
xorg-server-for-tests))
(inputs
- (list glib
+ (list glib-next
glib-networking
liba52
libcdio
@@ -1042,11 +1044,11 @@ (define-public gst-editing-services
(propagated-inputs
(list gstreamer gst-plugins-base))
(inputs
- (list glib glib-networking gtk+ libxml2))
+ (list glib-next glib-networking gtk+ libxml2))
(native-inputs
(list flex
gobject-introspection
- `(,glib "bin")
+ `(,glib-next "bin")
gst-plugins-bad
gst-plugins-good
perl

base-commit: 23552fb2fbcb78757e8b563de9466831f6386105
prerequisite-patch-id: 3805e062116fd14a78ca03847b237e75977c6d8d
prerequisite-patch-id: 9967fd9b0de5c36d810ca5c346e49762dfd3dad8
prerequisite-patch-id: f5feb08c9249508d22e0debbe47222324e9f354e
--
2.39.2
Liliana Marie Prikler wrote 2 years ago
1fd375c2cb1e62221bb91a5502f4bded3a72ffc7.camel@gmail.com
Am Montag, dem 01.05.2023 um 09:17 -0700 schrieb Andy Tai:
Toggle quote (5 lines)
> * gnu/packages/gstreamer.scm: gstreamer: [arguments] (configure-
> flags): Add "--wrap-mode=nofallback" to ensure no subproject sources
> in repo are used
>   [propagated-inputs]: Use glib-next
>   [inputs]: Use glib-next
We prefer not to bundle things, tyvm.

Toggle quote (16 lines)
> * gnu/packages/gstreamer.scm: gst-plugins-base:   [propagated-
> inputs]: Use glib-next
>   [inputs]: Use glib-next
>
> * gnu/packages/gstreamer.scm: gst-plugins-bad:   [propagated-inputs]:
> Use glib-next. Add dav1d
>   [inputs]: Use glib-next
>
> * gnu/packages/gstreamer.scm: gst-plugins-ugly:   [propagated-
> inputs]: Use glib-next
>   [inputs]: Use glib-next
>
> * gnu/packages/gstreamer.scm: gst-editing-services   [propagated-
> inputs]: Use glib-next
>   [inputs]: Use glib-next
> ---
Is there a *good* reason to do this now? Note that gnome-team is
working on getting glib 2.76 everywhere, including GStreamer.

Cheers
Andy Tai wrote 2 years ago
(address . 63208@debbugs.gnu.org)
CAJsg1E9LoUiqApH1BPgmOWemMfMVyr5o3tK0s=F5PbBKj_M_5g@mail.gmail.com
Hi, I will revise the patch to only keep the config flag for not using
subprojects as the Guix GNOME team is working on moving to glib latest
version
Andy Tai wrote 2 years ago
(address . 63208@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230502054853.31446-1-atai@atai.org
* gnu/packages/gstreamer.scm: gstreamer: [arguments] (configure-flags): Add "--wrap-mode=nofallback" to ensure no subproject sources in repo are used
---
gnu/packages/gstreamer.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 8971c11479..55876268cc 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -474,6 +474,7 @@ (define-public gstreamer
(build-system meson-build-system)
(arguments
(list #:disallowed-references (list python)
+ #:configure-flags #~(list "--wrap-mode=nofallback")
#:phases
#~(modify-phases %standard-phases
#$@%common-gstreamer-phases

base-commit: 854c57c3525325070e261a2e6f81d4016ef44bfa
--
2.39.2
Liliana Marie Prikler wrote 2 years ago
dd66919862afeb4252d2ca9ce0bfaec0fe27f642.camel@gmail.com
Am Montag, dem 01.05.2023 um 22:48 -0700 schrieb Andy Tai:
Toggle quote (3 lines)
> * gnu/packages/gstreamer.scm: gstreamer: [arguments] (configure-
> flags): Add "--wrap-mode=nofallback" to ensure no subproject sources
> in repo are used
For the ChangeLog part, "Add <flag>." is typically enough. Rationale
ought to be explained before the ChangeLog or in the code -- preferably
the latter for simple patches like the one at hand and the former if a
complex topic needs to be summarized.
Toggle quote (18 lines)
> ---
>  gnu/packages/gstreamer.scm | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
> index 8971c11479..55876268cc 100644
> --- a/gnu/packages/gstreamer.scm
> +++ b/gnu/packages/gstreamer.scm
> @@ -474,6 +474,7 @@ (define-public gstreamer
>      (build-system meson-build-system)
>      (arguments
>       (list #:disallowed-references (list python)
> +           #:configure-flags #~(list "--wrap-mode=nofallback")
>             #:phases
>             #~(modify-phases %standard-phases
>                 #$@%common-gstreamer-phases
>
> base-commit: 854c57c3525325070e261a2e6f81d4016ef44bfa
On the topic of wrapping dependencies: In Guix, we prefer to unbundle
them already through snippets in the source; thus, this configure-flag
would be obsolete in the ideal case. You can of course still add it
for good measure, but I'd argue it's more important to tackle the the
actual bundle first.

Cheers
Andy Tai wrote 2 years ago
Re: Processed: your mail
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)(address . tracker@debbugs.gnu.org)
CAJsg1E8sVg_K=G7q_k6FJdNH4hxOivLSQ0=H6BQ+XQ_uQtmaqw@mail.gmail.com
reopen 63028
close 63208

thanks


sorry for mixing up the bug numbers

On Sun, May 7, 2023 at 5:17 PM GNU bug tracker automated control
server <control@debbugs.gnu.org> wrote:
Toggle quote (17 lines)
>
> Processing commands for control@debbugs.gnu.org:
>
> > close 63028
> bug#63028: 28.2; Rendering Traditional Mongolian Script
> bug closed, send any further explanations to
> 63028@debbugs.gnu.org and "Garid Z." <garidzorigoo@gmail.com>
>
> > thanks
> Stopping processing here.
>
> Please contact help-debbugs@gnu.org if you need assistance.
>
> GNU bugs database, https://debbugs.gnu.org/



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2023 民國112年
自動的精神力是信仰與覺悟
自動的行為力是勞動與技能
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63208@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63208
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help