[PATCH] gnu: Add juce.

  • Open
  • quality assurance status badge
Details
One participant
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal
S
S
Sughosha wrote on 1 May 2023 07:49
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
82Vq54ICY2wY3ste1ysyzh2OlgViC2d6cXej6r12bRJd1BcNtggmr6180ZNeCvNOoItWOTzDf-wx2KCQvHemXOy-NFD0Kq8XCfUCNfySEkc=@proton.me
* gnu/packages/cpp.scm (juce): New variable.
---
gnu/packages/cpp.scm | 55 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (87 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 023d1c0..5945923 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -66,6 +66,7 @@
#:use-module (guix gexp)
#:use-module (gnu packages)
#:use-module (gnu packages assembly)
+ #:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages build-tools)
@@ -82,6 +83,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libunwind)
#:use-module (gnu packages linux)
@@ -98,6 +100,7 @@
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
+ #:use-module (gnu packages webkit)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (ice-9 match))
@@ -2430,6 +2433,58 @@ queues, resource pools, strings, etc.
@end itemize")
(license license:zlib))))
+(define-public juce
+ (package
+ (name "juce")
+ (version "7.0.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/juce-framework/JUCE")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zfkyf9gwwvv0mrslvvjlh6gxv1zd50bkcal54x1kqil46hps49m"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f ;no test suite
+ #:configure-flags #~(list "-DJUCE_TOOL_INSTALL_DIR=bin")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute*
+ "extras/Projucer/Source/ProjectSaving/jucer_ProjectExport_CodeBlocks.h"
+ (("/usr/include/freetype2")
+ (string-append #$freetype "/include/freetype2")))
+ (substitute*
+ "modules/juce_graphics/native/juce_linux_Fonts.cpp"
+ (("/etc/fonts")
+ (string-append #$fontconfig "/etc/fonts"))))))))
+ (native-inputs
+ (list alsa-lib
+ curl
+ jack-1
+ libx11
+ pkg-config
+ webkitgtk-with-libsoup2))
+ (inputs (list fontconfig freetype libjpeg-turbo libpng))
+ (home-page "https://juce.com")
+ (synopsis "Cross-platform C++ application framework")
+ (description
+ "JUCE is a cross-platform C++ application framework for creating
+applications including VST, VST3, AU, AUv3, AAX and LV2 audio plug-ins and
+plug-in hosts.")
+ (license
+ (list license:asl2.0 ;for Oboe and AudioUnitSDK
+ license:bsd-3 ;for FLAC, Ogg Vorbis and OpenGL Extension Wrangler
+ license:expat ;for Mesa 3-D graphics and jucer icons
+ license:gpl3 ;for JUCE and VST3 SDK
+ license:ijg ;for jpeglib
+ license:isc ;for LV2 SDK
+ license:zlib)))) ;for pngLib, zlib and Box2D
+
(define-public ftxui
(package
(name "ftxui")
--
libgit2 1.5.1
S
S
Sughosha wrote on 15 Jun 2023 06:48
[PATCH v2] gnu: Add juce.
(name . 63199@debbugs.gnu.org)(address . 63199@debbugs.gnu.org)
wfGJW8BJEeU_Pfi_qFMUFmbc78m2IoadeslsJZB_KP1bOpORM_87vNu_O5UjaXcbNFvkY4yM3F-YJ2Tcr8l07p8NYLbK-L2L8FFWNKkBIlY=@proton.me
* gnu/packages/cpp.scm (juce): New variable.
---
gnu/packages/cpp.scm | 55 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (87 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 365b15a..47b1117 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -68,6 +68,7 @@ (define-module (gnu packages cpp)
#:use-module (guix gexp)
#:use-module (gnu packages)
#:use-module (gnu packages assembly)
+ #:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages benchmark)
@@ -86,6 +87,7 @@ (define-module (gnu packages cpp)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libunwind)
#:use-module (gnu packages linux)
@@ -102,6 +104,7 @@ (define-module (gnu packages cpp)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
+ #:use-module (gnu packages webkit)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
;; Using autoload to avoid a cycle.
@@ -2513,6 +2516,58 @@ (define-public wdl
@end itemize")
(license license:zlib))))
+(define-public juce
+ (package
+ (name "juce")
+ (version "7.0.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/juce-framework/JUCE")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zfkyf9gwwvv0mrslvvjlh6gxv1zd50bkcal54x1kqil46hps49m"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f ;no test suite
+ #:configure-flags #~(list "-DJUCE_TOOL_INSTALL_DIR=bin")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute*
+ "extras/Projucer/Source/ProjectSaving/jucer_ProjectExport_CodeBlocks.h"
+ (("/usr/include/freetype2")
+ (search-input-directory inputs "/include/freetype2")))
+ (substitute*
+ "modules/juce_graphics/native/juce_linux_Fonts.cpp"
+ (("/etc/fonts")
+ (search-input-directory inputs "/etc/fonts"))))))))
+ (native-inputs
+ (list alsa-lib
+ curl
+ jack-1
+ libx11
+ pkg-config
+ webkitgtk-with-libsoup2))
+ (inputs (list fontconfig freetype libjpeg-turbo libpng))
+ (home-page "https://juce.com")
+ (synopsis "Cross-platform C++ application framework")
+ (description
+ "JUCE is a cross-platform C++ application framework for creating
+applications including VST, VST3, AU, AUv3, AAX and LV2 audio plug-ins and
+plug-in hosts.")
+ (license
+ (list license:asl2.0 ;for Oboe and AudioUnitSDK
+ license:bsd-3 ;for FLAC, Ogg Vorbis and OpenGL Extension Wrangler
+ license:expat ;for Mesa 3-D graphics and jucer icons
+ license:gpl3 ;for JUCE and VST3 SDK
+ license:ijg ;for jpeglib
+ license:isc ;for LV2 SDK
+ license:zlib)))) ;for pngLib, zlib and Box2D
+
(define-public ftxui
(package
(name "ftxui")
--
libgit2 1.5.1
S
S
Sughosha wrote on 20 Jun 2023 10:23
[PATCH v3] gnu: Add juce.
(name . 63199@debbugs.gnu.org)(address . 63199@debbugs.gnu.org)
tIuSvBCo7KIMp_Cu5gEQWDygEWGRsGfh7qwoK3OlQe6GdpNurj1FzWafq_jCsfrieaz8mqUmHC4W6oFlwlb9XFJq_Pte70e2R0wwRBSvJXU=@proton.me
From a438104658df4365958f7e4cb2620d4df378024e Mon Sep 17 00:00:00 2001

* gnu/packages/cpp.scm (juce): New variable.
---
gnu/packages/cpp.scm | 57 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (89 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 365b15a..37b81b7 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -68,6 +68,7 @@ (define-module (gnu packages cpp)
#:use-module (guix gexp)
#:use-module (gnu packages)
#:use-module (gnu packages assembly)
+ #:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages benchmark)
@@ -86,6 +87,7 @@ (define-module (gnu packages cpp)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libunwind)
#:use-module (gnu packages linux)
@@ -102,6 +104,7 @@ (define-module (gnu packages cpp)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
+ #:use-module (gnu packages webkit)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
;; Using autoload to avoid a cycle.
@@ -2513,6 +2516,60 @@ (define-public wdl
@end itemize")
(license license:zlib))))
+(define-public juce
+ (package
+ (name "juce")
+ (version "7.0.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/juce-framework/JUCE")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zfkyf9gwwvv0mrslvvjlh6gxv1zd50bkcal54x1kqil46hps49m"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f ;no test suite
+ #:configure-flags #~(list "-DJUCE_TOOL_INSTALL_DIR=bin")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute*
+ (find-files "." "jucer_ProjectExport_CodeBlocks.h$")
+ (("/usr/include/freetype2")
+ (search-input-directory inputs "/include/freetype2")))
+ (substitute*
+ (find-files "." "juce_linux_Fonts.cpp$")
+ (("fonts\\.conf\" };")
+ (string-append
+ "fonts.conf\"\n\""
+ (search-input-file inputs "/etc/fonts/fonts.conf")
+ "\"\n};"))))))))
+ (native-inputs
+ (list alsa-lib
+ curl
+ jack-1
+ libx11
+ pkg-config
+ webkitgtk-with-libsoup2))
+ (inputs (list fontconfig freetype libjpeg-turbo libpng))
+ (home-page "https://juce.com")
+ (synopsis "C++ application framework for audio plugins and plugin hosts")
+ (description
+ "JUCE is a C++ application framework for creating applications including
+VST, VST3, AU, AUv3, AAX and LV2 audio plug-ins and plug-in hosts.")
+ (license
+ (list license:asl2.0 ;for Oboe and AudioUnitSDK
+ license:bsd-3 ;for FLAC, Ogg Vorbis and OpenGL Extension Wrangler
+ license:expat ;for Mesa 3-D graphics and jucer icons
+ license:gpl3 ;for JUCE and VST3 SDK
+ license:ijg ;for jpeglib
+ license:isc ;for LV2 SDK
+ license:zlib)))) ;for pngLib, zlib and Box2D
+
(define-public ftxui
(package
(name "ftxui")
--
libgit2 1.5.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 63199@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63199
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch