[PATCH] gnu: Add systemtap

  • Done
  • quality assurance status badge
Details
5 participants
  • Andy Tai
  • Liliana Marie Prikler
  • Ludovic Courtès
  • Christopher Baines
  • Olivier Dion
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 30 Apr 2023 07:41
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230430054102.29098-1-atai@atai.org
* gnu/packages/debug.scm (systemtap): New variable
---
gnu/packages/debug.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index fe00cb5705..3e01c7f0a2 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -48,6 +48,8 @@ (define-module (gnu packages debug)
#:use-module (gnu packages check)
#:use-module (gnu packages code)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpio)
+ #:use-module (gnu packages elf)
#:use-module (gnu packages flex)
#:use-module (gnu packages gdb)
#:use-module (gnu packages glib)
@@ -918,3 +920,39 @@ (define-public delve
(synopsis "Debugger for the Go programming language")
(description "Delve is a debugger for the Go programming language.")
(license license:expat)))
+
+(define-public systemtap
+ (package
+ (name "systemtap")
+ (version "4.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://sourceware.org/ftp/systemtap/releases/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "161smpv4ajqfncmgylvs89bbix1id60nf0g7clmga2lxxax3646h"))))
+ (build-system gnu-build-system)
+ (native-inputs (list cpio python))
+ (inputs (list elfutils))
+
+ (home-page "https://sourceware.org/systemtap/")
+ (synopsis "a linux trace/probe tool")
+ (description
+ "SystemTap provides free software (GPL) infrastructure to simplify the
+gathering of information about the running Linux system. This assists
+diagnosis of a performance or functional problem. SystemTap eliminates the
+need for the developer to go through the tedious and disruptive
+instrument, recompile, install, and reboot sequence that may be otherwise
+required to collect data.
+
+SystemTap provides a simple command line interface and scripting language for
+writing instrumentation for a live running kernel plus user-space applications.
+We are publishing samples, as well as enlarging the internal \"tapset\" script
+library to aid reuse and abstraction.
+
+Among other tracing/probing tools, SystemTap is the tool of choice for complex
+tasks that may require live analysis, programmable on-line response, and
+whole-system symbolic access. SystemTap can also handle simple tracing jobs.")
+ (license license:gpl2+)))

base-commit: 85c137adde84055d78b16d84e5ae4817995bce28
prerequisite-patch-id: f5feb08c9249508d22e0debbe47222324e9f354e
prerequisite-patch-id: de3be9ca0e20edac4bdf93eacda91b65df196c2d
prerequisite-patch-id: 9967fd9b0de5c36d810ca5c346e49762dfd3dad8
--
2.39.2
L
L
Liliana Marie Prikler wrote on 30 Apr 2023 08:23
b303fb83404a14d87d4e003256bd9835a11d6d45.camel@gmail.com
Am Samstag, dem 29.04.2023 um 22:41 -0700 schrieb Andy Tai:
Toggle quote (44 lines)
> * gnu/packages/debug.scm (systemtap): New variable
> ---
>  gnu/packages/debug.scm | 38 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 38 insertions(+)
>
> diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
> index fe00cb5705..3e01c7f0a2 100644
> --- a/gnu/packages/debug.scm
> +++ b/gnu/packages/debug.scm
> @@ -48,6 +48,8 @@ (define-module (gnu packages debug)
>    #:use-module (gnu packages check)
>    #:use-module (gnu packages code)
>    #:use-module (gnu packages compression)
> +  #:use-module (gnu packages cpio)
> +  #:use-module (gnu packages elf)
>    #:use-module (gnu packages flex)
>    #:use-module (gnu packages gdb)
>    #:use-module (gnu packages glib)
> @@ -918,3 +920,39 @@ (define-public delve
>      (synopsis "Debugger for the Go programming language")
>      (description "Delve is a debugger for the Go programming
> language.")
>      (license license:expat)))
> +
> +(define-public systemtap
> +  (package
> +    (name "systemtap")
> +    (version "4.9")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append
> +                    "https://sourceware.org/ftp/systemtap/releases/"
> name "-"
> +                    version ".tar.gz"))
> +              (sha256
> +               (base32
> +               
> "161smpv4ajqfncmgylvs89bbix1id60nf0g7clmga2lxxax3646h"))))
> +    (build-system gnu-build-system)
> +    (native-inputs (list cpio python))
> +    (inputs (list elfutils))
> +
> +    (home-page "https://sourceware.org/systemtap/")
> +    (synopsis "a linux trace/probe tool")
Synopsis should not lead with "a" or "the".
Toggle quote (3 lines)
> +    (description
> +     "SystemTap provides free software (GPL) infrastructure to
> simplify the
"free software" is non-informative even with "(GPL)" added, as all
software in Guix should be free. Leave this information to the license
field.
Toggle quote (23 lines)
> +gathering of information about the running Linux system. This
> assists
> +diagnosis of a performance or functional problem. SystemTap
> eliminates the
> +need for the developer to go through the tedious and disruptive
> +instrument, recompile, install, and reboot sequence that may be
> otherwise
> +required to collect data.
> +
> +SystemTap provides a simple command line interface and scripting
> language for
> +writing instrumentation for a live running kernel plus user-space
> applications.
> +We are publishing samples, as well as enlarging the internal
> \"tapset\" script
> +library to aid reuse and abstraction.
> +
> +Among other tracing/probing tools, SystemTap is the tool of choice
> for complex
> +tasks that may require live analysis, programmable on-line response,
> and
> +whole-system symbolic access. SystemTap can also handle simple
> tracing jobs.")
On the whole, this description is very market-y. I'm sure you can
condense it to a third of its length without losing information.
(Compression algorithms hate this trick.)

Cheers
O
O
Olivier Dion wrote on 30 Apr 2023 15:56
Re: [bug#63184] [PATCH] gnu: Add systemtap
(name . Andy Tai)(address . atai@atai.org)
87lei9mq2r.fsf@laura
On Sat, 29 Apr 2023, Andy Tai <atai@atai.org> wrote:
Toggle quote (2 lines)
> * gnu/packages/debug.scm (systemtap): New variable

I would put this under gnu/packages/instrumentation.scm.

--
Olivier Dion
oldiob.dev
A
A
Andy Tai wrote on 1 May 2023 00:56
[PATCH v2] gnu: Add systemtap
(address . 63184@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230430225616.27671-1-atai@atai.org
* gnu/packages/instrumentation.scm (systemtap): New variable
---
gnu/packages/instrumentation.scm | 38 ++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index c25086127a..eca7b5bd15 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021, 2022 Olivier Dion <olivier.dion@polymtl.ca>
+;;; Copyright © 2023 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,6 +26,7 @@ (define-module (gnu packages instrumentation)
#:use-module (gnu packages compression)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages cpio)
#:use-module (gnu packages elf)
#:use-module (gnu packages engineering)
#:use-module (gnu packages file)
@@ -526,3 +528,39 @@ (define-public uftrace
performance. It provides the command @command{uftrace}. User that want to do
scripting need to install python-3 or luajit in their profile.")
(license license:gpl2)))
+
+
+(define-public systemtap
+ (package
+ (name "systemtap")
+ (version "4.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://sourceware.org/ftp/systemtap/releases/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "161smpv4ajqfncmgylvs89bbix1id60nf0g7clmga2lxxax3646h"))))
+ (build-system gnu-build-system)
+ (native-inputs (list cpio python))
+ (inputs (list elfutils))
+
+ (home-page "https://sourceware.org/systemtap/")
+ (synopsis "a GNU/Linux trace/probe tool")
+ (description
+ "SystemTap provides infrastructure to simplify the
+gathering of information about the running Linux system. This assists
+diagnosis of a performance or functional problem. SystemTap eliminates the
+need for the developer to go through the tedious and disruptive
+instrument, recompile, install, and reboot sequence that may be otherwise
+required to collect data.
+
+SystemTap provides a simple command line interface and scripting language for
+writing instrumentation for a live running kernel plus user-space applications.
+We are publishing samples, as well as enlarging the internal \"tapset\" script
+library to aid reuse and abstraction. SystemTap is a tool for complex
+tasks that may require live analysis, programmable on-line response, and
+whole-system symbolic access, and can also handle simple tracing jobs.")
+ (license license:gpl2+)))
+

base-commit: 85c137adde84055d78b16d84e5ae4817995bce28
prerequisite-patch-id: f5feb08c9249508d22e0debbe47222324e9f354e
prerequisite-patch-id: de3be9ca0e20edac4bdf93eacda91b65df196c2d
prerequisite-patch-id: 9967fd9b0de5c36d810ca5c346e49762dfd3dad8
--
2.39.2
O
O
Olivier Dion wrote on 1 May 2023 02:30
(name . Andy Tai)(address . atai@atai.org)
87mt2oevw1.fsf@laura
On Sun, 30 Apr 2023, Andy Tai <atai@atai.org> wrote:
Toggle quote (18 lines)
> * gnu/packages/instrumentation.scm (systemtap): New variable
> ---
> gnu/packages/instrumentation.scm | 38 ++++++++++++++++++++++++++++++++
> 1 file changed, 38 insertions(+)
>
> diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
> index c25086127a..eca7b5bd15 100644
> --- a/gnu/packages/instrumentation.scm
> +++ b/gnu/packages/instrumentation.scm
> @@ -25,6 +26,7 @@ (define-module (gnu packages instrumentation)
> #:use-module (gnu packages compression)
> #:use-module (gnu packages datastructures)
> #:use-module (gnu packages documentation)
> + #:use-module (gnu packages cpio)
> #:use-module (gnu packages elf)
> #:use-module (gnu packages engineering)
> #:use-module (gnu packages file)

Please keep the #:use-module sorted. The same applies for define-public.

Toggle quote (2 lines)
> + (synopsis "a GNU/Linux trace/probe tool")

Synopsis start with a capital case I think. Use `guix lint' to be
sure.

--
Olivier Dion
oldiob.dev
A
A
Andy Tai wrote on 1 May 2023 03:06
[PATCH v3] gnu: Add systemtap
(address . 63184@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230501010654.8940-1-atai@atai.org
* gnu/packages/instrumentation.scm (systemtap): New variable
---
gnu/packages/instrumentation.scm | 38 ++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index c25086127a..0d57cdd316 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021, 2022 Olivier Dion <olivier.dion@polymtl.ca>
+;;; Copyright © 2023 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,6 +24,7 @@ (define-module (gnu packages instrumentation)
#:use-module (gnu packages boost)
#:use-module (gnu packages commencement)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpio)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages documentation)
#:use-module (gnu packages elf)
@@ -468,6 +470,40 @@ (define-public perf-tools
ftrace.")
(license (list license:gpl2))))
+(define-public systemtap
+ (package
+ (name "systemtap")
+ (version "4.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://sourceware.org/ftp/systemtap/releases/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "161smpv4ajqfncmgylvs89bbix1id60nf0g7clmga2lxxax3646h"))))
+ (build-system gnu-build-system)
+ (native-inputs (list cpio python))
+ (inputs (list elfutils))
+
+ (home-page "https://sourceware.org/systemtap/")
+ (synopsis "GNU/Linux trace/probe tool")
+ (description
+ "SystemTap provides infrastructure to simplify the
+gathering of information about the running Linux system. This assists
+diagnosis of a performance or functional problem. SystemTap eliminates the
+need for the developer to go through the tedious and disruptive
+instrument, recompile, install, and reboot sequence that may be otherwise
+required to collect data.
+
+SystemTap provides a simple command line interface and scripting language for
+writing instrumentation for a live running kernel plus user-space applications.
+We are publishing samples, as well as enlarging the internal \"tapset\" script
+library to aid reuse and abstraction. SystemTap is a tool for complex
+tasks that may require live analysis, programmable on-line response, and
+whole-system symbolic access, and can also handle simple tracing jobs.")
+ (license license:gpl2+)))
+
(define-public uftrace
(package
(name "uftrace")
@@ -526,3 +562,5 @@ (define-public uftrace
performance. It provides the command @command{uftrace}. User that want to do
scripting need to install python-3 or luajit in their profile.")
(license license:gpl2)))
+
+

base-commit: 23552fb2fbcb78757e8b563de9466831f6386105
--
2.39.2
A
A
Andy Tai wrote on 12 May 2023 01:40
Guix QA: 13482 packages waiting for Hurd target to build for a package addition patch
CAJsg1E9bhxuK6iu0U5JuvhCYUh4H5UDDKbDvqKeSy_9D-_6dqQ@mail.gmail.com
funny issue with Guix QA:


shows 13482 packages waiting to build for a package addition patch
for target i586-gnu
That shall make no sense. The package is Linux kernel specific, as well.
C
C
Christopher Baines wrote on 12 May 2023 08:50
(name . Andy Tai)(address . atai@atai.org)
874joirqhd.fsf@cbaines.net
Andy Tai <atai@atai.org> writes:

Toggle quote (8 lines)
> funny issue with Guix QA:
>
> https://qa.guix.gnu.org/issue/63184
>
> shows 13482 packages waiting to build for a package addition patch
> for target i586-gnu
> That shall make no sense. The package is Linux kernel specific, as well.

This isn't a QA issue, it's an actual issue with the derivations,
they're very broken.

I've got some patches here https://issues.guix.gnu.org/63416

Note that even though this information is showing up, the i586-gnu
system isn't looked at when considering the "status" [2].

-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmRd4i5fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XduXA//b+tW2JZwtswjKLeilJJJ+hx7RYjthaIv
iUtsw8zt9Qub/ce5fsqgodJcmH2VVxaff0emTdNt2Mtgpfl3T7+AG+Hj2GEpOHe2
04P7VXMNVudkZXCjenh0GO1KhtsBDmXwrYin9RERZa2Of/fdA0b3+oFOsgi80MsF
AjQuR4Adms5cRcGq8z/LTxaHcIheeZeSqTKj9jLsOs/pH7E6VASmQneIE8uZTpiL
gHM2J57pPZNfWIKvvP1jpOMrNCtc7CueLoNKvuqMZ0V+4jkcdoaN9AIGtbmD6KDi
Gjo5T/iwc85fP/ZMES291uIYgfziwhryi66PDfoMwxC2C9f8OEY9CAOmKiRxow+f
fyeSgbgBMCqC87h/4UYACvlcMuNbLmvpR7AO5RjNVZF2Ekn79rp1U2HYCJlOpzY/
p8zZN1OkYZP0FcMY9qjfL0zTX1SqhqMLe/yPpYUtKIDzmQwhne+DRifEes8qi7aC
u1FvnX9wUBGYfH4MNJBb0fTyY/nUmz6HHQzsDt+9+C2L5gXE9Wcq3YUFgYHw+2M8
ekNMKFLnC1GOdMp0ApZX1C6VwZ7gbL6Pjj8jLN8wfOytrqhggpNiQvfbeu9C6O/s
G7D0zoEKBfBcoWVlBLBF/UGDjMeFRRyhTwDBTU/ZR0yXL9j2ZnjxuIqGW95VBR+1
Rn2bCPHmZPk=
=a5gX
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 14 Jun 2023 23:23
Re: bug#63184: [PATCH] gnu: Add systemtap
(name . Andy Tai)(address . atai@atai.org)(address . 63184-done@debbugs.gnu.org)
87ttv9pwki.fsf_-_@gnu.org
Andy Tai <atai@atai.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/instrumentation.scm (systemtap): New variable

Applied, thanks!
Closed
?