Getting error while trying to compile treesitter plugin for neovim.

  • Done
  • quality assurance status badge
Details
2 participants
  • Apoorv
  • Simon Tournier
Owner
unassigned
Submitted by
Apoorv
Severity
normal

Debbugs page

Apoorv wrote 2 years ago
(address . bug-guix@gnu.org)
CAEuo0jgv1eXetxG_H=1bFADE6G-Bm8nk1FZZ910s6TDCU6+a7g@mail.gmail.com
I'm using the kickstart.nvim configuration,

And while it tries to compile the treesitter plugin I am getting an error,
```
nvim-treesitter[python]: Error during compilation
In file included from src/scanner.cc:2:
In file included from /home/apoorv/.guix-home/profile/include/c++/vector:66:
In file included from
/home/apoorv/.guix-home/profile/include/c++/bits/refwrap.h:39:
/home/apoorv/.guix-home/profile/include/c++/bits/stl_function.h:439:11:
error: no member named '__is_constant_evaluated' in namespace 'std'
if (std::__is_constant_evaluated())
~~~~~^
/home/apoorv/.guix-home/profile/include/c++/bits/stl_function.h:454:11:
error: no member named '__is_constant_evaluated' in namespace 'std'
if (std::__is_constant_evaluated())
~~~~~^
/home/apoorv/.guix-home/profile/include/c++/bits/stl_function.h:469:11:
error: no member named '__is_constant_evaluated' in namespace 'std'
if (std::__is_constant_evaluated())
~~~~~^
/home/apoorv/.guix-home/profile/include/c++/bits/stl_function.h:484:11:
error: no member named '__is_constant_evaluated' in namespace 'std'
if (std::__is_constant_evaluated())
~~~~~^
4 errors generated.
```
Attachment: file
Apoorv wrote 2 years ago
The issue no longer exists.
(address . 63170@debbugs.gnu.org)
CAEuo0jgVOAAA+aQ=hYCvU5bkM5eRK5mqRJybjL3HVEDJPLBqOw@mail.gmail.com
The issue seems to be fixed now. It's been a while actually, I just forgot
to respond here.
Attachment: file
Simon Tournier wrote 2 years ago
86h6o8u18y.fsf@gmail.com
Hi,

On Wed, 23 Aug 2023 at 06:19, Apoorv <apoorvs569@gmail.com> wrote:
Toggle quote (3 lines)
> The issue seems to be fixed now. It's been a while actually, I just forgot
> to respond here.

Thanks for the notification. So I am closing.


Cheers,
simon
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63170@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63170
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help