[PATCH 1/2] gnu: supercollider: Use G-expressions.

  • Done
  • quality assurance status badge
Details
2 participants
  • Zhu Zihao
  • 宋文武
Owner
unassigned
Submitted by
Zhu Zihao
Severity
normal

Debbugs page

Zhu Zihao wrote 2 years ago
(address . guix-patches@gnu.org)(name . Zhu Zihao)(address . all_but_last@163.com)
20230428133329.31666-1-all_but_last@163.com
* gnu/packages/audio.scm (supercollider)[source]: Use G-expression in snippet.
[arguments]: Use G-expressions.
<#:phases>: Replace `(assoc-ref outputs ...)` with `#$output`.
---
gnu/packages/audio.scm | 102 ++++++++++++++++++++---------------------
1 file changed, 51 insertions(+), 51 deletions(-)

Toggle diff (122 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index dca5e516a1..69570109d9 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3460,64 +3460,64 @@ (define-public supercollider
;; The build system doesn't allow us to unbundle the following
;; libraries. hidapi is also heavily patched and upstream not
;; actively maintained.
- '(let ((keep-dirs '("nova-simd" "nova-tt" "hidapi"
- "TLSF-2.4.6" "oscpack_1_1_0" "." "..")))
- (with-directory-excursion "./external_libraries"
- (for-each
- delete-file-recursively
- (scandir "."
- (lambda (x)
- (and (eq? (stat:type (stat x)) 'directory)
- (not (member (basename x) keep-dirs)))))))
- ;; To find the Guix provided ableton-link library.
- (substitute* "lang/CMakeLists.txt"
- (("include\\(\\.\\./external_libraries/link/\
+ #~(let ((keep-dirs '("nova-simd" "nova-tt" "hidapi"
+ "TLSF-2.4.6" "oscpack_1_1_0" "." "..")))
+ (with-directory-excursion "./external_libraries"
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (x)
+ (and (eq? (stat:type (stat x)) 'directory)
+ (not (member (basename x) keep-dirs)))))))
+ ;; To find the Guix provided ableton-link library.
+ (substitute* "lang/CMakeLists.txt"
+ (("include\\(\\.\\./external_libraries/link/\
AbletonLinkConfig\\.cmake\\)")
- "find_package(AbletonLink NAMES AbletonLink ableton-link \
+ "find_package(AbletonLink NAMES AbletonLink ableton-link \
link REQUIRED)"))))))
(build-system cmake-build-system)
(outputs
'("out" ;core language
"ide")) ;qt ide
(arguments
- `(#:configure-flags '("-DSYSTEM_BOOST=ON"
- "-DSYSTEM_YAMLCPP=ON"
- "-DSC_QT=ON"
- "-DCMAKE_BUILD_TYPE=Release"
- "-DFORTIFY=ON"
- ;; "-DLIBSCSYNTH=ON" ; TODO: Re-enable?
- "-DSC_EL=OFF") ;scel is packaged individually as emacs-scel
- #:phases
- (modify-phases %standard-phases
- ;; HOME must be defined otherwise supercollider throws a "ERROR:
- ;; Primitive '_FileMkDir' failed." error when generating the doc.
- ;; The graphical tests also hang without it.
- (add-after 'unpack 'set-home-directory
- (lambda _
- (setenv "HOME" (getcwd))))
- (add-after 'unpack 'patch-scclass-dir
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (scclass-dir
- (string-append out
- "/share/SuperCollider/SCClassLibrary")))
- (substitute* "lang/LangSource/SC_LanguageConfig.cpp"
- (((string-append
- "SC_Filesystem::instance\\(\\)\\.getDirectory"
- "\\(DirName::Resource\\) / CLASS_LIB_DIR_NAME"))
- (string-append "Path(\"" scclass-dir "\")"))))))
- (add-before 'build 'prepare-x
- (lambda _
- (system "Xvfb &")
- (setenv "DISPLAY" ":0")))
- (add-before 'install 'install-ide
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (ide (assoc-ref outputs "ide"))
- (scide "editors/sc-ide/scide"))
- (install-file scide
- (string-append ide "/bin"))
- (delete-file scide)))))))
+ (list
+ #:configure-flags
+ #~(list "-DSYSTEM_BOOST=ON"
+ "-DSYSTEM_YAMLCPP=ON"
+ "-DSC_QT=ON"
+ "-DCMAKE_BUILD_TYPE=Release"
+ "-DFORTIFY=ON"
+ ;; "-DLIBSCSYNTH=ON" ; TODO: Re-enable?
+ "-DSC_EL=OFF") ;scel is packaged individually as emacs-scel
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; HOME must be defined otherwise supercollider throws a "ERROR:
+ ;; Primitive '_FileMkDir' failed." error when generating the doc.
+ ;; The graphical tests also hang without it.
+ (add-after 'unpack 'set-home-directory
+ (lambda _
+ (setenv "HOME" (getcwd))))
+ (add-after 'unpack 'patch-scclass-dir
+ (lambda _
+ (let* ((scclass-dir
+ (string-append #$output
+ "/share/SuperCollider/SCClassLibrary")))
+ (substitute* "lang/LangSource/SC_LanguageConfig.cpp"
+ (((string-append
+ "SC_Filesystem::instance\\(\\)\\.getDirectory"
+ "\\(DirName::Resource\\) / CLASS_LIB_DIR_NAME"))
+ (string-append "Path(\"" scclass-dir "\")"))))))
+ (add-before 'build 'prepare-x
+ (lambda _
+ (system "Xvfb &")
+ (setenv "DISPLAY" ":0")))
+ (add-before 'install 'install-ide
+ (lambda _
+ (let* ((ide #$output:ide)
+ (scide "editors/sc-ide/scide"))
+ (install-file scide
+ (string-append ide "/bin"))
+ (delete-file scide)))))))
(native-inputs
(list ableton-link pkg-config qttools-5 xorg-server-for-tests))
(inputs (list jack-1
--
2.39.2
Zhu Zihao wrote 2 years ago
[PATCH 2/2] gnu: supercollider: Update to 3.13.0.
(address . 63147@debbugs.gnu.org)
86v8hg82ju.fsf@163.com

-----BEGIN PGP SIGNATURE-----

iIsEARYIADMWIQT4UAIrVkIEZilSHr2K2nJqP6LM8gUCZEviFRUcYWxsX2J1dF9s
YXN0QDE2My5jb20ACgkQitpyaj+izPKGXgEA/eQRbS5o6Ft/bJCb5aHNDEQx0JQk
9LEQ7Xc5+wOq0HUA/jFZLX37AUAS4u1+3wVsWG/DNjeIHqF7VlsEOfY2QxMK
=rzAe
-----END PGP SIGNATURE-----

From 4bf2a1cfc6b5633ad1c6cb1a6e302bc36cd24ab6 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Fri, 28 Apr 2023 21:17:54 +0800
Subject: [PATCH 2/2] gnu: supercollider: Update to 3.13.0.

* gnu/packages/audio.scm (supercollider): Update to 3.13.0.
---
gnu/packages/audio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 69570109d9..c3db095007 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3441,7 +3441,7 @@ (define-public qjackrcd
(define-public supercollider
(package
(name "supercollider")
- (version "3.12.1")
+ (version "3.13.0")
(source
(origin
(method git-fetch)
@@ -3453,7 +3453,7 @@ (define-public supercollider
(file-name (git-file-name name version))
(sha256
(base32
- "0id522338a464j1slcspajwc7klypbc9qpigw5mqjhrw970wij5z"))
+ "1dkpnaly4m2j41ypy7xj5m2yhbl4ykw3vbnam345z4dk6qhyj9b1"))
(modules '((guix build utils)
(ice-9 ftw)))
(snippet
--
2.39.2
--
Retrieve my PGP public key:

gpg --recv-keys B3EBC086AB0EBC0F45E0B4D433DB374BCEE4D9DC

Zihao
宋文武 wrote 2 years ago
Re: bug#63147: [PATCH 1/2] gnu: supercollider: Use G-expressions.
(name . Zhu Zihao)(address . all_but_last@163.com)(address . 63147-done@debbugs.gnu.org)
87jzxfywk8.fsf_-_@envs.net
Applied, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63147@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63147
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help