[PATCH] gnu: lightning: Update to 2.2.2

  • Done
  • quality assurance status badge
Details
5 participants
  • Andreas Enge
  • Andy Tai
  • Ludovic Courtès
  • Christopher Baines
  • Paulo César Pereira de Andrade
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 28 Apr 2023 07:58
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230428055812.5143-1-atai@atai.org
* gnu/packages/assembly.scm (lightning): Update to 2.2.2
---
gnu/packages/assembly.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index ff8fe69e64..1a51be67cf 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -133,14 +133,14 @@ (define-public yasm
(define-public lightning
(package
(name "lightning")
- (version "2.2.1")
+ (version "2.2.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/lightning/lightning-"
version ".tar.gz"))
(sha256
(base32
- "1aiwx9cl9c7swqcgrsjnvd5laah3iwxzl1van3670iv8sn0icrwq"))))
+ "1qmkfg7br543kqy82hhpr1n8bsm9wrwb1z5w2whxc5xdvr185jha"))))
(build-system gnu-build-system)
(native-inputs (list zlib))
(arguments

base-commit: db19e30673a72ff8ee34276ede5dd081e6023cd3
prerequisite-patch-id: e080cad1ab4c8868b7e3ff6e1e569a496a76fa4b
--
2.39.2
L
L
Ludovic Courtès wrote on 19 May 2023 16:42
(name . Andy Tai)(address . atai@atai.org)(address . 63140@debbugs.gnu.org)
87r0rcxu04.fsf@gnu.org
Hi,

Andy Tai <atai@atai.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/assembly.scm (lightning): Update to 2.2.2

This seems to break ‘smalltalk’. Its ‘check’ phase fails with things
like:

Toggle snippet (51 lines)
ERROR: 128 tests were run,
66 failed (1 expected failure).
7 tests were skipped.
## -------------------------- ##
## testsuite.log was created. ##
## -------------------------- ##

Please send `tests/testsuite.log' and all information you think might help:

To: <help-smalltalk@gnu.org>
Subject: [GNU Smalltalk 3.2.91] testsuite: 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 failed

You may investigate any problem if you feel able to do so, in which
case the test suite provides a good starting point. Its output may
be found below `tests/testsuite.dir'.

make[2]: *** [Makefile:631: check-local] Error 1
make[2]: Leaving directory '/tmp/guix-build-smalltalk-3.2.91.drv-0/smalltalk-3.2.91/tests'
make[1]: *** [Makefile:487: check-am] Error 2
make[1]: Leaving directory '/tmp/guix-build-smalltalk-3.2.91.drv-0/smalltalk-3.2.91/tests'
make: *** [Makefile:1069: check-recursive] Error 1

Test suite failed, dumping logs.

--- ./tests/testsuite.dir/046/testsuite.log ---------------------------------

# -*- compilation -*-
46. testsuite.at:82: testing ArrayANSITest ...
{ (cd /tmp/guix-build-smalltalk-3.2.91.drv-0/smalltalk-3.2.91 && timeout 600s gst -I /tmp/guix-build-smalltalk-3.2.91.drv-0/smalltalk-3.2.91/tests/gst.im -f /tmp/guix-build-smalltalk-3.2.91.drv-0/smalltalk-3.2.91/tests/AnsiRun.st ArrayANSITest); echo exit 0 > retcode; } | tr -d '\r' | tee stdout; . ./retcode
./testsuite.at:82: { (cd $abs_top_builddir && $TIMEOUT gst $image_path -f $abs_srcdir/AnsiRun.st ArrayANSITest); echo exit $? > retcode; } | tr -d '\r' | tee stdout; . ./retcode
--- /dev/null 2023-05-15 06:41:31.460926528 +0000
+++ /tmp/guix-build-smalltalk-3.2.91.drv-0/smalltalk-3.2.91/tests/testsuite.dir/at-groups/46/stderr 2023-05-19 14:39:04.960486435 +0000
@@ -0,0 +1,13 @@
+gst: Aborted
+gst: Error occurred while not in byte code interpreter!!
+/tmp/guix-build-smalltalk-3.2.91.drv-0/smalltalk-3.2.91/libgst/.libs/libgst.so.7(+0x72907)[0x7ffff7f52907]
+/gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35/lib/libc.so.6(+0x3d2a0)[0x7ffff7b682a0]
+/gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35/lib/libc.so.6(+0x86fec)[0x7ffff7bb1fec]
+/gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35/lib/libc.so.6(raise+0x12)[0x7ffff7b68202]
+/gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35/lib/libc.so.6(abort+0xc1)[0x7ffff7b5345b]
+/tmp/guix-build-smalltalk-3.2.91.drv-0/smalltalk-3.2.91/libgst/.libs/libgst.so.7(+0x10c19)[0x7ffff7ef0c19]
+/gnu/store/8k2smdr5wvrxi3haw5l657rcbj97f0hz-libsigsegv-2.14/lib/libsigsegv.so.2(+0x1278)[0x7ffff7edb278]
+/gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35/lib/libc.so.6(+0x3d2a0)[0x7ffff7b682a0]
+/tmp/guix-build-smalltalk-3.2.91.drv-0/smalltalk-3.2.91/libgst/.libs/libgst.so.7(+0x56e48)[0x7ffff7f36e48]
+/tmp/guix-build-smalltalk-3.2.91.drv-0/smalltalk-3.2.91/libgst/.libs/libgst.so.7(+0x72479)[0x7ffff7f52479]
+/tmp/guix-build-smalltalk-3.2.91.drv-0/smalltalk-3.2.91/tests/testsuite.dir/at-groups/46/test-source: line 20: 20149 Aborted $TIMEOUT gst $image_path -f $abs_srcdir/AnsiRun.st ArrayANSITest
stdout:
./testsuite.at:82: exit code was 134, expected 0
46. testsuite.at:82: 46. ArrayANSITest (testsuite.at:82): FAILED (testsuite.at:82)

Could you take a look and/or take it upstream?

Thanks,
Ludo’.
A
A
Andy Tai wrote on 19 May 2023 20:17
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 63140@debbugs.gnu.org)
CAJsg1E_Fho1ZXnyMcsxiCQfEkfr0GbSFGXVHDTd-b3ndJFbnSg@mail.gmail.com
will do (or try)

On Fri, May 19, 2023 at 7:43?AM Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (17 lines)
> Hi,
>
> Andy Tai <atai@atai.org> skribis:
>
> > * gnu/packages/assembly.scm (lightning): Update to 2.2.2
>
> This seems to break ‘smalltalk’. Its ‘check’ phase fails with things
> like:
>
>
> Could you take a look and/or take it upstream?
>
> Thanks,
> Ludo’.
>


--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat:
andytai1010
Year 2023 ??112?
????????????
????????????
Attachment: file
A
A
Andy Tai wrote on 22 May 2023 06:00
Re: GNU Smalltalk test suite failure with lightning 2.2.2
CAJsg1E-n00RZfD1RQoG+Nem2-hhm09DUsn7m3P3xk6p9XGfcHg@mail.gmail.com
Additional info:

it seems this GNU Smalltalk has the same problem with GNU Lightning
2.2.1, 2.2.0 and 2.1.4 what I have tried so far)

On Sat, May 20, 2023 at 9:34?PM Andy Tai <atai@atai.org> wrote:
Toggle quote (42 lines)
>
> Hi, this is regarding GNU Smalltalk test suite failure when building
> with GNU Lightning at 2.2.2
>
> Context: I was trying to upgrade lightning package in GNU Guix to 2.2.2.
>
> GNU Guix is a source based GNU/Linux distribution so the way it works
> is that it runs the test suites of packages included in it as part of
> process ofm upgrading package receipts. In the build check it was
> discovered that GNU Smalltalk will fail in test suites when lightning
> is upgraded to 2.2.2.
>
> I am trying to report this to GNU Smalltalk but it has no bug tracker
> and it mailing list is not very active; I am still waiting for
> subscribing to the mailing list.
>
> In any case, it seems GNU Smalltalk uses lightning. With this issue I
> cannot tell if it is a bug in GNU Smalltalk or GNU Lightning So I
> will bring it up here first.
> with GNU Lightning at 2.2.2, then building GNU Smalltalk:
> key parts of log:
>
> Basic packages.
>
> 44: SUnit ok
> 45: Parser ok
>
> ANSI compliancy tests.
>
> 46: ArrayANSITest FAILED (testsuite.at:82)
> 47: ArrayFactoryANSITest FAILED (testsuite.at:83)
> 48: BagANSITest FAILED (testsuite.at:84)
> 49: BagFactoryANSITest FAILED (testsuite.at:85)
> 50: BooleanANSITest FAILED (testsuite.at:86)
> 51: ByteArrayANSITest FAILED (testsuite.at:87)
> 52: ByteArrayFactoryANSITest FAILED (testsuite.at:88)
> ....
>
> complete build log (gzipped) as attachment



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2023 ??112?
????????????
????????????
P
P
Paulo César Pereira de Andrade wrote on 22 May 2023 14:49
(name . Andy Tai)(address . atai@atai.org)
CAHAq8pEkY9CDxArucwobGDgXuZt-G4tmMjzOURKOh6P5MjA4Bg@mail.gmail.com
Em seg., 22 de mai. de 2023 às 01:01, Andy Tai <atai@atai.org> escreveu:
Toggle quote (3 lines)
>
> Additional info:

Hi,

GNU Smalltalk uses an embedded Lightning 1.x if built with --enable-jit.

I believe I lost most if no all emails I did exchange about porting
lightning 2.x to work with gnu smalltalk.

Last time I tested, a few months ago, I believe only the debugger test failed.

But I tested a very old branch, with patches at

Toggle quote (26 lines)
> it seems this GNU Smalltalk has the same problem with GNU Lightning
> 2.2.1, 2.2.0 and 2.1.4 what I have tried so far)
>
> On Sat, May 20, 2023 at 9:34?PM Andy Tai <atai@atai.org> wrote:
> >
> > Hi, this is regarding GNU Smalltalk test suite failure when building
> > with GNU Lightning at 2.2.2
> >
> > Context: I was trying to upgrade lightning package in GNU Guix to 2.2.2.
> >
> > GNU Guix is a source based GNU/Linux distribution so the way it works
> > is that it runs the test suites of packages included in it as part of
> > process ofm upgrading package receipts. In the build check it was
> > discovered that GNU Smalltalk will fail in test suites when lightning
> > is upgraded to 2.2.2.
> >
> > I am trying to report this to GNU Smalltalk but it has no bug tracker
> > and it mailing list is not very active; I am still waiting for
> > subscribing to the mailing list.
> >
> > In any case, it seems GNU Smalltalk uses lightning. With this issue I
> > cannot tell if it is a bug in GNU Smalltalk or GNU Lightning So I
> > will bring it up here first.
> > with GNU Lightning at 2.2.2, then building GNU Smalltalk:
> > key parts of log:

Please check if you can get some GNU Smalltalk contact. I would like
to talk with any person involved again.

Thanks!
Paulo
A
A
Andy Tai wrote on 22 May 2023 19:44
(name . Paulo César Pereira de Andrade)(address . paulo.cesar.pereira.de.andrade@gmail.com)
CAJsg1E8n=48D-P0BSnLcaYZUjGXTL--kB1k4-KTuFZgHu-Az-g@mail.gmail.com
Thanks. I will try to make contact with GNU Smalltalk people.

On Mon, May 22, 2023 at 5:49?AM Paulo César Pereira de Andrade
<paulo.cesar.pereira.de.andrade@gmail.com> wrote:
Toggle quote (51 lines)
>
> Em seg., 22 de mai. de 2023 às 01:01, Andy Tai <atai@atai.org> escreveu:
> >
> > Additional info:
>
> Hi,
>
> GNU Smalltalk uses an embedded Lightning 1.x if built with --enable-jit.
>
> I believe I lost most if no all emails I did exchange about porting
> lightning 2.x to work with gnu smalltalk.
>
> Last time I tested, a few months ago, I believe only the debugger test failed.
>
> But I tested a very old branch, with patches at
> https://github.com/pcpa/smalltalk/compare/master...scratch-lightning-branch
>
> > it seems this GNU Smalltalk has the same problem with GNU Lightning
> > 2.2.1, 2.2.0 and 2.1.4 what I have tried so far)
> >
> > On Sat, May 20, 2023 at 9:34?PM Andy Tai <atai@atai.org> wrote:
> > >
> > > Hi, this is regarding GNU Smalltalk test suite failure when building
> > > with GNU Lightning at 2.2.2
> > >
> > > Context: I was trying to upgrade lightning package in GNU Guix to 2.2.2.
> > >
> > > GNU Guix is a source based GNU/Linux distribution so the way it works
> > > is that it runs the test suites of packages included in it as part of
> > > process ofm upgrading package receipts. In the build check it was
> > > discovered that GNU Smalltalk will fail in test suites when lightning
> > > is upgraded to 2.2.2.
> > >
> > > I am trying to report this to GNU Smalltalk but it has no bug tracker
> > > and it mailing list is not very active; I am still waiting for
> > > subscribing to the mailing list.
> > >
> > > In any case, it seems GNU Smalltalk uses lightning. With this issue I
> > > cannot tell if it is a bug in GNU Smalltalk or GNU Lightning So I
> > > will bring it up here first.
> > > with GNU Lightning at 2.2.2, then building GNU Smalltalk:
> > > key parts of log:
>
> Please check if you can get some GNU Smalltalk contact. I would like
> to talk with any person involved again.
>
> Thanks!
> Paulo



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2023 ??112?
????????????
????????????
A
A
Andreas Enge wrote on 25 Aug 2023 14:25
Failure of smalltalk
(address . 63140@debbugs.gnu.org)
ZOidon4zzzfwgEEb@jurong
Hello,

the situation is a bit confusing.

QA shows a green button, but apparently has not tried to build smalltalk.

Currently a smalltalk package is available from CI, compiled with
lightning@2.2.1 (which should not be possible according to some previous
messages).

The same smalltalk recipe breaks building for me after updating lightning.

In any case, I would suggest to not apply the patch for the time being.

Andreas
C
C
Christopher Baines wrote on 26 Aug 2023 13:31
tag 63140 moreinfo
(address . control@debbugs.gnu.org)
87cyzaca5b.fsf@cbaines.net
tags 63140 + moreinfo
quit
C
C
Christopher Baines wrote on 26 Aug 2023 13:31
Re: [bug#63140] Failure of smalltalk
(name . Andreas Enge)(address . andreas.enge@inria.fr)(address . 63140@debbugs.gnu.org)
87a5uejawo.fsf@cbaines.net
Andreas Enge <andreas.enge@inria.fr> writes:

Toggle quote (4 lines)
> the situation is a bit confusing.
>
> QA shows a green button, but apparently has not tried to build smalltalk.

Yeah, the detected patch is actually from part of the log output that
Ludo sent [1].


I'm not quite sure how to avoid this, as I guess it looks like a patch.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmTp4wdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeIIQ//SAMlxRTgw0gG8dogs+bXQA7glICfBFV/
bywH/SZZ6muzQVQ9T84FhQIwb2WIWC9V5qo+3y+Wx0n4+7iznroGvgUuq4UjzchA
5GXcKfovt8pbBAGti6BsfGNr8qNoRcSQWToRvL1FiZzVLCXQycQPWneB9q9eOkkK
9al521s5xmAhcuJVvnYb86TCCMCh44J4dbWSGmbROWzncwOno320w1NiJ0QtWoSh
8I6wx0f2yEU+LavvJxTHatB6nrNEcDupSzVwx3VTsSPdT+X9lXFfEjK5YawTSubU
lci+GxS2pFXYXtJSsPeTox+qrLXrgHtHB0jqyNQG9BPBtVbRRE8DfZA9b1KMQ1BR
nEzMT9uSFPiRd2JdLOFiSv6nlufLi8FDoSMyMniDHfziTmYik/jJF7SjwHSN30CD
9294NbqQSaFOV77637xapFrvrIZu5VFOYzip4ZHdZS0kErac6k3t6jFXdHZvnEd+
Hik33SC3XCryeK0ytG5m4tisVrpoquFyryjAe7doHC0FFeN88G3wRionEHpcb4i2
m3xGaqX6xrIkSjPsuCFc2bSrbd8K+/ewjMBrf7G3I9yfN8ZXQ1I5cse53C9saLG7
qxWN8EdKhtIUpgtINVJPYCN8B1JDnWLx4gmltcS2MLbbGLqGA8kgkKXDbQge1hMt
iMny1C1p9tQ=
=TGqT
-----END PGP SIGNATURE-----

A
A
Andy Tai wrote on 9 Feb 08:18 +0100
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E_VRFeNps-ZjajibGhmo9ypXAu6mm7Tc5xLeOR5s7Ziyg@mail.gmail.com
close 63140
thanks
out of date
?