[PATCH] gnu: gnutls: skip examples on mingw.

  • Open
  • quality assurance status badge
Details
3 participants
  • Maxim Cournoyer
  • Vivien Kraus
  • Simon Tournier
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal
V
V
Vivien Kraus wrote on 25 Apr 2023 23:26
(address . bug-guix@gnu.org)
c1af330c3f2958005595fa4de9f870c071373dc8.1682458873.git.vivien@planete-kraus.eu
* gnu/packages/tls.scm (gnutls): Skip the doc/examples subdir on mingw,
because the gnulib modules are not correct.
---
gnu/packages/tls.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 6d7cff41b0..9e16b04702 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -253,6 +253,15 @@ (define-public gnutls
(substitute* "tests/fastopen.sh"
(("^unset RETCODE")
"exit 77\n")))) ;skip
+ #$@(if (target-mingw?)
+ #~((add-after 'unpack 'skip-doc-examples
+ ;; The examples in doc do not link to correct
+ ;; gnulib modules.
+ (lambda _
+ (substitute* "doc/Makefile.in"
+ (("SUBDIRS = examples")
+ "SUBDIRS =")))))
+ #~())
#$@(if (target-ppc32?)
;; https://gitlab.com/gnutls/gnutls/-/issues/1354
;; Extend the test timeout from the default of 20 * 1000

base-commit: e287a0e402ee15eefa80c2804e487025507fe3b1
--
2.39.2
M
M
Maxim Cournoyer wrote on 5 Jan 19:06 +0100
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)(address . 63077@debbugs.gnu.org)
875y071wow.fsf@gmail.com
Hi Vivien,

Vivien Kraus <vivien@planete-kraus.eu> writes:

Toggle quote (24 lines)
> * gnu/packages/tls.scm (gnutls): Skip the doc/examples subdir on mingw,
> because the gnulib modules are not correct.
> ---
> gnu/packages/tls.scm | 9 +++++++++
> 1 file changed, 9 insertions(+)
>
> diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
> index 6d7cff41b0..9e16b04702 100644
> --- a/gnu/packages/tls.scm
> +++ b/gnu/packages/tls.scm
> @@ -253,6 +253,15 @@ (define-public gnutls
> (substitute* "tests/fastopen.sh"
> (("^unset RETCODE")
> "exit 77\n")))) ;skip
> + #$@(if (target-mingw?)
> + #~((add-after 'unpack 'skip-doc-examples
> + ;; The examples in doc do not link to correct
> + ;; gnulib modules.
> + (lambda _
> + (substitute* "doc/Makefile.in"
> + (("SUBDIRS = examples")
> + "SUBDIRS =")))))
> + #~())

Did you report it upstream? Perhaps they'd know how to properly fix it.

--
Thanks,
Maxim
S
S
Simon Tournier wrote on 8 Mar 18:22 +0100
(address . 63077@debbugs.gnu.org)
878r2s8wqb.fsf@gmail.com
Hi,

On ven., 05 janv. 2024 at 13:06, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
Toggle quote (28 lines)
> Vivien Kraus <vivien@planete-kraus.eu> writes:
>
>> * gnu/packages/tls.scm (gnutls): Skip the doc/examples subdir on mingw,
>> because the gnulib modules are not correct.
>> ---
>> gnu/packages/tls.scm | 9 +++++++++
>> 1 file changed, 9 insertions(+)
>>
>> diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
>> index 6d7cff41b0..9e16b04702 100644
>> --- a/gnu/packages/tls.scm
>> +++ b/gnu/packages/tls.scm
>> @@ -253,6 +253,15 @@ (define-public gnutls
>> (substitute* "tests/fastopen.sh"
>> (("^unset RETCODE")
>> "exit 77\n")))) ;skip
>> + #$@(if (target-mingw?)
>> + #~((add-after 'unpack 'skip-doc-examples
>> + ;; The examples in doc do not link to correct
>> + ;; gnulib modules.
>> + (lambda _
>> + (substitute* "doc/Makefile.in"
>> + (("SUBDIRS = examples")
>> + "SUBDIRS =")))))
>> + #~())
>
> Did you report it upstream? Perhaps they'd know how to properly fix it.

Digging all bugs, what about this?

It could be nice if it is fixed upstream. On the other, we could also
apply a fix waiting such fix.

WDYT?

Cheers,
simon
V
V
Vivien Kraus wrote on 11 Mar 18:47 +0100
(address . 63077@debbugs.gnu.org)
69c6d353db2442006b34eb12fe9428b5f69935d1.camel@planete-kraus.eu
Hello,

Le vendredi 08 mars 2024 à 18:22 +0100, Simon Tournier a écrit :
Toggle quote (20 lines)
> > > +               #$@(if (target-mingw?)
> > > +                      #~((add-after 'unpack 'skip-doc-examples
> > > +                           ;; The examples in doc do not link to
> > > correct
> > > +                           ;; gnulib modules.
> > > +                           (lambda _
> > > +                             (substitute* "doc/Makefile.in"
> > > +                               (("SUBDIRS = examples")
> > > +                                "SUBDIRS =")))))
> > > +                      #~())
> >
> > Did you report it upstream?  Perhaps they'd know how to properly
> > fix it.
>
> Digging all bugs, what about this?
>
> It could be nice if it is fixed upstream.  On the other, we could
> also
> apply a fix waiting such fix.

I reported it, and I believe upstream fixed it:


However it’s difficult to check because libidn2 fails (maybe the more
recent 2.3.7 does not). This libidn2 failure seems to have been
reported here:


I notice that libidn2 uses its own libunistring instead of the guix’
one, because libunistring is not an input of libidn2. Is this intended
to avoid a cycle?

Best regards,

Vivien
?