[PATCH] Fix supercollider.

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Wicki
  • Ludovic Courtès
Owner
unassigned
Submitted by
Gabriel Wicki
Severity
normal

Debbugs page

Gabriel Wicki wrote 2 years ago
(address . guix-patches@gnu.org)
20230425203323.j5emxz2ebvhs4ckt@blackbox
Howdy y'all

Supercollider was broken so I've fixed it. Btw there's no "audio"
team.. Should I start one? Not that I'm too much of an expert, but I am
somewhat enthusiastic about audio...

Also: I'm not too sure what to think about the style improvements
brought to the input section of the package.


The patch set is based on: 8c5ba69d6e9e4b1b9d6b5e9cd28859b19e8e180c


Best wishes,
gabber
Gabriel Wicki wrote 2 years ago
[PATCH 1/2] gnu: Fix supercollider.
(address . 63075@debbugs.gnu.org)
20230425203559.uzhf3mwdqcc4imvv@blackbox
From f67786eb958a65ba778f67a8f443fa3d24293438 Mon Sep 17 00:00:00 2001
Message-Id: <f67786eb958a65ba778f67a8f443fa3d24293438.1682453413.git.gabriel@erlikon.ch>
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Tue, 25 Apr 2023 22:03:03 +0200
Subject: [PATCH 1/2] gnu: Fix supercollider.

* gnu/packages/audio.scm (supercollider): Fix the build.
[configure-flags] Re-enable DLIBSCSYNTH.
[phases] New phase fix-struct-SOUNDFILE-tag.
[inputs] Add ruby and python to appease the build process.
---
gnu/packages/audio.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index dca5e516a1..109133ba8e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -43,6 +43,7 @@
;;; Copyright � 2023 Sergiu Ivanov <sivanov@colimite.fr>
;;; Copyright � 2023 David Thompson <dthompson2@worcester.edu>
;;; Copyright � 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright � 2023 Gabriel Wicki <gabriel@erlikon.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -119,6 +120,7 @@ (define-module (gnu packages audio)
#:use-module (gnu packages qt)
#:use-module (gnu packages rdf)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages samba)
#:use-module (gnu packages sdl)
#:use-module (gnu packages serialization)
@@ -3485,7 +3487,7 @@ (define-public supercollider
"-DSC_QT=ON"
"-DCMAKE_BUILD_TYPE=Release"
"-DFORTIFY=ON"
- ;; "-DLIBSCSYNTH=ON" ; TODO: Re-enable?
+ "-DLIBSCSYNTH=ON"
"-DSC_EL=OFF") ;scel is packaged individually as emacs-scel
#:phases
(modify-phases %standard-phases
@@ -3506,6 +3508,12 @@ (define-public supercollider
"SC_Filesystem::instance\\(\\)\\.getDirectory"
"\\(DirName::Resource\\) / CLASS_LIB_DIR_NAME"))
(string-append "Path(\"" scclass-dir "\")"))))))
+ (add-after 'patch-scclass-dir 'fix-struct-SOUNDFILE-tag
+ (lambda* _
+ (display (getcwd)) (newline)
+ (substitute* "include/plugin_interface/SC_SndBuf.h"
+ (("SNDFILE_tag")
+ "sf_private_tag"))))
(add-before 'build 'prepare-x
(lambda _
(system "Xvfb &")
@@ -3532,6 +3540,8 @@ (define-public supercollider
boost
boost-sync
yaml-cpp
+ python-wrapper ;there were warnings in the build process
+ ruby ;there were warnings in the build process
qtbase-5
qtdeclarative-5
qtsvg-5
--
2.39.2
Gabriel Wicki wrote 2 years ago
[PATCH 2/2] gnu: supercollider: Apply guix style.
(address . 63075@debbugs.gnu.org)
20230425203921.lm32yffgshuakjm6@blackbox
Attachment: file
Ludovic Courtès wrote 2 years ago
Re: bug#63075: [PATCH] Fix supercollider.
(name . Gabriel Wicki)(address . gabriel@erlikon.ch)(address . 63075-done@debbugs.gnu.org)
87wn1vsuxb.fsf_-_@gnu.org
Hi,

Gabriel Wicki <gabriel@erlikon.ch> skribis:

Toggle quote (11 lines)
>>From f67786eb958a65ba778f67a8f443fa3d24293438 Mon Sep 17 00:00:00 2001
> Message-Id: <f67786eb958a65ba778f67a8f443fa3d24293438.1682453413.git.gabriel@erlikon.ch>
> From: Gabriel Wicki <gabriel@erlikon.ch>
> Date: Tue, 25 Apr 2023 22:03:03 +0200
> Subject: [PATCH 1/2] gnu: Fix supercollider.
>
> * gnu/packages/audio.scm (supercollider): Fix the build.
> [configure-flags] Re-enable DLIBSCSYNTH.
> [phases] New phase fix-struct-SOUNDFILE-tag.
> [inputs] Add ruby and python to appease the build process.

Applied, thanks!

I didn’t apply the ‘guix style’ patch because I’m not sure it brings
much.

Ludo’.
Closed
Ludovic Courtès wrote 2 years ago
(name . Gabriel Wicki)(address . gabriel@erlikon.ch)(address . 63075@debbugs.gnu.org)
87sfcjsuw5.fsf@gnu.org
Hi!

Gabriel Wicki <gabriel@erlikon.ch> skribis:

Toggle quote (4 lines)
> Supercollider was broken so I've fixed it. Btw there's no "audio"
> team.. Should I start one? Not that I'm too much of an expert, but I am
> somewhat enthusiastic about audio...

You should bring it up on guix-devel, with a patch adding the team and
yourself. Based on commit history, I’m pretty sure you’d find folks to
join you!

Ludo’.
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63075@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63075
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help