[PATCH 0/3] gnu: cl-fast-ecs: Update to 0.2.2

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230424220956.30002-1-sharlatanus@gmail.com
Hi Guix!

This patch series updates game development system cl-fast-ecs with packing
new native-inputs components and updating some of their dependencies.

Toggle quote (5 lines)
> ./pre-inst-env guix build --rounds=2 cl-chlorophyll cl-fast-ecs cl-mock
> /gnu/store/77nz286w1i8hg6acdkyzr3nprrvb1cnl-cl-mock-1.1.0-0.01762fd
> /gnu/store/l4gc1m7hma975pxmxq0lxy5cjp8l0gls-cl-fast-ecs-0.2.2
> /gnu/store/ikw959g1hj1zxqfhbhy15f6v73r0qxaj-cl-chlorophyll-0.0.1-1.f2a50ad

Sharlatan Hellseher (3):
gnu: Add cl-chlorophyll.
gnu: cl-fast-ecs: Update to 0.2.2.
gnu: cl-mock: Update to 1.1.0-0.01762fd.

gnu/packages/lisp-check.scm | 17 +++++++++++------
gnu/packages/lisp-xyz.scm | 37 ++++++++++++++++++++++++++++++++++---
2 files changed, 45 insertions(+), 9 deletions(-)


base-commit: 5eb1d1b6482e29239f1d40dfcb815cdc12a2bdf0
--
2.39.2
Sharlatan Hellseher wrote 2 years ago
[PATCH 1/3] gnu: Add cl-chlorophyll.
(address . 63059@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230424221505.30390-1-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-chlorophyll, ecl-chlorophyll,
sbcl-chlorophyll): New variables.
---
gnu/packages/lisp-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d7b0531bcc..fcc549d632 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -23722,6 +23722,37 @@ (define-public cl-chemboy
(define-public ecl-chemboy
(sbcl-package->ecl-package sbcl-chemboy))
+(define-public sbcl-chlorophyll
+ (let ((commit "f2a50ad36d2fb11823c0e5a8da08a0de89c5c35f")
+ (revision "1"))
+ (package
+ (name "sbcl-chlorophyll")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorozhin/chlorophyll")
+ (commit commit)))
+ (file-name (git-file-name "chlorophyll" version))
+ (sha256
+ (base32 "1hgl8sjsmyqx4gs77q4p94b63zgpxk1wi9w9niki8j0213dr1s3y"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs (list sbcl-fiveam))
+ (inputs (list sbcl-alexandria))
+ (home-page "https://github.com/gorozhin/chlorophyll")
+ (synopsis "ANSI escape code library for Common Lisp")
+ (description
+"This package provides a Common Lisp system CHLOROPHYLL which implements an
+ANSI escape code functionality.")
+ (license license:expat))))
+
+(define-public cl-chlorophyll
+ (sbcl-package->cl-source-package sbcl-chlorophyll))
+
+(define-public ecl-chlorophyll
+ (sbcl-package->ecl-package sbcl-chlorophyll))
+
(define-public sbcl-cl-pass
(let ((commit "e58e97c0c0588dc742c061208afb9bc31e4dbd34")
(revision "1"))
--
2.39.2
Sharlatan Hellseher wrote 2 years ago
[PATCH 2/3] gnu: cl-fast-ecs: Update to 0.2.2.
(address . 63059@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230424221505.30390-2-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (sbcl-cl-fast-ecs): Update to 0.2.2.
[native-inputs]: Add sbcl-chlorophyll, sbcl-cl-mock.
---
gnu/packages/lisp-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fcc549d632..dbf4ea87bd 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -7049,7 +7049,7 @@ (define-public ecl-cl-fastcgi
(define-public sbcl-cl-fast-ecs
(package
(name "sbcl-cl-fast-ecs")
- (version "0.1.1")
+ (version "0.2.2")
(source
(origin
(method git-fetch)
@@ -7058,10 +7058,10 @@ (define-public sbcl-cl-fast-ecs
(commit version)))
(file-name (git-file-name "cl-fast-ecs" version))
(sha256
- (base32 "06cnhm8zpyqyjr17mji5wvj4gh2glpdw8gqy1vwrq3vgphfmg560"))))
+ (base32 "00nw5nwzcz8x1x1lycmjik8pcqzxrl896j0xjjl33rjljsmj45sx"))))
(build-system asdf-build-system/sbcl)
(native-inputs
- (list sbcl-parachute))
+ (list sbcl-chlorophyll sbcl-cl-mock sbcl-parachute))
(inputs
(list sbcl-alexandria sbcl-trivial-garbage))
(home-page "https://lockie.gitlab.io/cl-fast-ecs/")
--
2.39.2
Sharlatan Hellseher wrote 2 years ago
[PATCH 3/3] gnu: cl-mock: Update to 1.1.0-0.01762fd.
(address . 63059@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230424221505.30390-3-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (sbcl-cl-mock): Update to 1.1.0-0.01762fd.
[arguments]: Build cl-mock and cl-mock-basic systems.
[inputs]: Add sbcl-bordeaux-threads.
---
gnu/packages/lisp-check.scm | 17 +++++++++++------
1 file changed, 11 insertions(+), 6 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 1b4d80de00..1d2e439e9a 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -253,23 +253,28 @@ (define-public ecl-checkl
(sbcl-package->ecl-package sbcl-checkl))
(define-public sbcl-cl-mock
- ;; .asd version only got updated recently, despired the old GitHug "1.0.1" release.
- (let ((commit "7988dca2093358911b67597a2cd1570c785dfe76"))
+ (let ((commit "01762fda96718fefd3745ce4a20a4013a865b109")
+ (revision "0"))
(package
(name "sbcl-cl-mock")
- (version (git-version "1.0.1" "1" commit))
+ (version (git-version "1.1.0" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/Ferada/cl-mock/")
(commit commit)))
- (file-name (git-file-name name version))
+ (file-name (git-file-name "cl-mock" version))
(sha256
- (base32 "0f40wikcf783jx26ip0nnhwjjfjvjiw7njqsqrb6kaphc8bgw0i1"))))
+ (base32 "19641sm3klx9yfk8lr376rfkd26vy72yp1hkpkqcw3q3m1xrf9xp"))))
(build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:asd-systems '("cl-mock" "cl-mock-basic")))
(inputs
- (list sbcl-alexandria sbcl-closer-mop sbcl-trivia))
+ (list sbcl-alexandria
+ sbcl-bordeaux-threads
+ sbcl-closer-mop
+ sbcl-trivia))
(native-inputs
(list sbcl-fiveam))
(home-page "https://github.com/Ferada/cl-mock")
--
2.39.2
Guillaume Le Vaillant wrote 2 years ago
Re: [bug#63059] [PATCH 0/3] gnu: cl-fast-ecs: Update to 0.2.2
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 63059-done@debbugs.gnu.org)
87y1me4wlx.fsf@kitej
Patches pushed as 870f2d40e055d57659dff0dc20b903522f055bb0 and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZEki6g8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/JLQD+Pux2fQgmUzMZf9q8GsAeKYFnxA3+99DMJn15
3QTCDyUA/3+P3CpbG55KMuRhbZQQDKk+3hNcX6hcfsEnDMI+Xk4q
=4Fc3
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63059@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63059
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help