[PATCH] Add support for the python i18n package to Guix

  • Open
  • quality assurance status badge
Details
2 participants
  • Felix Lechner
  • Graham James Addis
Owner
unassigned
Submitted by
Graham James Addis
Severity
normal
G
G
Graham James Addis wrote on 21 Apr 2023 17:53
644639c0.050a0220.aa986.1564@mx.google.com
The package is built from source at https://github.com/danhper/python-i18n
and is available on PyPi here: https://pypi.org/project/python-i18n/
---
gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 284f8019bb..ace316d746 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -135,6 +135,7 @@
;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
;;; Copyright © 2023 Amade Nemes <nemesamade@gmail.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2023 Graham James Addis <graham@addis.org.uk>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1600,6 +1601,29 @@ (define-public python-clyent
by @code{binstar}, @code{binstar-build}, and @code{chalmers}.")
(license license:bsd-3)))
+(define-public python-i18n
+ (package
+ (name "python-i18n")
+ (version "v0.3.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danhper/python-i18n")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0c7fjx3znyp0d8p5c8nlny8bcaa4q2i4dzd436cfas3afsha2mp8"))))
+ (build-system python-build-system)
+
+ (inputs (list python-pyyaml))
+ (synopsis
+ "This library provides i18n functionality for Python 3 out of the box")
+ (description (string-append
+ "This library provides i18n functionality for Python 3 out of the box.
The usage is mostly based on Rails i18n library."))
+ (home-page "https://github.com/danhper/python-i18n")
+ (license license:expat)))
+
(define-public python-babel
(package
(name "python-babel")
--
2.39.2
F
F
Felix Lechner wrote on 29 Nov 2023 19:04
(no subject)
(address . control@debbugs.gnu.org)(name . Graham James Addis)(address . grahamjamesaddis@gmail.com)
8734wol9ll.fsf@lease-up.com
reassign 63049 guix-patches
thanks
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 63049@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63049
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch