<guix-home>/profile/bin missing from PATH for ssh commands

  • Done
  • quality assurance status badge
Details
2 participants
  • Janneke Nieuwenhuizen
  • Ludovic Courtès
Owner
unassigned
Submitted by
Janneke Nieuwenhuizen
Severity
normal
J
J
Janneke Nieuwenhuizen wrote on 22 Apr 2023 10:19
(address . bug-guix@gnu.org)
87fs8ss50e.fsf@gnu.org
Hi,

Yesterday I updated my account on our 'kluit' server to use guix home,
and found that broke pushing to my git archives. Apparently, my git
installed as a guix home package is not seen for ssh commands.

Toggle snippet (6 lines)
$ ssh kluit type -p git
[1]10:13:59 janneke@drakenpad:~
$ ssh kluit echo '$PATH'
/run/setuid-programs:/home/janneke/.config/guix/current/bin:/home/janneke/.guix-profile/bin:/run/current-system/profile/bin:/run/current-system/profile/sbin

See? Although there is no "/home/janneke/.guix-profile/bin", it is
still present in PATH, while "/home/janneke/.guix-home/profile/bin" is
missing!

Also (re-)installing git in my home profile again (ugh!) is a workaround
to fix this:

Toggle snippet (5 lines)
$ ssh kluit type -p git
/home/janneke/.guix-profile/bin/git
10:14:52 janneke@drakenpad:~

The attached patch has a fix for this. WYDT?

Greetings,
Janneke
From 2ac41477dad5699b748acfc72d4e91e0e14fa16a Mon Sep 17 00:00:00 2001
From: Janneke Nieuwenhuizen <janneke@gnu.org>
Date: Sat, 22 Apr 2023 09:58:48 +0200
Subject: [PATCH] gnu: system: Cater for Guix Home in PATH.

* gnu/system.scm (operating-system-etc-service): Also add a user's
<guix-home>/profile/bin directory to PATH, before <guix-profile>/bin.
---
gnu/system.scm | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/system.scm b/gnu/system.scm
index c17c6e4e98..df1e4e8640 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2020, 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Florian Pelz <pelzflorian@pelzflorian.de>
;;; Copyright © 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <jannek@gnu.org>
+;;; Copyright © 2020, 2023 Jan (janneke) Nieuwenhuizen <jannek@gnu.org>
;;; Copyright © 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 raid5atemyhomework <raid5atemyhomework@protonmail.com>
@@ -1037,8 +1037,11 @@ (define* (operating-system-etc-service os)
export `cat /etc/environment | cut -d= -f1`
fi
-# Arrange so that ~/.config/guix/current comes first.
-for profile in \"$HOME/.guix-profile\" \"$HOME/.config/guix/current\"
+# Arrange so that ~/.config/guix/current comes first,
+# and guix-home comes before guix-profile.
+for profile in \"$HOME/.guix-profile\" \\
+ \"$HOME/.guix-home/profile\" \\
+ \"$HOME/.config/guix/current\"
do
if [ -f \"$profile/etc/profile\" ]
then
--
2.39.2
--
Janneke Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond https://LilyPond.org
Freelance IT https://www.JoyOfSource.com| Avatar® https://AvatarAcademy.com
J
J
Janneke Nieuwenhuizen wrote on 23 Apr 2023 09:57
etc/teams.scm cc home
(address . 63009@debbugs.gnu.org)
878rejrpyb.fsf_-_@gnu.org

J
J
Janneke Nieuwenhuizen wrote on 25 Apr 2023 11:09
etc/team.scm cc home #2
(address . 63009@debbugs.gnu.org)
87zg6wpbto.fsf@gnu.org
Seems only one X-Debbugs-Cc header is honoured at a time, forgot them
initiially...
J
J
Janneke Nieuwenhuizen wrote on 25 Apr 2023 11:11
etc/team.scm cc home #3
(address . 63009@debbugs.gnu.org)
87y1mgpbr2.fsf@gnu.org
Seems only one X-Debbugs-Cc header is honoured at a time, forgot them
initiially...
J
J
Janneke Nieuwenhuizen wrote on 29 Apr 2023 09:22
control message for bug #63009
(address . control@debbugs.gnu.org)
87cz3nnods.fsf@gnu.org
tags 63009 + patch
quit
L
L
Ludovic Courtès wrote on 11 May 2023 14:29
Re: bug#63009: <guix-home>/profile/bin missing from PATH for ssh commands
(name . Janneke Nieuwenhuizen)(address . janneke@gnu.org)(address . 63009@debbugs.gnu.org)
87ttwj3vbt.fsf@gnu.org
Hi,

This patch had fallen through the cracks…

Janneke Nieuwenhuizen <janneke@gnu.org> skribis:

Toggle quote (8 lines)
>>From 2ac41477dad5699b748acfc72d4e91e0e14fa16a Mon Sep 17 00:00:00 2001
> From: Janneke Nieuwenhuizen <janneke@gnu.org>
> Date: Sat, 22 Apr 2023 09:58:48 +0200
> Subject: [PATCH] gnu: system: Cater for Guix Home in PATH.
>
> * gnu/system.scm (operating-system-etc-service): Also add a user's
> <guix-home>/profile/bin directory to PATH, before <guix-profile>/bin.

LGTM, thanks!

Ludo’.
J
J
Janneke Nieuwenhuizen wrote on 12 May 2023 10:02
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 63009-done@debbugs.gnu.org)
87cz36vuy4.fsf@gnu.org
Ludovic Courtès writes:

Hello,

Toggle quote (2 lines)
> This patch had fallen through the cracks…

Ah, no problem.

Toggle quote (12 lines)
> Janneke Nieuwenhuizen <janneke@gnu.org> skribis:
>
>>>From 2ac41477dad5699b748acfc72d4e91e0e14fa16a Mon Sep 17 00:00:00 2001
>> From: Janneke Nieuwenhuizen <janneke@gnu.org>
>> Date: Sat, 22 Apr 2023 09:58:48 +0200
>> Subject: [PATCH] gnu: system: Cater for Guix Home in PATH.
>>
>> * gnu/system.scm (operating-system-etc-service): Also add a user's
>> <guix-home>/profile/bin directory to PATH, before <guix-profile>/bin.
>
> LGTM, thanks!

Great, pushed to master as

ff2e22d1e122eb5b85fd85f8e922e6e8cfb0ee7b

Janneke

--
Janneke Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond https://LilyPond.org
Freelance IT https://www.JoyOfSource.com| Avatar® https://AvatarAcademy.com
Closed
?