[PATCH core-updates] gnu: python-aenum: Update to 3.1.12.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Kaelyn Takata
Owner
unassigned
Submitted by
Kaelyn Takata
Severity
normal

Debbugs page

Kaelyn Takata wrote 2 years ago
(address . guix-patches@gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
e2bdde498536faaa60e1ff6156fdaa92921e9219.1682113467.git.kaelyn.alexi@protonmail.com
* gnu/packages/python-xyz.scm (python-aenum): Update to 3.1.12.
[source]: Add snippet to delete Python 2 specific files.
---
gnu/packages/python-xyz.scm | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 10b28f0888..2f5123fa51 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2407,13 +2407,18 @@ (define-public python-textparser
(define-public python-aenum
(package
(name "python-aenum")
- (version "2.2.4")
+ (version "3.1.12")
(source
(origin
(method url-fetch)
(uri (pypi-uri "aenum" version))
(sha256
- (base32 "0r1812bjm72x73pl7y4yhffr4zbdjgxa08avsy4b3di0pqgqv0l1"))))
+ (base32 "1w1ffkcxgnimi5w8802qk6w2qxz9k8hpvsg6yy2zi08ahs8iqlry"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Delete the Python 2 specific files which won't compile load
+ ;; in Python 3.
+ '(for-each delete-file (find-files "." "_py2.py$")))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases

base-commit: 3f7ae420d8a54d4e2ab7f349c40d8930fe9e0771
--
2.39.2
Kaelyn wrote 2 years ago
(name . 63007@debbugs.gnu.org)(address . 63007@debbugs.gnu.org)
CrS1K1g8uyZ7gNo2V8KBV1W54F7qzVa6LSaEwDyPTaS1XPda03LkUOq-YA5cNi7eq4cga2zwMnsIHm23CbUr0lWfNv0kVMReXc2SjgV03bE=@protonmail.com
Hi,

I just realized this could easily apply to master as well; I marked the patch for core-updates because the current version of python-aenum builds fine on master but has test failures on core-updates. I discovered and wanted to fix the failure there as part of testing my local profile--including a package definition for the OnlyKey CLI, which depends on python-aenum and which seems to work fine with the updated version.

Cheers,
Kaelyn
Andreas Enge wrote 2 years ago
Close
(address . 63007-done@debbugs.gnu.org)
ZERDhoMP0nlqLBzV@jurong
Hello Kaelyn,

thanks for the patch, which I applied to core-updates. It will soon
arrive in master anyway.

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63007@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63007
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help