[PATCH] gnu: Add trurl.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 21 Apr 2023 22:53
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230421205329.13503-1-sharlatanus@gmail.com
* gnu/packages/curl.scm (trurl): New variable.
---
gnu/packages/curl.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index bd00a6d274..ef9e284d38 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -411,3 +412,39 @@ (define-public curlie
on features and performance. All @code{curl} options are exposed with syntax
sugar and output formatting inspired from @code{httpie}.")
(license license:expat)))
+
+(define-public trurl
+ (package
+ (name "trurl")
+ (version "0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/curl/trurl")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mvkpjs6wnz5hzmp2iglik85zljrzglsa6fm839l78fhw89dg3w6"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:test-target "test"
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list python))
+ ;; Tests failed on older curl version
+ ;; (see https://github.com/curl/trurl/pull/165)
+ (inputs (list curl-7.84.0))
+ (home-page "https://curl.se/trurl/")
+ (synopsis "Command line tool for URL parsing and manipulatio")
+ (description "@code{trurl} is a tool in a similar spirit of @code{tr} but
+for URLs. Here, @code{tr} stands for translate or transpose.
+
+@code{trurl} is a command line tool that parses and manipulates URLs, designed
+to help shell script authors everywhere.")
+ (license (license:non-copyleft "file://COPYING"
+ "See COPYING in the distribution."))))
--
2.39.2
N
N
Nicolas Goaziou wrote on 25 Apr 2023 11:51
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 63005-done@debbugs.gnu.org)
87zg6wnvb8.fsf@nicolasgoaziou.fr
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/curl.scm (trurl): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63005@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63005
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch