[PATCH] gnu: Add emacs-bookmark-plus

  • Done
  • quality assurance status badge
Details
2 participants
  • kyle
  • Nicolas Goaziou
Owner
unassigned
Submitted by
kyle
Severity
normal

Debbugs page

kyle wrote 2 years ago
(address . guix-patches@gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
e62afb73b971f2b41cb7395e623088f12003420d.1682082880.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6618aac332..6522012cdd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -349,6 +349,29 @@ (define-public emacs-ace-jump-helm-line
"This package allows using Ace jump to a candidate in Helm window.")
(license license:gpl3+))))
+(define-public emacs-bookmark-plus
+ (package
+ (name "emacs-bookmark-plus")
+ (version "2022.11.05")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacsmirror/bookmark-plus")
+ (commit "3db369056a722c42b3eafd10a91831f87d056dfa")))
+ (sha256
+ (base32
+ "0fnq24f597zfr8jj5h3vr87kdil5lhy11m81q6ayqc03qm0jymrf"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/emacsmirror/bookmark-plus")
+ (synopsis "Extensions to the bookmark.el library in Emacs")
+ (description
+ "Bookmarks are a powerful Emacs feature. This package makes them even more
+versatile. You can bookmark many more kinds of data. You can add tags. There
+are many more ways to organize and display your bookmarks. I recommend reading
+the extensive documentation about BookmarkPlus on the Emacs Wiki.")
+ (license license:gpl3)))
+
(define-public emacs-cfrs
(package
(name "emacs-cfrs")
--
2.39.2
Nicolas Goaziou wrote 2 years ago
(name . kyle)(address . kyle@posteo.net)(address . 62993@debbugs.gnu.org)
87mt312uvb.fsf@nicolasgoaziou.fr
Hello,

kyle <kyle@posteo.net> writes:

Toggle quote (14 lines)
> +(define-public emacs-bookmark-plus
> + (package
> + (name "emacs-bookmark-plus")
> + (version "2022.11.05")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/emacsmirror/bookmark-plus")
> + (commit "3db369056a722c42b3eafd10a91831f87d056dfa")))
> + (sha256
> + (base32
> + "0fnq24f597zfr8jj5h3vr87kdil5lhy11m81q6ayqc03qm0jymrf"))))

Nitpick: indentation is a bit off here.

Toggle quote (4 lines)
> + (build-system emacs-build-system)
> + (home-page "https://github.com/emacsmirror/bookmark-plus")
> + (synopsis "Extensions to the bookmark.el library in Emacs")

Nitpick: Bookmark (the library) instead of "bookmark.el" (the file).

Toggle quote (6 lines)
> + (description
> + "Bookmarks are a powerful Emacs feature. This package makes them even more
> +versatile. You can bookmark many more kinds of data. You can add tags. There
> +are many more ways to organize and display your bookmarks. I recommend reading
> +the extensive documentation about BookmarkPlus on the Emacs Wiki.")

Guix usually puts two spaces between sentences.

Toggle quote (2 lines)
> + (license license:gpl3)))

License is actually GPL3+.

Otherwise, LGTM.

Regards,
--
Nicolas Goaziou
Nicolas Goaziou wrote 2 years ago
(name . kyle)(address . kyle@posteo.net)(address . 62993@debbugs.gnu.org)
87ildp2up5.fsf@nicolasgoaziou.fr
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (2 lines)
> Otherwise, LGTM.

And thanks for the patch, of course!
kyle wrote 2 years ago
[PATCH v2] gnu: Add emacs-bookmark-plus
(address . 62993@debbugs.gnu.org)(name . Kyle Andrews)(address . kyle@posteo.net)
d6cd5f2ad70d091219a19d5ad2b2562a71d17721.1682114443.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6618aac332..ff2bbf0bd7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -349,6 +349,29 @@ (define-public emacs-ace-jump-helm-line
"This package allows using Ace jump to a candidate in Helm window.")
(license license:gpl3+))))
+(define-public emacs-bookmark-plus
+ (package
+ (name "emacs-bookmark-plus")
+ (version "2022.11.05")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacsmirror/bookmark-plus")
+ (commit "3db369056a722c42b3eafd10a91831f87d056dfa")))
+ (sha256
+ (base32
+ "0fnq24f597zfr8jj5h3vr87kdil5lhy11m81q6ayqc03qm0jymrf"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/emacsmirror/bookmark-plus")
+ (synopsis "Extensions to the Bookmark library in Emacs")
+ (description
+ "Bookmarks are a powerful Emacs feature. This package makes them even
+more versatile. You can bookmark many more kinds of data. You can add tags.
+There are many more ways to organize and display your bookmarks. I recommend
+reading the extensive documentation about BookmarkPlus on the Emacs Wiki.")
+ (license license:gpl3+)))
+
(define-public emacs-cfrs
(package
(name "emacs-cfrs")
--
2.39.2
Nicolas Goaziou wrote 2 years ago
(name . kyle)(address . kyle@posteo.net)(address . 62993-done@debbugs.gnu.org)
87ildo1b5b.fsf@nicolasgoaziou.fr
Hello,

kyle <kyle@posteo.net> writes:

Toggle quote (2 lines)
> +(define-public emacs-bookmark-plus

I normalized the commit message and applied your patch. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62993@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62993
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help