[PATCH] gnu: Add python-rseqc.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
20230421102845.46529-1-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-rseqc): New variable.
---
gnu/packages/bioinformatics.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b27e12a5b4..ecc1815539 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3060,6 +3060,30 @@ (define-public python-pysam
also includes an interface for tabix.")
(license license:expat)))
+(define-public python-rseqc
+ (package
+ (name "python-rseqc")
+ (version "5.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "RSeQC" version))
+ (sha256
+ (base32
+ "106av4ms6agrfjdlw5j3fsrk86clr0f4ygysv19g66l6hj3laz9w"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-bx-python python-numpy python-pybigwig
+ python-pysam))
+ (native-inputs (list python-cython python-nose))
+ (home-page "https://github.com/MonashBioinformaticsPlatform/RSeQC")
+ (synopsis "RNA-seq quality control packag")
+ (description
+ "Useful modules that can comprehensively evaluate high throughput sequence data.
+Some basic modules quickly inspect sequence, quality, nucleotide composition bias,
+PCR bias and GC bias, while RNA-seq specific modules evaluate sequencing saturation,
+mapped reads distribution, coverage uniformity, strand specificity, transcript level
+RNA integrity and etc.")
+ (license license:gpl3)))
+
(define-public python-twobitreader
(package
(name "python-twobitreader")
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 62989-done@debbugs.gnu.org)
87jzu96uwb.fsf@elephly.net
I’m closing this because

1. we have a package for rseqc.
2. this is an unmaintained fork
3. IIRC it doesn’t actually work

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62989@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62989
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help