[PATCH core-updates 1/2] gnu: lz4: Remove valgrind from native-inputs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 20 Apr 2023 15:17
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20230420131714.16965-1-zimon.toutoune@gmail.com
* gnu/compression.scm (lz4)[native-inputs]: Remove valgrind.
[arguments]<phases>: Remove trailing #t.
---
gnu/packages/compression.scm | 12 +++---------
1 file changed, 3 insertions(+), 9 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 7283a05050..8a8b94c07b 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -840,11 +840,7 @@ (define-public lz4
(build-system gnu-build-system)
(outputs (list "out" "static"))
(native-inputs
- (append
- (list python) ;; For tests.
- (if (member (%current-system) (package-supported-systems valgrind))
- (list valgrind)
- '())))
+ (list python)) ;; For tests.
(arguments
`(;; Not designed for parallel testing.
;; See https://github.com/lz4/lz4/issues/957#issuecomment-737419821
@@ -860,16 +856,14 @@ (define-public lz4
(substitute* "tests/Makefile"
;; This fails when $prefix is not a single top-level directory.
(("^test: (.*) test-install" _ targets)
- (string-append "test: " targets)))
- #t))
+ (string-append "test: " targets)))))
(add-after 'install 'move-static-library
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(static (assoc-ref outputs "static")))
(mkdir-p (string-append static "/lib"))
(rename-file (string-append out "/lib/liblz4.a")
- (string-append static "/lib/liblz4.a"))
- #t))))))
+ (string-append static "/lib/liblz4.a"))))))))
(home-page "https://www.lz4.org")
(synopsis "Compression algorithm focused on speed")
(description "LZ4 is a lossless compression algorithm, providing

base-commit: c0ac055918ec1eee53c7e14f62c2e3516321588b
--
2.38.1
Z
Z
zimoun wrote on 20 Apr 2023 15:23
[PATCH core-updates 2/2] gnu: valgrind: Update to 3.20.0.
(address . 62967@debbugs.gnu.org)
20230420132333.17102-1-zimon.toutoune@gmail.com
* gnu/packages/valgrind.scm (valgrind): Update to 3.20.0.
[arguments]<phases>: Remove trailing #t.
---
gnu/packages/valgrind.scm | 21 ++++-----------------
1 file changed, 4 insertions(+), 17 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 204dd4a3c5..113cf614c2 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -40,7 +40,7 @@ (define-public valgrind
(name "valgrind")
;; Note: check "guix refresh -l -e '(@ (gnu packages valgrind) valgrind)'"
;; when updating this package to find which branch it should go to.
- (version "3.17.0")
+ (version "3.20.0")
(source (origin
(method url-fetch)
(uri (list (string-append "https://sourceware.org/pub/valgrind"
@@ -49,8 +49,7 @@ (define-public valgrind
"/valgrind-" version ".tar.bz2")))
(sha256
(base32
- "18l5jbk301j3462gipqn9bkfx44mdmwn0pwr73r40gl1irkfqfmd"))
- (patches (search-patches "valgrind-enable-arm.patch"))))
+ "1ipkp6yi202pml2r0qwflysmq86dkqd8iyi1y51d6y70vcqw0dl5"))))
(build-system gnu-build-system)
(outputs '("doc" ;16 MB
"out"))
@@ -69,15 +68,13 @@ (define-public valgrind
(substitute* (find-files dir "\\.supp$")
(("obj:/lib") "obj:*/lib")
(("obj:/usr/X11R6/lib") "obj:*/lib")
- (("obj:/usr/lib") "obj:*/lib"))
- #t)))
+ (("obj:/usr/lib") "obj:*/lib")))))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let ((orig (format #f "~a/share/doc" (assoc-ref outputs "out")))
(dest (format #f "~a/share" (assoc-ref outputs "doc"))))
(mkdir-p dest)
- (rename-file orig dest)
- #t))))))
+ (rename-file orig dest)))))))
(native-inputs
(list perl))
(home-page "https://www.valgrind.org/")
@@ -97,16 +94,6 @@ (define-public valgrind
(define-public valgrind/interactive
(package/inherit
valgrind
- (version "3.20.0")
- (source (origin
- (method url-fetch)
- (uri (list (string-append "https://sourceware.org/pub/valgrind"
- "/valgrind-" version ".tar.bz2")
- (string-append "ftp://sourceware.org/pub/valgrind"
- "/valgrind-" version ".tar.bz2")))
- (sha256
- (base32
- "1ipkp6yi202pml2r0qwflysmq86dkqd8iyi1y51d6y70vcqw0dl5"))))
(inputs
;; GDB is needed to provide a sane default for `--db-command'.
(list gdb `(,(canonical-package glibc) "debug")))
--
2.38.1
A
A
Andreas Enge wrote on 26 Apr 2023 10:50
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 62967@debbugs.gnu.org)
ZEjl7XcwTFJgei0O@jurong
Well, building this on CI is trickier than it looks at first sight:
The derivations are not changed by dropping the valgrind input from lz4,
the source code of packages downloaded via subversion is not downloaded
again, so r-minimal still fails because texlive-ms is not retried, but
just memorised as failing. I will restart a few packages by hand, and
then relaunch all failing builds.

Andreas
A
A
Andreas Enge wrote on 26 Apr 2023 14:31
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 62967-done@debbugs.gnu.org)
ZEkZnjy/sxDJeFOt@jurong
And without a button to compare with current master, it is difficult to
judge. But r-minimal has built, as well as lots of R packages; I checked
a few missing ones, for which indeed a different input (not related to
valgrind) fails. KDE packages also do not build due to a test failure in
kpimcommon, which also appears on master.

So I am going to push.

Andreas
Closed
S
S
Simon Tournier wrote on 28 Apr 2023 11:41
Re: bug#62967: [PATCH core-updates 2/2] gnu: valgrind: Update to 3.20.0.
(name . Andreas Enge)(address . andreas@enge.fr)(address . 62967-done@debbugs.gnu.org)
87bkj8bays.fsf@gmail.com
Hi Andreas,

On mer., 26 avril 2023 at 14:31, Andreas Enge <andreas@enge.fr> wrote:
Toggle quote (8 lines)
> And without a button to compare with current master, it is difficult to
> judge. But r-minimal has built, as well as lots of R packages; I checked
> a few missing ones, for which indeed a different input (not related to
> valgrind) fails. KDE packages also do not build due to a test failure in
> kpimcommon, which also appears on master.
>
> So I am going to push.

Cool! Thanks.

Cheers,
simon
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62967@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62967
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch