(address . guix-patches@gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
* gnu/packages/cryptsetup.scm (cryptsetup): Update to 2.6.1.
[native-inputs]: Add ruby-asciidoctor.
[inputs]: Add libssh.
(cryptsetup-static)[arguments]: Disable asciidoc and ssh token support.
---
gnu/packages/cryptsetup.scm | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)
Toggle diff (62 lines)
diff --git a/gnu/packages/cryptsetup.scm b/gnu/packages/cryptsetup.scm
index d8a6437259..cdeed5c26a 100644
--- a/gnu/packages/cryptsetup.scm
+++ b/gnu/packages/cryptsetup.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2019–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2023 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,12 +31,14 @@ (define-module (gnu packages cryptsetup)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages ruby)
+ #:use-module (gnu packages ssh)
#:use-module (gnu packages web))
(define-public cryptsetup
(package
(name "cryptsetup")
- (version "2.3.7")
+ (version "2.6.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/utils/cryptsetup/v"
@@ -43,7 +46,7 @@ (define-public cryptsetup
"/cryptsetup-" version ".tar.xz"))
(sha256
(base32
- "1a97rvi6arsj8dikh1qsvixx9rizm89k155q2ypifqlqllr530v1"))))
+ "14s6vbb9llpgnhmv0badxxzhi73jp4vyvp8swk4bjah7l5jys3a1"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -55,11 +58,13 @@ (define-public cryptsetup
;; GRUB 2.06 supports LUKS2, but does it reliably support all set-ups…?
"--with-default-luks-format=LUKS1")))
(native-inputs
- (list pkg-config))
+ (list pkg-config
+ ruby-asciidoctor))
(inputs
(list argon2
json-c
libgcrypt
+ libssh
lvm2 ; device-mapper
popt
`(,util-linux "lib"))) ;libuuid
@@ -110,7 +115,9 @@ (define-public cryptsetup-static
;; The default is OpenSSL which provides better PBKDF performance.
"--with-crypto_backend=gcrypt"
+ "--disable-asciidoc"
"--disable-blkid"
+ "--disable-ssh-token"
;; 'libdevmapper.a' pulls in libpthread, libudev and libm.
"LIBS=-ludev -pthread -lm")
--
2.39.2