recoll package does not provide recollq which Emacs needs

  • Done
  • quality assurance status badge
Details
3 participants
  • kiasoc5
  • Kyle Andrews
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Kyle Andrews
Severity
normal

Debbugs page

Kyle Andrews wrote 2 years ago
(name . bug-guix)(address . bug-guix@gnu.org)
87h6tc76ty.fsf@posteo.net
Dear Guix,

I am experimenting with using Recoll to help me discover topical files on my computer. I'm finding it very helpful, but I would rather eschew the QT interface in favor of sticking with Emacs.

There is an existing package which integrates with recoll interactively through "consult" on ELPA. Unfortunately, it depends on recoll providing an executable called recollq. Yet, recollq is not currently provided the recoll package in Guix. However, strangely the recollq man page is. The HTML documentation in the source tarball suggests it is not always built, but being unfamiliar with these complex auto-configured Makefile-based workflow I couldn't find a way to enable it.

While I have found that `recoll -t' lets me make plain text queries from a database at a shell prompt, I was unsuccessful substituting `recollq' with `recoll -t' in the Emacs extension package since recollq apparently needed to be a file on the path. It would seem to me a lot less janky to just include that file. I included what I tried in the package recipe for emacs-consult-recoll below.

Thanks,
Kyle

P.S. - Here is the package recipe I made for emacs-consult-recoll based on the ELPA importer and reading the consult-recoll web page to simplify the description.

```
(use-modules
(gnu packages)
(guix packages)
(guix download)
(guix build utils)
((guix licenses) #:prefix license:)
(guix build-system emacs)
(gnu packages emacs-xyz))

(define-public emacs-consult-recoll
(package
(name "emacs-consult-recoll")
(version "0.8")
(source (origin
(method url-fetch)
(uri (string-append
".tar"))
;; (modules '((guix build utils)))
;; (snippet
;; (substitute* "consult-recoll.el"
;; (("recollq") "recoll -t -n 0")))
(sha256
(base32
"02vg1rr2fkcqrrivqgggdjdq0ywvlyzazwq1xd02yah3j4sbv4ag"))))
(build-system emacs-build-system)
(propagated-inputs (list emacs-consult))
(synopsis "Recoll queries using a consult interface in Emacs")
(description
" This package provides an emacs interface to perform recoll queries,
and display its results, via consult. It is also recommened that you
use a a package for vertical display of completions that works well
with consult, such as vertico.

Recoll is a local search engine that knows how to index a wide variety
of file formats, including PDFs, org and other text files and
emails. It also offers a sophisticated query language, and, for some
document kinds, snippets in the the found documents actually matching
the query at hand.")
(license license:gpl3)))
```
kiasoc5 wrote 2 years ago
(address . 62946@debbugs.gnu.org)
bf1cd851-a173-a1e8-f6e2-6ecc4004b654@disroot.org
I updated recoll to the latest version and added the recollq binary in
#62971. Can you see if that works?
Maxim Cournoyer wrote 1 years ago
Re: bug#62946: recoll package does not provide recollq which Emacs needs
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 62946-done@debbugs.gnu.org)
87cyxv5dol.fsf@gmail.com
kiasoc5 <kiasoc5@disroot.org> writes:

Toggle quote (3 lines)
> I updated recoll to the latest version and added the recollq binary in
> #62971. Can you see if that works?

I'm happy to assume it does; the updated package has a 'recollq' command
under bin.

Closing!

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62946@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62946
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help