[PATCH core-updates] gnu: gcc-7, gcc-10, gcc-11: Hide packages.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Simon Tournier
Owner
unassigned
Submitted by
Simon Tournier
Severity
normal

Debbugs page

Simon Tournier wrote 2 years ago
(address . guix-patches@gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230418101456.1479034-1-zimon.toutoune@gmail.com
* gnu/packages/gcc.scm (gcc-7, gcc-10, gcc-11): Also inherit 'hidden?'
properties.
---
gnu/packages/gcc.scm | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)

Hi,

This fixes annoyance and does not trigger any rebuild. The package 'gcc'
whatever its version should be visisble from the command line. The initial,

(hidden-package
(package
(name "gcc")
(version "4.7.4")

had been lost when inheriting, introduced by commit
2576e2019d2f5049ad3dc51404c7e991af45d1d6:

gnu: gcc: Add 'compiler-cpu-architectures' property.

* gnu/packages/gcc.scm (%gcc-7.5-x86_64-micro-architectures)
(%gcc-10-x86_64-micro-architectures): New variables.
(gcc-7, gcc-10): Add 'properties' field.
* gnu/packages/commencement.scm (make-gcc-toolchain): Likewise.

Cheers,
simon




Toggle diff (38 lines)
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 5b1ef83ce6..b7d15d0730 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -632,7 +632,8 @@ (define-public gcc-7
`((compiler-cpu-architectures
("aarch64" ,@%gcc-7.5-aarch64-micro-architectures)
("armhf" ,@%gcc-7.5-armhf-micro-architectures)
- ("x86_64" ,@%gcc-7.5-x86_64-micro-architectures))))))
+ ("x86_64" ,@%gcc-7.5-x86_64-micro-architectures))
+ ,@(package-properties gcc-6)))))
(define-public gcc-8
(package
@@ -688,7 +689,8 @@ (define-public gcc-10
`((compiler-cpu-architectures
("aarch64" ,@%gcc-10-aarch64-micro-architectures)
("armhf" ,@%gcc-10-armhf-micro-architectures)
- ("x86_64" ,@%gcc-10-x86_64-micro-architectures))))))
+ ("x86_64" ,@%gcc-10-x86_64-micro-architectures))
+ ,@(package-properties gcc-8)))))
(define-public gcc-11
(package
@@ -722,7 +724,8 @@ (define patch
`((compiler-cpu-architectures
("aarch64" ,@%gcc-11-aarch64-micro-architectures)
("armhf" ,@%gcc-11-armhf-micro-architectures)
- ("x86_64" ,@%gcc-11-x86_64-micro-architectures))))))
+ ("x86_64" ,@%gcc-11-x86_64-micro-architectures))
+ ,@(package-properties gcc-8)))))
(define-public gcc-12
(package

base-commit: 39ec7b86c0730f07da01f008f85287c05efde1bc
--
2.38.1
Ludovic Courtès wrote 2 years ago
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 62923-done@debbugs.gnu.org)
874jpdxwet.fsf@gnu.org
Hi,

Simon Tournier <zimon.toutoune@gmail.com> skribis:

Toggle quote (3 lines)
> * gnu/packages/gcc.scm (gcc-7, gcc-10, gcc-11): Also inherit 'hidden?'
> properties.

Good catch. Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62923@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62923
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help