[PATCH] gnu: python-pytest-trio: Disable tests.

  • Done
  • quality assurance status badge
Details
3 participants
  • Katherine Cox-Buday
  • jgart
  • Maxim Cournoyer
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20230417152743.19932-1-jgart@dismail.de
See the following GitHub issue on the project page:

* gnu/packages/python-check.scm (python-pytest-trio)[arguments]: Disable
broken tests.
---

Hi,

pytest-trio currently causes guix pull to fail because the tests are broken.

I have diabled the tests and linked the associated issue from the project page detailing more.

all best,

jgart

gnu/packages/python-check.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1046602800..613fa23a99 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1095,7 +1095,9 @@ (define-public python-pytest-trio
(base32 "0c8cqf9by2884riksrqymqfp2g1d2d798a2zalcw9hmf34c786y0"))))
(build-system python-build-system)
(arguments
- `(#:phases
+ `(;; https://github.com/python-trio/pytest-trio/issues/122
+ #:tests? #f ; Tests are currently broken.
+ #:phases
(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? inputs outputs #:allow-other-keys)
--
2.39.2
J
9059240d2b0208024e937ce3ab4a54de@dismail.de
Hi,

I forgot to add that there is also an issue reporting the pytest-trio failure here by bdju:


62906 fixes the problem by disabling the tests for pytest-trio.

all best,

jgart
K
K
Katherine Cox-Buday wrote on 17 Apr 2023 18:19
(address . guix-patches@gnu.org)
u1jrib$lv7$1@ciao.gmane.io
On 4/17/23 9:33 AM, jgart via Guix-patches via wrote:
Toggle quote (12 lines)
> Hi,
>
> I forgot to add that there is also an issue reporting the pytest-trio failure here by bdju:
>
> https://issues.guix.gnu.org/62871
>
> 62906 fixes the problem by disabling the tests for pytest-trio.
>
> all best,
>
> jgart

I'm also also running into this. I can confirm that it looks like the
issue is upstream, and an issue is open for it.

+1 for disabling the tests (I don't have merge abilities).
M
M
Maxim Cournoyer wrote on 18 Apr 2023 04:12
Re: bug#62906: [PATCH] gnu: python-pytest-trio: Disable tests.
(name . jgart)(address . jgart@dismail.de)(address . 62906-done@debbugs.gnu.org)
87354y3pm1.fsf@gmail.com
Hello,

jgart <jgart@dismail.de> writes:

Toggle quote (15 lines)
> See the following GitHub issue on the project page:
> https://github.com/python-trio/pytest-trio/issues/122
>
> * gnu/packages/python-check.scm (python-pytest-trio)[arguments]: Disable
> broken tests.
> ---
>
> Hi,
>
> pytest-trio currently causes guix pull to fail because the tests are broken.
>
> I have diabled the tests and linked the associated issue from the project page detailing more.
>
> all best,

I don't understand how that was breaking 'guix pull' for you, it
shouldn't have played a role. I suspect extra channels.

I've pushed an updated to 0.8.0, with two tests disable in commit
27a4bfbd07022ebabc352a419c7588fcfc881d88. Closing!

--
Thanks,
Maxim
Closed
?