[PATCH] gnu: python-anyio: Update to 3.6.2

  • Done
  • quality assurance status badge
Details
3 participants
  • Greg Hogan
  • Hugo Buddelmeijer
  • Ludovic Courtès
Owner
unassigned
Submitted by
Hugo Buddelmeijer
Severity
normal

Debbugs page

Hugo Buddelmeijer wrote 2 years ago
(address . guix-patches@gnu.org)(name . Hugo Buddelmeijer)(address . hugo@buddelmeijer.nl)
ebd7ead212a77c2155120821c33b11a481e17a7c.1681734660.git.hugo@buddelmeijer.nl
python-anyio 3.5.0 does not work with trio 0.22, which was added on 2023/04/01.

It fails with

E trio.TrioDeprecationWarning: trio.MultiError is deprecated since Trio 0.22.0 [...]

python-anyio 3.6.2 works fine.

* gnu/packages/python-xyz.scm (python-anyio): Update to 3.6.2


---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0147870b06..4f936164ba 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25711,14 +25711,14 @@ (define-public python-iocapture
(define-public python-anyio
(package
(name "python-anyio")
- (version "3.5.0")
+ (version "3.6.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "anyio" version))
(sha256
(base32
- "19m58805wir4i2s45dd5ynwlzb7ky1218isbir53gpqzzgigzbm0"))))
+ "8bljjq5xq0l9id36q3vvjgygirq7g7q2bs41hdg82p379khvsi5x"))))
(build-system python-build-system)
(arguments
`(#:phases

base-commit: 9a5e1dc1f16f5f8c056e64f2077b035784003673
--
2.39.2
Greg Hogan wrote 2 years ago
(name . Hugo Buddelmeijer)(address . hugo@buddelmeijer.nl)(address . 62900@debbugs.gnu.org)
CA+3U0Z=p=Mz=VoJ3poQ=bWXuZTUKsVqrFzvHOt7UMD3GGXjzBQ@mail.gmail.com
On Mon, Apr 17, 2023 at 9:06 AM Hugo Buddelmeijer <hugo@buddelmeijer.nl> wrote:
Toggle quote (35 lines)
>
> python-anyio 3.6.2 works fine.
>
> * gnu/packages/python-xyz.scm (python-anyio): Update to 3.6.2
>
> ---
> gnu/packages/python-xyz.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 0147870b06..4f936164ba 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -25711,14 +25711,14 @@ (define-public python-iocapture
> (define-public python-anyio
> (package
> (name "python-anyio")
> - (version "3.5.0")
> + (version "3.6.2")
> (source
> (origin
> (method url-fetch)
> (uri (pypi-uri "anyio" version))
> (sha256
> (base32
> - "19m58805wir4i2s45dd5ynwlzb7ky1218isbir53gpqzzgigzbm0"))))
> + "8bljjq5xq0l9id36q3vvjgygirq7g7q2bs41hdg82p379khvsi5x"))))
> (build-system python-build-system)
> (arguments
> `(#:phases
>
> base-commit: 9a5e1dc1f16f5f8c056e64f2077b035784003673
> --
> 2.39.2

I see that this is still scheduled on qa.guix.gnu.org, with
python-pillow the only attempted package, even though that package is
a (4th-level) dependency of python-anyio, so why would this be a
derivation change?

I also see a slightly different hash, with a leading zero replacing
the trailing 'x'. I find this puzzling.

$ guix describe
Generation 43 Apr 18 2023 20:30:44 (current)
guix bb721d8
branch: master
commit: bb721d88618d93d38aa5dfc33629e223c8b1c884

$ guix graph --path python-anyio python-pillow
python-anyio@3.5.0
python-trio@0.22.0
python-ipython@8.2.0
python-matplotlib@3.5.2
python-pillow@9.2.0

$ wget --quiet -O -
| guix hash -
08bljjq5xq0l9id36q3vvjgygirq7g7q2bs41hdg82p379khvsi5
Hugo Buddelmeijer wrote 2 years ago
[PATCH v2] Upgrade python-anyio to 3.6.2
(address . 62900@debbugs.gnu.org)(name . Hugo Buddelmeijer)(address . hugo@buddelmeijer.nl)
ee9c4abc6a9edc040b7ec97ce9617f91e01cfab5.1681974787.git.hugo@buddelmeijer.nl
---

Thank you Greg. I'm a bit puzzled too (and embarashed).

Attached is the patch with the corrected hash. However, it has the same
problems as 3.5.0 so it is perhaps not worth it to merge this patch.

The mismatching hash is due to me trying to learn everything at the same
time: guix, scheme, emacs. I'm used to copy pasting with ctrl-insert
shift-insert and removing text with ctrl-backspace (IBM Common User
Access). With my muscle memory failing me, I botched changing the hash.

However, I believed I fixed the hash, and built the package, also with
--rounds=2, otherwise I would not have submitted the patch. At least,
that's what I thought, but apparently I did not and wasted your time.
My apologies for that; I'll be more careful in the future.

Now that I've submitted a broken patch, would that be noticed somewhere
automatically? The linter on qa.guix.gnu.org seems to be fine with it.
Or are patched packages not build automatically?

As about why the derivation changed, perhaps that is because
python-trio has been updated to 0.22? I don't yet fully understand how
these derivation work.

Once again my apologies, I feel bad for messing this patch up.

Hugo


gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0147870b06..0c2ec44db3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25711,14 +25711,14 @@ (define-public python-iocapture
(define-public python-anyio
(package
(name "python-anyio")
- (version "3.5.0")
+ (version "3.6.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "anyio" version))
(sha256
(base32
- "19m58805wir4i2s45dd5ynwlzb7ky1218isbir53gpqzzgigzbm0"))))
+ "08bljjq5xq0l9id36q3vvjgygirq7g7q2bs41hdg82p379khvsi5"))))
(build-system python-build-system)
(arguments
`(#:phases

base-commit: 9a5e1dc1f16f5f8c056e64f2077b035784003673
--
2.39.2
Ludovic Courtès wrote 2 years ago
control message for bug #62900
(address . control@debbugs.gnu.org)
871qg4811j.fsf@gnu.org
close 62900
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62900@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62900
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help