[PATCH core-updates 0/2] gnu: samba: Fix build on i686-linux.

  • Done
  • quality assurance status badge
Details
3 participants
  • John Kehayias
  • Kaelyn
  • Maxim Cournoyer
Owner
unassigned
Submitted by
John Kehayias
Severity
normal
J
J
John Kehayias wrote on 17 Apr 2023 06:23
(name . Guix-patches)(address . guix-patches@gnu.org)
87jzybrval.fsf@protonmail.com
Hi Guix,

Two patches here:

1. Fix samba building on i686-linux, as the selftest configure option requires python-cryptography, which relies on rust and thus won't work on i686 currently. So conditionally enable this flag and that native-input.

The check here happens twice, better to have a let form for the whole package (or even reduce it to a "rust?" variable)? I went with the check we use for librsvg, but haven't checked on aarch64 if this does build. I did test that samba builds for x86_64 and i686-linux and this allows wine on x86_64 to build for me as well.

2. In doing this I noticed that samba is outdated and vulnerable to CVEs so I updated it in the next patch. I separately verified the download's signature, though samba's key is expired, so...

I didn't push this directly since I wasn't sure if there was a more elegant way to do this check and since I'm not certain on the rust architectures question.

A similar fix is needed on master I believe, but since the inheritance is flipped there I wasn't sure if this will just confuse the upcoming merge more. If the core-updates merge is happening soon we can wait? Or once this is good for core-updates I'll push the same fix to master.

Thanks!
John
J
J
J
John Kehayias wrote on 17 Apr 2023 06:34
[PATCH core-updates 2/2] gnu: samba: Update to 4.18.1.
(address . 62894@debbugs.gnu.org)
87h6tfrusc.fsf@protonmail.com
Empty Message
From 494277966cec68249f4c978dd52ebd1e8b527296 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Mon, 17 Apr 2023 00:11:33 -0400
Subject: [PATCH 2/2] gnu: samba: Update to 4.18.1.
* gnu/packages/samba.scm (samba): Update to 4.18.1.
---
gnu/packages/samba.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (24 lines)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 1621706807..f95ce13fc8 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -298,7 +298,7 @@ (define-public samba
(package
(inherit samba/pinned)
(name "samba")
- (version "4.17.0")
+ (version "4.18.1")
(source
;; For updaters: the current PGP fingerprint is
;; 81F5E2832BD2545A1897B713AA99442FB680B620.
@@ -307,7 +307,7 @@ (define-public samba
(uri (string-append "https://download.samba.org/pub/samba/stable/"
"samba-" version ".tar.gz"))
(sha256
- (base32 "0fl2y5avmyxjadh6zz0fwz35akd6c4j9lldzp2kyvjrgm36qx1h4"))))
+ (base32 "03ncp49pfpzjla205y3xpb9iy61dz4pryyrvyz26422a4hpsmpnf"))))
(properties (alist-delete 'hidden? (package-properties samba/pinned)))))
(define-public talloc
--
2.39.2
M
M
Maxim Cournoyer wrote on 18 Apr 2023 18:35
Re: bug#62894: [PATCH core-updates 0/2] gnu: samba: Fix build on i686-linux.
(name . John Kehayias)(address . john.kehayias@protonmail.com)(address . 62894@debbugs.gnu.org)
87y1mp2lng.fsf_-_@gmail.com
Hi,

I pushed this to master, fixing the graft at the same time (it was not
applied to 'samba').

I'll look for core-updates later.

--
Thanks,
Maxim
K
K
Kaelyn wrote on 19 Apr 2023 18:14
(name . 62894@debbugs.gnu.org)(address . 62894@debbugs.gnu.org)
Q03K2BMYyoM5LSV8t2o9jTcKGDnUScI9XaQ2FwKXHTPKvsLWHpbn7Uv6GjVbZ38v9IQf2KHJGzPDr2ODJlv6U5YH7X_5oZR2ktNbAadPtfc=@protonmail.com
Hi,

I've applied the two patches locally to my core-updates worktree and can confirm the patches allow me to once again build wine64 (post staging merge).

Cheers,
Kaelyn
J
J
John Kehayias wrote on 12 May 2023 22:09
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 62894-done@debbugs.gnu.org)
87h6shcnw9.fsf@protonmail.com
On Tue, Apr 18, 2023 at 12:35 PM, Maxim Cournoyer wrote:

Toggle quote (7 lines)
> Hi,
>
> I pushed this to master, fixing the graft at the same time (it was not
> applied to 'samba').
>
> I'll look for core-updates later.

Thanks. Since applied/merged so we're all set.

John
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62894@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62894
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch