[PATCH] gnu: Add python-extract-dtb.

  • Open
  • quality assurance status badge
Details
One participant
  • ??
Owner
unassigned
Submitted by
??
Severity
normal
?
(name . guix-patches)(address . guix-patches@gnu.org)
CAGNyvehDHniuu2w-63r6WhKFpohxs+-834o7BNKC7vHiN-UZsA@mail.gmail.com
From d75988c92da663715069fb660afb70333349551e Mon Sep 17 00:00:00 2001
From: LuHui <luhux76@gmail.com>
Date: Sun, 16 Apr 2023 21:43:44 +0800
Subject: [PATCH] gnu: Add python-extract-dtb.

* gnu/packages/python-xyz.scm (python-extract-dtb): New variable.
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0147870b06..887646e04f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -135,6 +135,7 @@
;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
;;; Copyright © 2023 Amade Nemes <nemesamade@gmail.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2023 Lu Hui <luhux76@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3624,6 +3625,23 @@ (define-public python-extras
"Extras is a set of extensions to the Python standard library.")
(license license:expat)))

+(define-public python-extract-dtb
+ (package
+ (name "python-extract-dtb")
+ (version "1.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "extract-dtb" version))
+ (sha256
+ (base32
+ "1a7rfvwisgri8b00pch6d9pfrl8s93w8g09yzxf4xh0qvmsxmh43"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/PabloCastellano/extract-dtb/")
+ (synopsis "Extract device tree blobs (dtb) from kernel images")
+ (description "Tool to split a kernel image with appended dtbs into
+separated kernel and dtb files.")
+ (license license:gpl3+)))
+
(define-public python-mimeparse
(package
(name "python-mimeparse")
--
2.35.7
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 62884@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62884
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch