[PATCH] gnu: wfview: Update to 1.62.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230416113445.19615-1-sharlatanus@gmail.com
* gnu/packages/radio.scm (wfview): Update to 1.62.
Use Gexp, shift order of components.
[inputs]: Add hidapi, qtgamepad.
---
gnu/packages/radio.scm | 51 +++++++++++++++++++++++++-----------------
1 file changed, 30 insertions(+), 21 deletions(-)

Toggle diff (82 lines)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 8192aefb0f..02509ea146 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -2591,7 +2591,7 @@ (define-public inspectrum
(define-public wfview
(package
(name "wfview")
- (version "1.50")
+ (version "1.62")
(source
(origin
(method git-fetch)
@@ -2600,37 +2600,46 @@ (define-public wfview
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1djgn1z4hibzci53mrvskz47jfq6hk8lhhqckpa93pvsi9kadl4k"))))
+ (base32 "0rrj6h5k8plq4m6fd2yxargfhqcwkxv6bdp4rmgh6bs4prl4wvwd"))))
(build-system qt-build-system)
+ (arguments
+ (list
+ #:tests? #f ; No test suite.
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda _
+ (substitute* "wfview.pro"
+ (("\\.\\./wfview/")
+ "../"))
+ (substitute* '("wfmain.cpp")
+ (("/usr/share")
+ (string-append #$output "/share")))))
+ (replace 'configure
+ (lambda _
+ (mkdir-p "build")
+ (chdir "build")
+ (invoke "qmake"
+ (string-append "PREFIX=" #$output)
+ "../wfview.pro"))))))
+ ;; XXX: During the build it complains on missing git and hostname commands
+ ;; but it successfully finishes the build.
(inputs
(list eigen
+ hidapi
opus
portaudio
pulseaudio
qcustomplot
+ ;; TODO: Needs to be renamed to qtgamepad-5 when version 6 is
+ ;; packed.
+ qtgamepad
qtbase-5
qtmultimedia-5
+ ;; TODO: Needs to be renamed to qtserialport-5. when version 6 is
+ ;; packed.
qtserialport
rtaudio))
- (arguments
- `(#:tests? #f ; No test suite.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "wfview.pro"
- (("\\.\\./wfview/")
- "../"))
- (substitute* '("wfmain.cpp")
- (("/usr/share")
- (string-append (assoc-ref outputs "out") "/share")))))
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (mkdir-p "build")
- (chdir "build")
- (invoke "qmake"
- (string-append "PREFIX=" (assoc-ref outputs "out"))
- "../wfview.pro"))))))
(home-page "https://wfview.org/")
(synopsis "Software to control Icom radios")
(description
--
2.39.2
Guillaume Le Vaillant wrote 2 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 62883-done@debbugs.gnu.org)
87zg76y0ww.fsf@kitej
Patch pushed as d3ce8833043073e69f94352ceec3ed3466f1b0fe.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZD1n3w8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/JFQD/QEdMmtGQvA22ic0dZUfsftcohiKZhtUEK7Qx
bzpYWmwA/2l4chY7rTQ8a1OSqMDJn1yO7OncdH3rSWHTHKkXb+F7
=0FDZ
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62883@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62883
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help