[PATCH] gnu: Add r-demultiplex2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
20230416102812.60375-1-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-demultiplex2): New variable.
---
gnu/packages/bioinformatics.scm | 41 +++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b5442dd0ad..1919866731 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9662,6 +9662,47 @@ (define-public r-demuxmix
rates can be estimated, and methods for quality control are provided.")
(license license:artistic2.0))))
+(define-public r-demultiplex2
+ (let ((commit "e42bc8310c0ea035af100e6ccea59b46ad6385f5")
+ (revision "1"))
+ (package
+ (name "r-demultiplex2")
+ (version (git-version "1.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Gartner-Lab/deMULTIplex2")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15f3kshsdvm97w24ql9b1wjlfbabimdsam0482hg7jivlvpl8j9w"))))
+ (properties `((upstream-name . "deMULTIplex2")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-data-table
+ r-devtools
+ r-dplyr
+ r-ggextra
+ r-ggplot2
+ r-gridextra
+ r-magrittr
+ r-mass
+ r-matrix
+ r-rcolorbrewer
+ r-shortread
+ r-stringdist
+ r-tidyr
+ r-uwot
+ r-viridis
+ r-xvector))
+ (home-page "https://github.com/Gartner-Lab/deMULTIplex2")
+ (synopsis "Robust sample demultiplexing for scRNA-seq")
+ (description
+ "Bioinformatics algorithm for demultiplexing multiplexed single cell datasets.
+It is built on a statistical model of tag read counts derived from
+the physical mechanism of tag cross-contamination.")
+ (license license:cc0))))
+
(define-public r-demultiplex
(let ((commit "6e2a1422c8e6f418cfb271997eebc91f9195f299")
(revision "1"))
--
2.34.1
Ricardo Wurmus wrote 2 years ago
gnu: Add r-demultiplex2.
(address . 62882-done@debbugs.gnu.org)
87a5z6sw4h.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62882@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62882
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help