[PATCH] gnu: Add r-demuxmix.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
20230416100948.59730-1-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-demuxmix): New variable.
---
gnu/packages/bioinformatics.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 99cc056f9f..b5442dd0ad 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9632,6 +9632,36 @@ (define-public r-centipede
information as possible.")
(license (list license:gpl2+ license:gpl3+))))
+(define-public r-demuxmix
+ (let ((commit "09a7918ca6e0cd23e6bbaed2b97388bc499e248e")
+ (revision "1"))
+ (package
+ (name "r-demuxmix")
+ (version (git-version "1.1.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/huklein/demuxmix")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03kfnns7m2447jsc3xplyv9qx8hvvdjmii7j837g3bb6smyxss96"))))
+ (properties `((upstream-name . "demuxmix")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ggplot2 r-gridextra r-mass r-matrix))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/huklein/demuxmix")
+ (synopsis
+ "Demultiplexing oligo-barcoded scRNA-seq data using regression mixture models")
+ (description
+ "This package is used for demultiplexing single-cell sequencing experiments of pooled cells.
+These cells are labeled with barcode oligonucleotides. The package
+implements methods to fit regression mixture models for a probabilistic
+classification of cells, including multiplet detection. Demultiplexing error
+rates can be estimated, and methods for quality control are provided.")
+ (license license:artistic2.0))))
+
(define-public r-demultiplex
(let ((commit "6e2a1422c8e6f418cfb271997eebc91f9195f299")
(revision "1"))
--
2.34.1
Ricardo Wurmus wrote 2 years ago
gnu: Add r-demuxmix.
(address . 62881-done@debbugs.gnu.org)
87edoisw5d.fsf@elephly.net
Applied, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62881@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62881
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help