[PATCH] gnu: Add mouseloupe.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ivan Gankevich
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ivan Gankevich
Severity
normal

Debbugs page

Ivan Gankevich wrote 2 years ago
(address . guix-patches@gnu.org)(name . Ivan Gankevich)(address . igankevich@capybaramail.xyz)
20230415190107.31539-1-igankevich@capybaramail.xyz
* gnu/packages/accessibility.scm (mouseloupe): New variable.
---
Hello.

I've added a magnifying tool for X11. This is an old package but still works.

Best regards,
Ivan

gnu/packages/accessibility.scm | 36 ++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/accessibility.scm b/gnu/packages/accessibility.scm
index 3613bd8c45..0b06a189ea 100644
--- a/gnu/packages/accessibility.scm
+++ b/gnu/packages/accessibility.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2019 Andrew Miloradovsky <andrew@interpretmath.pw>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Hunter Jozwiak <hunter.t.joz@gmail.com>
+;;; Copyright © 2023 Ivan Gankevich <igankevich@capybaramail.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -350,3 +351,38 @@ (define-public espeakup
CONFIG_SPEAKUP_SOFT=m
@end itemize")
(home-page "https://github.com/linux-speakup/espeakup")))
+
+(define-public mouseloupe
+ (package
+ (name "mouseloupe")
+ (version "0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/" name "/" name "/v" version
+ "/" name "-v" version ".tar.gz"))
+ (sha256 (base32 "0cvdkfakw7cix07j0c4iy10fkbqn6n8l1gr5dd3iy4f2d9bkza43"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; there are no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'strtof
+ (lambda _
+ (substitute* "mouseloupe.c"
+ (("\\bstrtof\\b") "mouseloupe_strtof"))))
+ (replace 'install
+ (lambda _
+ (define out (assoc-ref %outputs "out"))
+ (install-file "mouseloupe" (string-append out "/bin"))
+ (install-file "mouseloupe.1.gz" (string-append out "/share/man/man1")))))))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list libx11 libxext libxcomposite libxdamage libxrender))
+ (synopsis "Screen magnifier tool for people with low vision")
+ (description "MouseLoupe is a kind of magnifying glass combined with the mouse pointer
+which allows an easy and pleasant web navigation.")
+ (home-page "https://sourceforge.net/projects/mouseloupe/")
+ (license license:gpl2+)))
--
2.38.0
Ludovic Courtès wrote 2 years ago
(name . Ivan Gankevich)(address . igankevich@capybaramail.xyz)(address . 62874-done@debbugs.gnu.org)
874jo0fzv2.fsf@gnu.org
Hi,

Ivan Gankevich <igankevich@capybaramail.xyz> skribis:

Toggle quote (6 lines)
> * gnu/packages/accessibility.scm (mouseloupe): New variable.
> ---
> Hello.
>
> I've added a magnifying tool for X11. This is an old package but still works.

Indeed. :-) Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62874@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62874
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help