[PATCH gnome-team 0/5] Merge master into gnome-team

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 15 Apr 2023 23:39
(address . guix-patches@gnu.org)
e2c5a57969bb335e861866c69d372b2ffac040a5.camel@gmail.com
Hi Guix,

please apologize the murder commit that is the merge itself :(
With this out of the way, we should have GStreamer 1.22 building, though
I am not yet sure about the plugins. In any case, it should get us
closer to having a solid base for the actual GNOME 44 work.

Cheers

Liliana Marie Prikler (2):
gnu: meson: Update to 1.1.
gnu: gtk+-3: Fix build.
Merge branch 'master' into gnome-team.

Maxim Cournoyer (2):
build: meson: Explicitly invoke "meson setup" instead of just "meson".
build: meson: Honor bindir, libdir and includedir.
--
2.39.2
L
L
Liliana Marie Prikler wrote on 27 Mar 2023 20:27
[PATCH gnome-team 1/4] gnu: meson: Update to 1.1.
(address . 62873@debbugs.gnu.org)
fbe1ee22bdc800dab87112dc64af4f40387adb1c.camel@gmail.com
* gnu/packages/build-tools.scm (meson-1.1): New variable.
(meson-0.63): Inherit from meson-1.1.

sq meson 1.1

f meson 1.1
---
gnu/packages/build-tools.scm | 20 +++++++++++++++++---
1 file changed, 17 insertions(+), 3 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 2bbf7ce4c9..c53d4dd6db 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -283,10 +283,10 @@ (define-public gn
;; X11 license.
(license (list license:bsd-3 license:x11)))))
-(define-public meson-0.63
+(define-public meson-1.1
(package
(name "meson")
- (version "0.63.2")
+ (version "1.1.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mesonbuild/meson/"
@@ -294,7 +294,7 @@ (define-public meson-0.63
version ".tar.gz"))
(sha256
(base32
- "1gwba75z47m2hv3w08gw8sgqgbknjr7rj1qwr510bgknxwbjy8hn"))))
+ "17w2zymmvrffhfpqsaj7qcbjwgv9iaawcpzhz2gnhlvcrm26qqfr"))))
(build-system python-build-system)
(arguments
`(;; FIXME: Tests require many additional inputs and patching many
@@ -327,6 +327,20 @@ (define-public meson-0.63
resembles Python.")
(license license:asl2.0)))
+(define-public meson-0.63
+ (package
+ (inherit meson-1.1)
+ (name "meson")
+ (version "0.63.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mesonbuild/meson/"
+ "releases/download/" version "/meson-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1gwba75z47m2hv3w08gw8sgqgbknjr7rj1qwr510bgknxwbjy8hn"))))))
+
(define-public meson-0.60
(package
(inherit meson-0.63)
--
2.39.2
M
M
Maxim Cournoyer wrote on 8 Apr 2023 17:22
[PATCH gnome-team 2/4] build: meson: Explicitly invoke "meson setup" instead of just "meson".
(address . 62873@debbugs.gnu.org)
93093b0b40301a4c88f8842dded8d63b3c63bce2.camel@gmail.com
* guix/build/meson-build-system.scm (configure): Invoke the setup command to
avoid a deprecation warning.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
---
guix/build/meson-build-system.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/guix/build/meson-build-system.scm b/guix/build/meson-build-system.scm
index 61ce45367d..3d1a27cba7 100644
--- a/guix/build/meson-build-system.scm
+++ b/guix/build/meson-build-system.scm
@@ -55,7 +55,7 @@ (define* (configure #:key outputs configure-flags build-type
(mkdir build-dir)
(chdir build-dir)
- (apply invoke "meson" args)))
+ (apply invoke "meson" "setup" args)))
(define* (build #:key parallel-build?
#:allow-other-keys)
--
2.39.2
M
M
Maxim Cournoyer wrote on 8 Apr 2023 16:04
[PATCH gnome-team 3/4] build: meson: Honor bindir, libdir and includedir.
(address . 62873@debbugs.gnu.org)
43971973ac0be90c50f67b35a59734b8cea1c4c8.camel@gmail.com
This brings our meson-build-system closer to our gnu-build-system in terms of
using different installation prefixes based on the presence of outputs such as
"bin", "lib" or "include".

* guix/build/meson-build-system.scm (configure): Add --bindir, --libdir and
--includedir according to the presence of the "bin", "lib" and "include"
outputs, as done in gnu-build-system.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
---
guix/build/meson-build-system.scm | 20 +++++++++++++++++++-
1 file changed, 19 insertions(+), 1 deletion(-)

Toggle diff (44 lines)
diff --git a/guix/build/meson-build-system.scm b/guix/build/meson-build-system.scm
index 3d1a27cba7..d11a5d8e18 100644
--- a/guix/build/meson-build-system.scm
+++ b/guix/build/meson-build-system.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,10 +41,28 @@ (define* (configure #:key outputs configure-flags build-type
#:allow-other-keys)
"Configure the given package."
(let* ((out (assoc-ref outputs "out"))
+ (bindir (assoc-ref outputs "bin"))
+ (libdir (assoc-ref outputs "lib"))
+ (includedir (assoc-ref outputs "include"))
(source-dir (getcwd))
(build-dir "../build")
(prefix (assoc-ref outputs "out"))
(args `(,(string-append "--prefix=" prefix)
+ ,@(if bindir
+ (list (string-append "--bindir=" bindir "/bin"))
+ '())
+ ,@(if libdir
+ (cons (string-append "--libdir=" libdir "/lib")
+ (if includedir
+ '()
+ (list
+ (string-append "--includedir="
+ libdir "/include"))))
+ '())
+ ,@(if includedir
+ (list (string-append "--includedir="
+ includedir "/include"))
+ '())
,(string-append "--buildtype=" build-type)
,(string-append "-Dc_link_args=-Wl,-rpath="
(assoc-ref outputs "out") "/lib")
--
2.39.2
L
L
Liliana Marie Prikler wrote on 13 Apr 2023 15:33
[PATCH gnome-team 4/4] gnu: gtk+-3: Fix build.
(address . 62873@debbugs.gnu.org)
01feb5d46e7959b7818737ef348717bf56cd626a.camel@gmail.com
meson-build-system now sets bindir, so we don't need to move the files.

* gnu/packages/gtk.scm (gtk+-3)[arguments]: Do not attempt to move /bin.
---
gnu/packages/gtk.scm | 2 --
1 file changed, 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index e49115ad0e..64058fbf66 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1208,7 +1208,6 @@ (define-values (out bin doc)
(assoc-ref outputs "doc")))
(for-each mkdir-p
(list
- (string-append bin "/bin")
(string-append bin "/share/applications")
(string-append bin "/share/icons")
(string-append bin "/share/man")
@@ -1220,7 +1219,6 @@ (define-values (out bin doc)
(string-append out dir)
(string-append bin dir)))
(list
- "/bin"
"/share/applications"
"/share/icons"
"/share/man"))
--
2.39.2
L
L
Liliana Marie Prikler wrote on 15 Apr 2023 23:30
[PATCH] Merge branch 'master' into gnome-team.
(address . 62873@debbugs.gnu.org)
dd062cdbf3a2dc9b716524846590d0827f378081.camel@gmail.com
---
Note: master is at 7c7853d269fe53271dd35d5bd941d18a2cb55120 in this commit.

NEWS | 3 +++
doc/guix.texi | 38 +++++++++++++++++++-------------------
gnu/local.mk | 9 +++++----
gnu/packages/admin.scm | 56 +++++++++++++++++++++++++++++++++++++-------------------
gnu/packages/audio.scm | 63 ++++-----------------------------------------------------------
gnu/packages/benchmark.scm | 41 ++++++++++++++++++++++++++++-------------
gnu/packages/build-tools.scm | 2 +-
gnu/packages/c.scm | 79 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++---------------
gnu/packages/calendar.scm | 4 ++--
gnu/packages/cdrom.scm | 1 +
gnu/packages/certs.scm | 4 ++--
gnu/packages/check.scm | 12 ++++++------
gnu/packages/crates-graphics.scm | 7 +++++--
gnu/packages/crates-io.scm | 2489 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
gnu/packages/databases.scm | 112 ++++++++++++++++++++++++++++++++--------------------------------------------------------------------------------
gnu/packages/electronics.scm | 22 +++++++++-------------
gnu/packages/emulators.scm | 5 +++--
gnu/packages/fonts.scm | 60 ++++++++++++++++++++++++++++++++----------------------------
gnu/packages/fontutils.scm | 77 +++++++++++++++++++++++++++++++----------------------------------------------
gnu/packages/freedesktop.scm | 340 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
gnu/packages/games.scm | 8 ++++----
gnu/packages/gl.scm | 23 +++++++++++++----------
gnu/packages/gnome.scm | 20 +++++++++++---------
gnu/packages/gnunet.scm | 151 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++---------------------------------------------------------------------
gnu/packages/gnuzilla.scm | 183 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++-----
gnu/packages/golang.scm | 6 +++---
gnu/packages/graphics.scm | 163 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++------------------------------------------------------------------------------------
gnu/packages/gstreamer.scm | 91 ++++++++++++++++++++++++++++++++++++++++++++++++-------------------------------------------
gnu/packages/ibus.scm | 32 ++++++++++++++++++++------------
gnu/packages/image.scm | 4 ++--
gnu/packages/jami.scm | 70 +++++++++++++++++++---------------------------------------------------
gnu/packages/kde-frameworks.scm | 14 ++++++--------
gnu/packages/less.scm | 5 +++--
gnu/packages/libcanberra.scm | 6 ------
gnu/packages/linux.scm | 20 ++++++++++----------
gnu/packages/lisp-xyz.scm | 8 ++++----
gnu/packages/lisp.scm | 15 +++++++--------
gnu/packages/man.scm | 4 ++--
gnu/packages/maths.scm | 44 ++++++++++++++++++++++++++++++--------------
gnu/packages/minetest.scm | 9 +++++----
gnu/packages/music.scm | 97 +++++++++++++++++++++++++++++++++++++++++++++++++------------------------------------------------
gnu/packages/nss.scm | 10 +++++-----
gnu/packages/package-management.scm | 6 +++---
gnu/packages/patches/glslang-install-static-libs.patch | 61 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
gnu/packages/patches/jami-libjami-headers-search.patch | 45 ++++++++++++---------------------------------
gnu/packages/patches/libcdio-glibc-compat.patch | 43 +++++++++++++++++++++++++++++++++++++++++++
gnu/packages/patches/mariadb-link-libatomic.patch | 83 -----------------------------------------------------------------------------------
gnu/packages/patches/openboardview-use-system-mpc.patch | 42 ++++++++++++++++++++++++++++++++++++++++++
gnu/packages/patches/openboardview-use-system-utf8.patch | 48 ------------------------------------------------
gnu/packages/patches/orangeduck-mpc-fix-pkg-config.patch | 25 +++++++++++++++++++++++++
gnu/packages/patches/python-afdko-suppress-copyright-test.patch | 20 --------------------
gnu/packages/patches/python2-pyopenssl-openssl-compat.patch | 51 ---------------------------------------------------
gnu/packages/patches/rust-openssl-sys-no-vendor.patch | 30 ++++++++++++++++++------------
gnu/packages/patches/webkitgtk-libelogind.patch | 38 ++++++++++++++++++++++++++++++++++++++
gnu/packages/perl-check.scm | 4 ++--
gnu/packages/perl.scm | 4 ++--
gnu/packages/photo.scm | 6 ++----
gnu/packages/python-check.scm | 9 ++++-----
gnu/packages/python-compression.scm | 16 +++++++---------
gnu/packages/python-crypto.scm | 278 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++-----------------------------------------------------------------------------------------------------------------------------------------------------------------------
gnu/packages/python-web.scm | 17 ++++++++---------
gnu/packages/python-xyz.scm | 106 +++++++++++++++++++++++++++++++++++++++++++---------------------------------------------------------------
gnu/packages/qt.scm | 1193 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
gnu/packages/radio.scm | 84 +++++++++++++++++++++++++++++++++++++++++++++++++-----------------------------------
gnu/packages/rails.scm | 6 ++++++
gnu/packages/ruby.scm | 22 ++++++++++++++--------
gnu/packages/rust-apps.scm | 24 +++++++++++++++++++-----
gnu/packages/sdl.scm | 82 +++++++++++++++++++++++++++++++++++++++++++++++-----------------------------------
gnu/packages/sphinx.scm | 31 ++++++++++++++++++++-----------
gnu/packages/syndication.scm | 6 +++---
gnu/packages/telephony.scm | 11 +++++++----
gnu/packages/toolkits.scm | 58 +++++++++++++++++++++++++++++++++++++++++-----------------
gnu/packages/unicode.scm | 18 ++----------------
gnu/packages/version-control.scm | 4 ++++
gnu/packages/video.scm | 102 +++++++++++++++++++++++++++++++++---------------------------------------------------------------------
gnu/packages/vulkan.scm | 258 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++-------------------------------------------------------
gnu/packages/web.scm | 18 ++++++++++--------
gnu/packages/webkit.scm | 60 +++++++++++++++++++++++++++++++-----------------------------
gnu/packages/xdisorg.scm | 63 +++++++++++++++------------------------------------------------
gnu/packages/xiph.scm | 8 ++++----
gnu/packages/xorg.scm | 212 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++----------------------------------------------------------------------------------------------------------
gnu/tests/databases.scm | 6 +++++-
guix/build/qt-utils.scm | 5 ++---
83 files changed, 4422 insertions(+), 3188 deletions(-)
create mode 100644 gnu/packages/patches/glslang-install-static-libs.patch
create mode 100644 gnu/packages/patches/libcdio-glibc-compat.patch
delete mode 100644 gnu/packages/patches/mariadb-link-libatomic.patch
create mode 100644 gnu/packages/patches/openboardview-use-system-mpc.patch
delete mode 100644 gnu/packages/patches/openboardview-use-system-utf8.patch
create mode 100644 gnu/packages/patches/orangeduck-mpc-fix-pkg-config.patch
delete mode 100644 gnu/packages/patches/python-afdko-suppress-copyright-test.patch
delete mode 100644 gnu/packages/patches/python2-pyopenssl-openssl-compat.patch
create mode 100644 gnu/packages/patches/webkitgtk-libelogind.patch

Toggle diff (147 lines)
diff --git a/NEWS b/NEWS
index 47545f6..79c80cf 100644
--- a/NEWS
+++ b/NEWS
@@ -13,6 +13,9 @@ Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
Please send Guix bug reports to bug-guix@gnu.org.
+* Changes in 1.5.0 (since 1.4.0)
+** Package management
+*** New ‘rpm’ format for the ‘guix pack’ command
* Changes in 1.4.0 (since 1.3.0)
** Package management
*** New ‘guix home’ command, for home environment management
diff --git a/doc/guix.texi b/doc/guix.texi
index acb6f0c..adb1975 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -14398,7 +14398,7 @@ for compatibility with an upgraded @code{flex} package.
@table @code
@item --list-transitive
-@itemx --T
+@itemx -T
List all the packages which one or more packages depend upon.
@example
@@ -18464,7 +18464,7 @@ The Kmscon package to use.
@cindex @abbr{nscd, name service cache daemon}
@defvar nscd-service-type
Type of the service that runs the libc @abbr{nscd, name service cache
-daemon}, whose value is a @code{<nscd-configuration>} object.
+daemon}, whose value is an @code{<nscd-configuration>} object.
For convenience, the Shepherd service for nscd provides the following actions:
@@ -18992,7 +18992,7 @@ seconds for the negative lookups. @xref{Invoking guix publish,
@end deftp
@defvar rngd-service-type
-Type of the service that runs rng-tools rngd, whose value is a
+Type of the service that runs rng-tools rngd, whose value is an
@code{<rngd-configuration>} object.
@end defvar
@@ -26315,7 +26315,7 @@ variables.
@defvar getmail-service-type
This is the type of the @uref{http://pyropus.ca/software/getmail/, Getmail}
-mail retriever, whose value should be an @code{getmail-configuration}.
+mail retriever, whose value should be a @code{getmail-configuration}.
@end defvar
Available @code{getmail-configuration} fields are:
@@ -31520,7 +31520,7 @@ The list of knot-zone-configuration used by this configuration.
@defvar knot-resolver-service-type
This is the type of the knot resolver service, whose value should be
-an @code{knot-resolver-configuration} object as in this example:
+a @code{knot-resolver-configuration} object as in this example:
@lisp
(service knot-resolver-service-type
@@ -31557,7 +31557,7 @@ Number of milliseconds for @code{kres-cache-gc} to periodically trim the cache.
@subsubheading Dnsmasq Service
@defvar dnsmasq-service-type
-This is the type of the dnsmasq service, whose value should be an
+This is the type of the dnsmasq service, whose value should be a
@code{dnsmasq-configuration} object as in this example:
@lisp
@@ -37570,7 +37570,7 @@ on whatever else might be trying to use the disk at the time.
@defvar fstrim-service-type
Type for a service that periodically runs @command{fstrim}, whose value must
-be a @code{<fstrim-configuration>} object. The service can be instantiated
+be an @code{<fstrim-configuration>} object. The service can be instantiated
in its default configuration with:
@lisp
@@ -42313,7 +42313,7 @@ for home services is that they have to be declared in a
record.
@defvar home-mcron-service-type
-This is the type of the @code{mcron} home service, whose value is an
+This is the type of the @code{mcron} home service, whose value is a
@code{home-mcron-configuration} object. It allows to manage scheduled
tasks.
@@ -42661,16 +42661,16 @@ to the @code{services} field of your @code{home-environment}:
@end lisp
@defvar home-ssh-agent-service-type
-This is the type of the @code{git daemon} home service, whose value is an
+This is the type of the @code{ssh-agent} home service, whose value is a
@code{home-ssh-agent-configuration} object.
@end defvar
@deftp {Data Type} home-ssh-agent-configuration
Available @code{home-ssh-agent-configuration} fields are:
@table @asis
-@item @code{git} (default: @code{git}) (type: file-like)
-The git package to use.
+@item @code{openssh} (default: @code{openssh}) (type: file-like)
+The OpenSSH package to use.
@item @code{socket-directory} (default: @code{@env{XDG_RUNTIME_DIR}/ssh-agent"}) (type: gexp)
The directory to write the ssh-agent's @file{socket} file.
@@ -43100,16 +43100,16 @@ to the @code{services} field of your @code{home-environment}:
@end lisp
@defvar home-znc-service-type
-This is the type of the @code{git daemon} home service, whose value is an
+This is the type of the ZNC home service, whose value is a
@code{home-znc-configuration} object.
@end defvar
@deftp {Data Type} home-znc-configuration
Available @code{home-znc-configuration} fields are:
@table @asis
-@item @code{git} (default: @code{git}) (type: file-like)
-The git package to use.
+@item @code{znc} (default: @code{znc}) (type: file-like)
+The ZNC package to use.
@item @code{extra-options} (default: @code{'()})
Extra options will be passed to @command{znc}, please run @command{man
@@ -43122,9 +43122,9 @@ znc} for more information.
@subsection Media Home Services
@cindex kodi
-The @uref{https://kodi.tv, KODI media center} can be run as a daemon on
+The @uref{https://kodi.tv, Kodi media center} can be run as a daemon on
a media server. With the @code{(gnu home services kodi)} service, you
-can configure KODI to run upon login.
+can configure Kodi to run upon login.
Here is an example of a service and its configuration that you could add
to the @code{services} field of your @code{home-environment}:
@@ -43136,16 +43136,16 @@ to the @code{services} field of your @code{home-environment}:
@end lisp
@defvar home-kodi-service-type
-This is
This message was truncated. Download the full message here.
L
L
Liliana Marie Prikler wrote on 16 Apr 2023 07:47
[PATCH gnome-team 6/6] gnu: gst-plugins-base: Fix build.
(address . 62873@debbugs.gnu.org)
43da6ec9e3cd102cdd1403d144009ba15b2d6769.camel@gmail.com
* gnu/packages/patches/gst-plugins-base-fix-broken-test.patch: New file.
* gnu/packages/gstreamer.scm (gst-plugins-base)[patches]: Use it here.
* gnu/local.mk (dist_patch_DATA): Register it here.
---
As a follow-up to the master merge, the good, bad, and ugly plugins
as well as gst-editing-services build with this simple trick.

gnu/local.mk | 1 +
gnu/packages/gstreamer.scm | 3 ++-
.../gst-plugins-base-fix-broken-test.patch | 22 +++++++++++++++++++
3 files changed, 25 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/gst-plugins-base-fix-broken-test.patch

Toggle diff (56 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 72b73761d8..1d7c5696f5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1303,6 +1303,7 @@ dist_patch_DATA = \
%D%/packages/patches/guile-present-coding.patch \
%D%/packages/patches/guile-rsvg-pkgconfig.patch \
%D%/packages/patches/guile-emacs-fix-configure.patch \
+ %D%/packages/patches/gst-plugins-base-fix-broken-test.patch \
%D%/packages/patches/gtk2-fix-builder-test.patch \
%D%/packages/patches/gtk2-harden-list-store.patch \
%D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch \
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 0d051438e3..486ebe6dcd 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -554,7 +554,8 @@ (define-public gst-plugins-base
name "-" version ".tar.xz"))
(sha256
(base32
- "0jcxcx4mgfjvfb3ixibwhx8j330mq3ap469w7hapm6z79q614rgb"))))
+ "0jcxcx4mgfjvfb3ixibwhx8j330mq3ap469w7hapm6z79q614rgb"))
+ (patches (search-patches "gst-plugins-base-fix-broken-test.patch"))))
(build-system meson-build-system)
(propagated-inputs
(list glib ;required by gstreamer-sdp-1.0.pc
diff --git a/gnu/packages/patches/gst-plugins-base-fix-broken-test.patch b/gnu/packages/patches/gst-plugins-base-fix-broken-test.patch
new file mode 100644
index 0000000000..2785983d8d
--- /dev/null
+++ b/gnu/packages/patches/gst-plugins-base-fix-broken-test.patch
@@ -0,0 +1,22 @@
+Index: gst-plugins-base-1.22.1/tests/check/libs/allocators.c
+===================================================================
+--- gst-plugins-base-1.22.1.orig/tests/check/libs/allocators.c
++++ gst-plugins-base-1.22.1/tests/check/libs/allocators.c
+@@ -80,7 +80,7 @@ GST_START_TEST (test_fdmem)
+
+ alloc = gst_fd_allocator_new ();
+ fail_unless (alloc);
+- mem = gst_fd_allocator_alloc (alloc, fd, 10, GST_FD_MEMORY_FLAG_KEEP_MAPPED);
++ mem = gst_fd_allocator_alloc (alloc, fd, 10, GST_FD_MEMORY_FLAG_KEEP_MAPPED | GST_FD_MEMORY_FLAG_DONT_CLOSE);
+
+ fail_unless (gst_memory_map (mem, &info, GST_MAP_READ));
+ fail_unless (info.data[5] == '5');
+@@ -95,7 +95,7 @@ GST_START_TEST (test_fdmem)
+ gst_memory_unmap (mem, &info);
+
+ gst_memory_unref (mem);
+- fail_unless (g_close (fd, NULL) == 0);
++ fail_unless (g_close (fd, NULL));
+ gst_object_unref (alloc);
+ }
+
--
2.39.2
M
M
Maxim Cournoyer wrote on 18 Apr 2023 18:42
Re: bug#62873: [PATCH gnome-team 0/5] Merge master into gnome-team
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87ttxd2lc7.fsf_-_@gmail.com
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (26 lines)
> * gnu/packages/patches/gst-plugins-base-fix-broken-test.patch: New file.
> * gnu/packages/gstreamer.scm (gst-plugins-base)[patches]: Use it here.
> * gnu/local.mk (dist_patch_DATA): Register it here.
> ---
> As a follow-up to the master merge, the good, bad, and ugly plugins
> as well as gst-editing-services build with this simple trick.
>
> gnu/local.mk | 1 +
> gnu/packages/gstreamer.scm | 3 ++-
> .../gst-plugins-base-fix-broken-test.patch | 22 +++++++++++++++++++
> 3 files changed, 25 insertions(+), 1 deletion(-)
> create mode 100644 gnu/packages/patches/gst-plugins-base-fix-broken-test.patch
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 72b73761d8..1d7c5696f5 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -1303,6 +1303,7 @@ dist_patch_DATA = \
> %D%/packages/patches/guile-present-coding.patch \
> %D%/packages/patches/guile-rsvg-pkgconfig.patch \
> %D%/packages/patches/guile-emacs-fix-configure.patch \
> + %D%/packages/patches/gst-plugins-base-fix-broken-test.patch \
> %D%/packages/patches/gtk2-fix-builder-test.patch \
> %D%/packages/patches/gtk2-harden-list-store.patch \
> %D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch \

I'm surprised this is needed, I hadn't encountered the failure. Perhaps
it's a non-deterministic test?

Anyway, thank you! The series LGTM.

--
Thanks,
Maxim
L
L
Liliana Marie Prikler wrote on 18 Apr 2023 20:30
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
5696239db2a54329c3131f8042d493e95853812a.camel@gmail.com
Am Dienstag, dem 18.04.2023 um 12:42 -0400 schrieb Maxim Cournoyer:
Toggle quote (38 lines)
> Hi Liliana,
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> > * gnu/packages/patches/gst-plugins-base-fix-broken-test.patch: New
> > file.
> > * gnu/packages/gstreamer.scm (gst-plugins-base)[patches]: Use it
> > here.
> > * gnu/local.mk (dist_patch_DATA): Register it here.
> > ---
> > As a follow-up to the master merge, the good, bad, and ugly plugins
> > as well as gst-editing-services build with this simple trick.
> >
> >  gnu/local.mk                                  |  1 +
> >  gnu/packages/gstreamer.scm                    |  3 ++-
> >  .../gst-plugins-base-fix-broken-test.patch    | 22
> > +++++++++++++++++++
> >  3 files changed, 25 insertions(+), 1 deletion(-)
> >  create mode 100644 gnu/packages/patches/gst-plugins-base-fix-
> > broken-test.patch
> >
> > diff --git a/gnu/local.mk b/gnu/local.mk
> > index 72b73761d8..1d7c5696f5 100644
> > --- a/gnu/local.mk
> > +++ b/gnu/local.mk
> > @@ -1303,6 +1303,7 @@ dist_patch_DATA
> > =                                         \
> >    %D%/packages/patches/guile-present-coding.patch              \
> >    %D%/packages/patches/guile-rsvg-pkgconfig.patch              \
> >    %D%/packages/patches/guile-emacs-fix-configure.patch         \
> > +  %D%/packages/patches/gst-plugins-base-fix-broken-
> > test.patch          \
> >    %D%/packages/patches/gtk2-fix-builder-test.patch             \
> >    %D%/packages/patches/gtk2-harden-list-store.patch            \
> >    %D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch       \
>
> I'm surprised this is needed, I hadn't encountered the failure. 
> Perhaps it's a non-deterministic test?
It is a deterministic failure as far as I see. Did you test with glib
2.73 (current master) or 2.76 (gnome-team)?

Cheers
M
M
Maxim Cournoyer wrote on 20 Apr 2023 03:41
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87sfcv1g9k.fsf@gmail.com
Hi Liliana,
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
Toggle quote (41 lines)
> Am Dienstag, dem 18.04.2023 um 12:42 -0400 schrieb Maxim Cournoyer:
>> Hi Liliana,
>>
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>>
>> > * gnu/packages/patches/gst-plugins-base-fix-broken-test.patch: New
>> > file.
>> > * gnu/packages/gstreamer.scm (gst-plugins-base)[patches]: Use it
>> > here.
>> > * gnu/local.mk (dist_patch_DATA): Register it here.
>> > ---
>> > As a follow-up to the master merge, the good, bad, and ugly plugins
>> > as well as gst-editing-services build with this simple trick.
>> >
>> >  gnu/local.mk                                  |  1 +
>> >  gnu/packages/gstreamer.scm                    |  3 ++-
>> >  .../gst-plugins-base-fix-broken-test.patch    | 22
>> > +++++++++++++++++++
>> >  3 files changed, 25 insertions(+), 1 deletion(-)
>> >  create mode 100644 gnu/packages/patches/gst-plugins-base-fix-
>> > broken-test.patch
>> >
>> > diff --git a/gnu/local.mk b/gnu/local.mk
>> > index 72b73761d8..1d7c5696f5 100644
>> > --- a/gnu/local.mk
>> > +++ b/gnu/local.mk
>> > @@ -1303,6 +1303,7 @@ dist_patch_DATA
>> > =                                         \
>> >    %D%/packages/patches/guile-present-coding.patch              \
>> >    %D%/packages/patches/guile-rsvg-pkgconfig.patch              \
>> >    %D%/packages/patches/guile-emacs-fix-configure.patch         \
>> > +  %D%/packages/patches/gst-plugins-base-fix-broken-
>> > test.patch          \
>> >    %D%/packages/patches/gtk2-fix-builder-test.patch             \
>> >    %D%/packages/patches/gtk2-harden-list-store.patch            \
>> >    %D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch       \
>>
>> I'm surprised this is needed, I hadn't encountered the failure. 
>> Perhaps it's a non-deterministic test?
> It is a deterministic failure as far as I see. Did you test with glib
> 2.73 (current master) or 2.76 (gnome-team)?
It was on staging, so 2.73 I think.
--
Thanks,
Maxim
L
L
Liliana Marie Prikler wrote on 30 Apr 2023 17:50
Re: [PATCH gnome-team 0/5] Merge master into gnome-team
(address . 62873-done@debbugs.gnu.org)
559bba3ac72824429c36622a2a5d8da7f8515b8c.camel@gmail.com
Am Samstag, dem 15.04.2023 um 23:39 +0200 schrieb Liliana Marie
Prikler:
Toggle quote (1 lines)
> please apologize the murder commit that is the merge itself :(
Since core-updates also got merged recently, I rebased the gnome-team
changes onto a semi-recent master and pushed that as a new gnome-team
branch. This new branch only contains older gnome-team changes with
adjustments made to account for things that were different on core-
updates; it no longer pulls in changes that were already committed to
staging or core-updates previously.

I'm closing this bug and will submit the GStreamer stuff in a new
series at a later time (unless someone beats me to it). Stay tuned!

Cheers
Closed
?