[PATCH core-updates] gnu: python-numpy: Skip failing tests on i686.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Kaelyn Takata
Owner
unassigned
Submitted by
Kaelyn Takata
Severity
normal

Debbugs page

Kaelyn Takata wrote 2 years ago
(address . guix-patches@gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
da820333bb827bc47847f445b5951a6461ee9e4a.1681502363.git.kaelyn.alexi@protonmail.com
* gnu/packages/python-xyz.scm (python-numpy): Skip failing tests on i686.
---
gnu/packages/python-xyz.scm | 10 ++++++++++
1 file changed, 10 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ae20f48ac6..26502a6d81 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -135,6 +135,7 @@
;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
;;; Copyright © 2023 Amade Nemes <nemesamade@gmail.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6300,6 +6301,15 @@ (define-public python-numpy
;; x86_64 CPUs such as the Core 2 Duo (see:
;; https://github.com/numpy/numpy/issues/22170).
"and not test_rint_big_int "
+ ;; The huge_array test is too large for 32-bit (see:
+ ;; https://bugs.gentoo.org/843599 and
+ ;; https://bugs.gentoo.org/846548).
+ ;; TestKind.test_all is a Fortran type failure
+ ;; that may be toolchain or environment related.
+ #$@(if (or (target-x86?) (target-arm32?))
+ `(" and not test_identityless_reduction_huge_array"
+ " and not (TestKind and test_all)")
+ '())
;; These tests seem to fail on machines without
;; an FPU is still under investigation upstream.
;; https://github.com/numpy/numpy/issues/20635

base-commit: 1e28aed2eb7049c8a40092071ac1ca1142869b6d
--
2.39.2
Andreas Enge wrote 2 years ago
Re: python-pytest on core-updates (was: i686 core-updates failure.)
(name . Kaelyn)(address . kaelyn.alexi@protonmail.com)
ZDqIZwMTQdCfag0A@jurong
Attachment: file
Andreas Enge wrote 2 years ago
(name . Kaelyn)(address . kaelyn.alexi@protonmail.com)
ZDsNxbv2vY67VQdC@jurong
Am Sat, Apr 15, 2023 at 01:20:07PM +0200 schrieb Andreas Enge:
Toggle quote (3 lines)
> The recent master/staging merge apparently broke python-pytest even on
> x86_64, see message below, which should be sorted out first.

With pytest repaired, your patch builds numpy successfully on both x86
architectures. Pushed, thanks again!

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62843@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62843
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help